American Megatrends, Inc.

VerifyBootReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

  • VerifyBoot.mak
  • VerifyBoot.sdl
Built on 13:34:30 04/05/14


VerifyBoot.mak

Description:


VerifyBoot.sdl

Description:
SDL file to define Verify Boot function


Functions in Alphabetical Order

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.


General Information


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2014 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: Verify Boot
Component Reference Name: VerifyBoot
Component Type: eModule
Release Date: 2014-01-03
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;

Dependencies
"Hash Data PEI - SHA256" eModule is needed for Verify Boot function.
Component Description:
This is used to create the Verify Boot BIOS Image.
This is a caption
Filename | Description
VerifyBoot.cif | CIF file for VerifyBoot eModule
VerifyBoot.mak | MAK file for the build process of the BIOS Image with VerifyBoot function support.
VerifyBootReleaseNotes.chm | CHM file for VerifyBoot eModule
VerifyBoot.sdl | Define the tokens, mak file and path used by VerifyBoot eModule
FusesConfiguration.bat | The batch file to update FUSE_FILE_OEM_KEY_HASH_1 field of FPF mirroring file.

ModulePart Name: Flash Manifest Generation Tool
ModulePart Description: Provide the tool to generate TXE Secure Boot Manifest images.
Filename | Description
FLAMInGO.exe | Intel TXE SBMGT (Secure Boot Manifest Generation Tool).
FLAMInGO.pdb | PDB file for FLAMInGO tool.
FpfMirrorNvarValues.txt | The input file of FusesConfiguration.bat to create FPF mirroring file.
SimpleSigner.exe | The tool used to create signature bin file with hash bin file and private key. The SimpleSigner tool only encode the key type PKCS#8. The tool is made by AMI TW.
ModulePart Name: Public Key File
ModulePart Description: The public and private key AMI used for test Verify Boot function.
Filename | Description
prikey.pem | Private key file used in Verify Boot function.
pubkey.pem | Public key file used in Verify Boot function.
Note:
AMI creates private and public key by using OpenSSL and following parameters:
=> req -batch -x509 -nodes -days 9000 -newkey rsa:2048 -keyout "prikey.pem" -out "pubkey.pem" -config "openssl.cnf"
AMI encodes the traditional private key by PKCS#8 by using OpenSSL and following parameters:
=> OpenSSL.exe pkcs8 -topk8 -in prikey.pem -out prikey-pk8.pem –nocrypt
Module Use Notice:
PASS_FPFMIRROR_FILE_TO_FITC: When it is set to 1, the FpfMirrorNvarValues.txt file (the file name is defined by FUSE_CONFIG_FILE token) created by FusesConfiguration.bat will be copied to RomImage folder. When it is set to 0, OEM needs to provide their own FPF mirroring file to FITC tool.
FD_PRE_BB_SIZE: It's not changeable for BYT-DM platform per Intel's design.
PUBLIC_KEY_FILE: OEM can clone this token for their own public key file.
PRIVATE_KEY_FILE: OEM can clone this token for their own privtae key file.
AMI Build Tools:
Tools Label: 5.004_BuildTools_22, Dated: 2013-10-09
Visual eBios: RSS.7.15.0244, Dated: 2013-10-09
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:
The first release.

© American Megatrends Inc.