American Megatrends, Inc.

MdeModulePkg

MdeModulePkg is a mandatory component for Aptio V projects. It is part of the Aptio V Framework (a collection of headers/libraries and a build system).

Copyright

Release Notes

© American Megatrends, Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2014 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


Release Notes - NDA Required

Component Information:
Component Title: MdeModulePkg

MdeModulePkg_12

Dependencies: MdePkg[07..]

Origin: TianoCore.org revision 15327.

Upgrade requirements: Pcd[02..]

PI 1.3 support:

CpuExceptionHandlerLib library class is updated to support new VectorHandoffInfo PPI

and to handle interrupts and exceptions differently.

SetupCpuExceptionHandlers function is replaced with the three new functions:

InitializeCpuExceptionHandlers, InitializeCpuInterruptHandlers,

RegisterCpuInterruptHandler

Support for a new PCD database format

gPcdDataBaseSignatureGuid is defined

New PcdShadowPeimOnS3Boot PCD.

The PCD is used by PEI Core to control loading of PEIM in memory

on S3 resume boot path.

NicIp4ConfigNvData.h: NIC_IP4_CONFIG_INFO field name is renamed

from 'Perment' to 'Permanent'

MdeModulePkg_11

Dependencies: None

Origin: TianoCore.org revision 14733.

Upgrade requirements: Pcd[02..]

Minor improvements

DxeNetLib(DxeNetLib.c): NetLibDefaultUnload function is updated to properly handle drivers

that produce multiple instances of the Driver Binding protocol.

UefiHiiLib(HiiLib.c):

Support for Name/Value varstore is added.

GCC compiler warnings are fixed.

SmmCorePerformanceLib: Improved input validation.

Make sure input buffer is in the addressable range.

NOTE: SmmCorePerformanceLib is part of the SMM Support eModule.

Updates to EDKII headers and libraries that are not used in Aptio V

5.004_MdeModulePkg_10

Dependencies: None

Origin: TianoCore.org revision 14165.

Upgrade requirements: Pcd[02..]

New library class: CpuExceptionHandlerLib

New event groups: gEventExitBootServicesFailedGuid and gConnectConInEventGuid

Updated Library Classes:

HiiLib: New function: HiiCreateGotoExOpCode

NetLib: New functions: NetDestroyLinkList, NetIsInHandleBuffer, NetLibIp6ToStr

SecurityManagementLib(PI 1.2.1 Support, Security2 Architectural protocol support is added):

New functions: RegisterSecurity2Handler, ExecuteSecurity2Handlers

MdeModulePkg.sdl cleanup:

IntelFrameworkModulePkg.LzmaCustomDecompressLib library instances

are moved into Foundation.sdl

PcdPei and PcdDxe FFS_FILE objects are moved to Pcd.sdl

MdeModulePkg.LockBoxNullLib is moved from Smm.sdl to MdeModulePkg.sdl

InfComponent and LibraryMapping for BasePlatformHookLibNull are added(EIP119084).

© American Megatrends Inc.