BayTrail Release Notes: Main Page

BayTrail Release Notes
  • Main Page
BayTrail Release Notes Documentation
Release Notes - NDA Required

BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 11/17/17
Source Control Label: 5.010_VEB_0ACCT032
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF048
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0F30679909
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_152_045
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. System May Experience Failure of LPC, USB 2.0 And SD Card Circuitry in Embedded And Industrial Use Conditions. The following tokens can be enabled to extend the LPC circuit life by clock gating when appropriate:
    1. LPC_CIRCUIT_LIFE_EXTENSION_WA: Main switch to enable the LPC circuit life extension workaround by clock gating when appropriate. This is based on the erratum draft published 2/16/17.
    2. LPC_WA_ENABLE_LPC_CLKRUN: Enable LPC CLKRUN# by setting LPC Control Register ILB offset 84h[2] to 1b.
    3. LPC_WA_SET_SERIRQ_QUIET_MODE: Set LPC SCNT (SERIRQ Control) Mode to Quiet Mode in SCNT register ILB offset 10h[7] to 0b.
    4. LPC_WA_DISABLE_SERIRQ: If SERIRQ is unused, set Other Interrupt Control Register ILB offset 60h[12] to 0b.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiModulePkg\CSM\CsmHwInfo.c" | Update it for EIP324741, EIP184371
"AmiModulePkg\FlashDriver\Flash.c" | EIP341497 - [Bay Trail_Client] SA50037 - BIOS update failure vulnerability.
"AmiModulePkg\PCI\PciBus.inf" | EIP357397 - [SAx0039][FSRT] Security Disclosures from Intel
"AmiModulePkg\Bds\Bds.sdl" | EIP357397 - [SAx0039][FSRT] Security Disclosures from Intel
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" 1. EIP357393 - [SAx0039] SPI opcode Security Vulnerability
2. EIP355841 - [Bay Trail_Client] Some physical memory address is cleared to 0 after S3 resume.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInitDxe.inf" | EIP357393 - [SAx0039] SPI opcode Security Vulnerability
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | EIP357393 - [SAx0039] SPI opcode Security Vulnerability
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchScc.c" | EIP314665
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP320598
"AmiValleyViewCpuPkg\Microcode\M0130679908.PDB" | BayTrail-I uCode.
"AmiValleyViewCpuPkg\Microcode\M0F30679909.PDB" | BayTrail-I uCode.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
Updated to M0F30679909 microcode
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP #355841 [Bay Trail_Client] Some physical memory address is cleared to 0 after S3 resume.
EIP #357393 [SAx0039] SPI opcode Security Vulnerability
EIP #358409 [SAx0039][5.004_Flash_14/11/10/09/08] SPI security update
EIP #357397 [SAx0039][FSRT] Security Disclosures from Intel
EIP #365588 REF-46694.V5: BIOS Basic Test failed
EIP #373470 Duplicate CRST table
Files changed for EIP fixes:
EIP #355841 - SbDxe.c
EIP #357393 - PchInitDxe.inf, PchInit.c
EIP #358409 - SPIFlash.c
EIP #357397 - PciBus.c
EIP #365588 - Crb.sdl
EIP #373470 - Crb.sdl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027
5.010_VEB_0ACCT028
5.010_VEB_0ACCT029
5.010_VEB_0ACCT030
5.010_VEB_0ACCT031

© American Megatrends Inc.

Generated on Mon Nov 13 2017 09:07:06 for BayTrail Release Notes by doxygen 1.8.10


Unit Tests

Platform Unit Tests

1. Installed and booted Windows 8 64-bit legacy
2. Installed and booted Windows 8 32-bit legacy
3. Installed and booted Fedora 18 64-bit legacy
4. BIOS update via EFI Shell

© American Megatrends Inc.


Unit Tests

Platform Unit Tests

NOTE: All tests performed on BayleyBay Fab 3 with BayTrail M/D SoC.
OS Installations:
Operating System | Install/Boot | Shutdown | Notes
Windows 7 32-bit legacy | Pass | Pass
Windows 7 64-bit legacy | Pass | Pass
WES 7 32-bit legacy Pass* [1] Pass* [2] 1. "Application Compatibility" template used
2. Restarts after shutdown
WES 7 64-bit legacy Pass* [1] Pass* [2] 1. "Application Compatibility" template used
2. Restarts after shutdown
WEC 7 32-bit N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 32-bit legacy | Pass | Pass* [1] | 1. Restarts after shutdown
Windows 8 64-bit legacy | Pass | Pass* [1] | 1. Restarts after shutdown
WES 8 32-bit legacy Pass* [1] Pass* [2] 1. "Template Device Retail" template used
2. Restarts after shutdown
WES 8 64-bit legacy Pass* [1] Pass* [2] 1. "Template Device Retail" template used
2. Restarts after shutdown
Linux Tizen IVI | N/A | N/A | Not tested.
Fedora 18 64-bit legacy Pass* [1] Fail* [2] 1. USB devices not working. PS/2 KB/MS used.
2. Hangs in OS on Shutdown.
Linux Yocto | N/A | N/A | Not tested. Will test once BSP is provided.
WindRiver Linux | N/A | N/A | Not tested. Will test once BSP is provided.
VxWorks | N/A | N/A | Not tested. Will test once BSP is provided.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.04.00
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.04.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.04.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot to PCIe device | Fail | Unable to legacy boot with RAID card attached
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass
Power Management:
Test | Result | Notes
CPU ACPI S3 | Fail | Enters S3 sucessfully and resumes to OS, but then BSOD occurs.
CPU ACPI C States | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Notes
Windows 7 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 7 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 7 32-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WES 7 64-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WEC 7 32-bit N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 8 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 8 32-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
WES 8 64-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
Linux Tizen IVI N/A N/A N/A N/A N/A Not tested.
Will test once legacy vBIOS is provided for IGD.
Fedora 18 64-bit legacy Pass Pass Pass Fail Pass Resumes in BIOS but doesn't repost video.
Cannot wake from USB keyboard.
Linux Yocto N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
WindRiver Linux N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.04.00
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.04.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.04.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot to PCIe device | Fail | Unable to legacy boot with RAID card attached
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Notes
Windows 7 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 7 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 7 32-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WES 7 64-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WEC 7 32-bit N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 32-bit UEFI Pass Pass Pass Fail Pass Used I.G.D. with UEFI GOP driver and USB DVD.
Resumes from S3 but doesn't repost video.
Windows 8 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 8 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 8 32-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
WES 8 64-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
Linux Tizen IVI N/A N/A N/A N/A N/A Not tested.
Will test once legacy vBIOS is provided for IGD.
Fedora 18 64-bit legacy Pass Pass Pass Pass Fail Resumes from S3 but video is not working properly.
Cannot wake from USB keyboard.
Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Hibernate fails to shut down completely from OS.
Linux Yocto N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
WindRiver Linux N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.04.00
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.04.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.04.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot to PCIe device | Fail | Unable to legacy boot with RAID card attached
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Notes
Windows 7 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 7 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 7 32-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WES 7 64-bit legacy | Pass | Pass | Pass | Fail | N/A | "Application Compatibility" template used
WEC 7 32-bit N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI Pass Pass Pass N/A Pass Used I.G.D. with UEFI GOP driver and USB DVD.
No 64-bit GOP driver, didn't test S3.
Windows 8 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 8 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 8 32-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
WES 8 64-bit legacy | Pass | Pass | Pass | Pass | N/A | "Template Device Retail" template used
Linux Tizen IVI N/A N/A N/A N/A N/A Not tested.
Will test once legacy vBIOS is provided for IGD.
Fedora 18 64-bit legacy Pass Pass Pass Fail Fail Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
S3/S4 fail to shut down completely from OS. No OS drivers for Fedora.
Linux Yocto N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
WindRiver Linux N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
EFI Shell on eMMMC | Pass | N/A | N/A | N/A | N/A | Filesystem seen in Shell.
DOS on eMMC | Fail | N/A | N/A | N/A | N/A | Cannot format /s on eMMC
EFI Shell on SD Card | Pass | N/A | N/A | N/A | N/A | Filesystem seen in Shell.
DOS on SD Card Pass N/A N/A N/A N/A Cannot format /s on SD card.
Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.04.00
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.04.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.04.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot to PCIe device | Fail | Unable to legacy boot with RAID card attached
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Notes
Windows 7 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 7 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI | Pass | Pass | Pass | Pass | Pass
Windows 8 32-bit legacy | Pass | Pass | Pass | Pass | Pass
Windows 8 64-bit legacy | Pass | Pass | Pass | Pass | Pass
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI N/A N/A N/A N/A N/A Not tested.
Will test once legacy vBIOS is provided for IGD.
Fedora 18 64-bit legacy Pass Pass Pass N/A N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
S3/S4 resumed to OS but video wasn't reposted every time.
No OS graphics driver for Fedora.
Linux Yocto N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
WindRiver Linux N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI on eMMMC | Pass | Pass | Pass | N/A | N/A
DOS on SD Card | Pass | N/A | N/A | N/A | N/A | Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.05.00
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.05.00
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.05.00
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 7 64-bit legacy Pass Pass Pass Pass Fail Bakersport SATA HDD
SATA DVD
PCIe graphics card
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
Windows 8 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 8 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once legacy vBIOS is provided for IGD.
Fedora 18 64-bit legacy Pass Pass Pass N/A N/A Bayley Bay SATA HDD
SATA DVD
PCIe graphics card
USB MS/KB
PS/2 MS/KB
4GB PC3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
S3/S4 resumed to OS but video wasn't reposted every time.
No OS graphics driver for Fedora.
Linux Yocto N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI on eMMMC Pass Pass Pass N/A N/A Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
DOS on SD Card | Pass | N/A | N/A | N/A | N/A | Bakersport | N/A | N/A | Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.05.01
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.05.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.05.01
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Fail Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 7 64-bit legacy Pass Pass Pass Pass Fail Bakersport SATA HDD
SATA DVD
PCIe graphics card
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
Windows 8 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 8 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Tested with BayTrail-I B0 stepping due to known issues.
Legacy boot on a USB key.
Timesys Fedora 18 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Tested with BayTrail-I B0 stepping due to known issues.
Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI on eMMMC Pass Pass Pass N/A N/A Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 3.05.01
Flash via AFUDOS in DOS | Pass | AFUDOS version: 3.05.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 3.05.01
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Fail Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 7 64-bit legacy Pass Pass Pass Pass Fail Bakersport SATA HDD
SATA DVD
PCIe graphics card
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
Windows 8 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.1.3266
Windows 8 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Tested with single CPU core config due to known issues.
Legacy boot on a USB key.
Timesys Fedora 18 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Tested with single CPU core config due to known issues.
Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI on eMMMC Pass Pass Pass N/A N/A Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 9.4.4.1006
Internal Graphics: 15.33.64.3275
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.1.3266
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.64.3374
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.7.64.3366
Windows 8 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.1.3266
Windows 8 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.7.64.3366
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8 64-bit UEFI on eMMMC Pass Pass Pass N/A N/A Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: 10.0.5
Internal Graphics: 15.33.7.64.3366
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode
Windows 7 | Windows 7 | PCI Mode
Windows 8 | Windows 8.x | ACPI Mode
Windows 8.1 | Windows 8.x | ACPI Mode

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.1.3266
LPSS: BYT_IO_WIN7_BETA_V1.0 (run in CMD "bcdedit /set testsigning on")
TXE: N/A
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.64.3374
LPSS: BYT_IO_WIN7_BETA_V1.0 (run in CMD "bcdedit /set testsigning on")
TXE: Bay Trail-MD Intel(R) TXE FW 3MB SKU 1.0.2.1060 Windows 7 64-bit Beta
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.7.64.3366
TXE: Bay_Trail_MD_Win8.1_64_PV_Intel(R)_TXE_FW_1.0.2.1060
GPIO: GPIO_WW46
I2C: I2C_WW46
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.7.3366
TXE: Bay_Trail_MD_Win8.1_64_PV_Intel(R)_TXE_FW_1.0.2.1060
GPIO: GPIO_WW46
I2C: I2C_WW46
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.7.64.3366
TXE: Bay_Trail_MD_Win8.1_64_PV_Intel(R)_TXE_FW_1.0.2.1060
GPIO: GPIO_WW46
I2C: I2C_WW46
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass N/A N/A Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006 and ChipsetINF_Beta_10.0.5
Internal Graphics: 15.33.7.64.3366
TXE: Bay_Trail_MD_Win8.1_64_PV_Intel(R)_TXE_FW_1.0.2.1060
GPIO: GPIO_WW46
I2C: I2C_WW46
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI/XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI/XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: ChipsetINF_Beta_10.0.12
Internal Graphics: 15.33.1.3266
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v1.0
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: ChipsetINF_Beta_10.0.12
Internal Graphics: 15.33.64.3374
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v1.0
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | EHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: ChipsetINF_Beta_10.0.12
Internal Graphics: 15.33.1.3266
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v1.0
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: ChipsetINF_Beta_10.0.12
Internal Graphics: 15.33.64.3374
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v1.0
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Linux Yocto Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Legacy boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.7.64.3366
TXE: Bay Trail-MD Intel(R) TXE FW 1.0.4.1089 HF4
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 36.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 37.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux 9.0.2 "Dylan" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 36.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 37.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Legacy boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux 9.0.2 "Dylan" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 36.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: Chipset_10.0.14
Internal Graphics: 37.15.0.1073
LPSS: Intel Atom E3800 Win7 IO Drivers_Gold_v2.0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A UEFI boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.05.03
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.05.03
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.05.03
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 36.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 37.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A UEFI boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
VxWorks BIOS Setup configuration:
  1. ACPI Auto Configuration: Enabled
  2. Console Redirection: Disabled
  3. CSM Support: Enabled
    • Boot Option Filter: UEFI and Legacy
    • Video: Legacy Only
  4. Chipset USB Configuration
    • XHCI Mode: Disabled
    • USB 2.0 (EHCI) Support: Enabled
    • USB OTG Support: Disabled
    • USB VBUS: On
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.06.01
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.06.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.06.01
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI or XHCI Smart Auto
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 36.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 37.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A UEFI boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
VxWorks BIOS Setup configuration:
  1. ACPI Auto Configuration: Enabled
  2. Console Redirection: Disabled
  3. CSM Support: Enabled
    • Boot Option Filter: UEFI and Legacy
    • Video: Legacy Only
  4. Chipset USB Configuration
    • XHCI Mode: Disabled
    • USB 2.0 (EHCI) Support: Enabled
    • USB OTG Support: Disabled
    • USB VBUS: On
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.07.01
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.07.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.07.01
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI or XHCI Smart Auto
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 36.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 37.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) Pass N/A N/A N/A N/A Bayley Bay USB key
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A UEFI boot on a USB key.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" Pass N/A N/A N/A N/A Bakersport USB key
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A UEFI boot on a USB key.
WindRiver Linux N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
VxWorks N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
VxWorks BIOS Setup configuration:
  1. ACPI Auto Configuration: Enabled
  2. Console Redirection: Disabled
  3. CSM Support: Enabled
    • Boot Option Filter: UEFI and Legacy
    • Video: Legacy Only
  4. Chipset USB Configuration
    • XHCI Mode: Disabled
    • USB 2.0 (EHCI) Support: Enabled
    • USB OTG Support: Disabled
    • USB VBUS: On
Legacy Windows 7 64-bit on eMMC:
Board Configuration:
  1. CRB: Bakersport Rev B
  2. SOC: BayTrail-I E3845 D0
  3. Setup Questions:
    • OS Selection = Windows 7
    • LPSS & SCC Device Mode = PCI Mode
    • XHCI Mode = Smart Auto
NOTE: To create the legacy Windows 7 64-bit USB installer see EIP 227381 or contact your AMI representative.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell | Pass | AFUEFI version: 5.07.01
Flash via AFUDOS in DOS | Pass | AFUDOS version: 5.07.01
Flash via AFUWIN in Windows | Pass | AFUWIN version: 5.07.01
Memory testing:
Test | Result | Notes
Verify memory channel 0 only | Pass | 2GB DDR3 SK hynix 1066 SODIMM
Verify memory channel 1 only Fail* 2GB DDR3 SK hynix 1066 SODIMM
* Not supported by platform
Verify memory channel 0 and 1 | Pass | 2x 2GB DDR3 SK hynix 1066 SODIMM
Verify 4GB and above | N/A | Not tested
PCIe testing:
Test | Result | Notes
Verify PCIe slot 1 | Pass | Radeon HD5450 w/ x16 to x4 PCIe Adapter
Verify PCIe slot 3 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify PCIe slot 4 | Pass | Radeon HD5450 w/ x16 to x1 PCIe Adapter
Verify boot with PCIe storage card | Pass
USB testing:
Test | Result | Notes
Boot to DOS | Pass
USB keyboard support in BIOS setup/EFI Shell/DOS | Pass


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI or XHCI Smart Auto
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 36.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: SetupChipset_10.0.13_PV
Internal Graphics: 37.15.0.1073
LPSS: Intel_Atom_E3800_Processor_Win7_IO_Drivers_MR1_v4_0
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bakersport SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bakersport eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: BYT-I_DUAL_BOOT_TXE_KIT_RELEASE_1.1.0.1089
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bakersport SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
PS/2 MS/KB
2GB EP3L memory 		N/A Created DOS SD Card via USB SD card adapter.
VxWorks BIOS Setup configuration:
  1. ACPI Auto Configuration: Enabled
  2. Console Redirection: Disabled
  3. CSM Support: Enabled
    • Boot Option Filter: UEFI and Legacy
    • Video: Legacy Only
  4. Chipset USB Configuration
    • XHCI Mode: Disabled
    • USB 2.0 (EHCI) Support: Enabled
    • USB OTG Support: Disabled
    • USB VBUS: On
Legacy Windows 7 64-bit on eMMC:
Board Configuration:
  1. CRB: Bakersport Rev B
  2. SOC: BayTrail-I E3845 D0
  3. Setup Questions:
    • OS Selection = Windows 7
    • LPSS & SCC Device Mode = PCI Mode
    • XHCI Mode = Smart Auto
NOTE: To create the legacy Windows 7 64-bit USB installer see EIP 227381 or contact your AMI representative.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell (AFU /p /b /n /me) | Pass | AFUEFI version: 5.08.02.1189


Unit Tests

Platform Unit Tests

OS Installations:
NOTE: The following setup questions need to be set for the correct OS driver configuration:

Operating System | OS Selection | LPSS & SCC Device Mode | USB
Windows 7 | Windows 7 | PCI Mode | EHCI or XHCI Smart Auto
Windows 8 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 8.1 | Windows 8.x | ACPI Mode | EHCI or XHCI
Windows 10 x64 | Windows 8.x | ACPI Mode | EHCI or XHCI
Timesys Fedora 18 | Windows 7 | PCI Mode | XHCI
Android | Android | ACPI Mode | XHCI

Operating System | Install/Boot | Shutdown | Restart | S3 (x2) | S4 (x2) | Board | Configuration | Driver Versions | Notes
Windows 7 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: chipset_10.1.1.38_nda
Internal Graphics: Installer-Release-32-bit-prod-15.2-1243
LPSS: 334397-002 Intel Atom E3800 Win7 IO Drivers MR4_Non Secure
TXE: TXEI_1.1.5.1162
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
Windows 7 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: chipset_10.1.1.38_nda
Internal Graphics: Installer-Release-64-bit-prod-15.2-1243
LPSS: 334397-002 Intel Atom E3800 Win7 IO Drivers MR4_Non Secure
TXE: TXEI_1.1.5.1162
XHCI: Intel(R) USB 3.0 eXtensible Host Controller Driver - Skylake Beta 4.0.0.18
WES 7 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 7 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WEC 7 32-bit N/A N/A N/A N/A N/A N/A N/A N/A Not tested.
Will test once BSP is provided.
Windows 8.1 64-bit UEFI Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: TXEI_1.1.5.1162
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 32-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.3496
TXE: TXEI_1.1.5.1162
GPIO: N/A
MBI: MBI_PV_Win8_1_WW51
Windows 8.1 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: TXEI_1.1.5.1162
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
Windows 10 64-bit UEFI Pass Pass Pass Pass Pass Bayley Bay SATA HDD
SATA DVD
Onboard UEFI graphics
USB MS/KB
4GB PC3L memory 		Chipset: chipset_10.1.1.38_nda
Internal Graphics: win64_15.33.44.64.4491
HD Audio: MS default
USB3: MS default
LPSS: IntelSerialIo_Win10_64b_99.16.55518
TXE: TXEI_1.1.5.1162
WES 8 32-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
WES 8 64-bit legacy | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Linux Tizen IVI (tizen-3.0.m14.3-ivi_20141028.3_ivi-efi-x86_64) | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Timesys Fedora 18 Gold 64-bit legacy Pass Pass Pass Pass Pass Bayley Bay USB key
SATA HDD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Press "Alt" in power menu to see "Suspend".
"systemctl hibernate" in terminal for hibernate.
Yocto Linux (valleyisland-2.0-dizzy-1.7)" | N/A | N/A | N/A | N/A | N/A | N/A | N/A | N/A | Not tested.
Windows 8.1 64-bit UEFI on eMMMC Pass Pass Pass Pass Pass Bayley Bay eMMC
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		Chipset: infinst_autol_9.4.4.1006
Internal Graphics: 15.33.18.64.3496
TXE: TXEI_1.1.5.1162
GPIO: Intel(R)_Serial_IO_Installer_WW06
MBI: MBI_PV_Win8_1_WW51
DOS on SD Card Pass N/A N/A N/A N/A Bayley Bay SD card
SATA DVD
Onboard legacy graphics
USB MS/KB
4GB PC3L memory 		N/A Created DOS SD Card via USB SD card adapter.
VxWorks BIOS Setup configuration:
  1. ACPI Auto Configuration: Enabled
  2. Console Redirection: Disabled
  3. CSM Support: Enabled
    • Boot Option Filter: UEFI and Legacy
    • Video: Legacy Only
  4. Chipset USB Configuration
    • XHCI Mode: Disabled
    • USB 2.0 (EHCI) Support: Enabled
    • USB OTG Support: Disabled
    • USB VBUS: On
Legacy Windows 7 64-bit on eMMC:
Board Configuration:
  1. CRB: Bakersport Rev B
  2. SOC: BayTrail-I E3845 D0
  3. Setup Questions:
    • OS Selection = Windows 7
    • LPSS & SCC Device Mode = PCI Mode
    • XHCI Mode = Smart Auto
NOTE: To create the legacy Windows 7 64-bit USB installer see EIP 227381 or contact your AMI representative.
BIOS Update:
Test | Result | Notes
Flash via AFUEFI in EFI Shell (AFU /p /b /n /me) | Pass | AFUEFI version: 5.08.02.1189


Release Notes - NDA Required

BIOS Information:
AMI BIOS Core: 5.007_Core
Release Date: 5/3/2013
Source Control Label: 5.007_VEB_0ACCT000
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: (BETA)5.007_VEB_1AREF002c
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I
CPU ID: TBD, Microcode Version: TBD
Memory: LPDDR3, Frequency: 1066
GOP: None
CoreVersion 5.007_Core
CPU version: 5.007_AmiValleyViewCpuPkg_004b
AmiChipsetModule version: 5.007_ValleyviewDM_002
NorthCluster version: 5.007_ValleyviewDM_NB_002a
SouthCluster: version 5.007_ValleyviewDM_SB_002a
Vlv2DeviceRefCodePkg version 5.007_Vlv2DeviceRefCodeDM_002a
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List: (Red letter change on this release)
File Name | Description
"IA32FamilyCpuPkg\SecCore\Ia32\ResetVec.asm16" | For the BayTrail setting.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCryptoPkg\AmiCryptoPkg.dec" | For Buid error
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | For Implement flash the FV_PRE_BB_BLOCK
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Uhcd.c" | For Boot to OS USB can't work.
"AmiModulePkg\Usb\Rt\Xhci.h" | For USB can't build.
"AmiModulePkg\Usb\Rt\Xhci.c" | For USB can't build.
"AmiModulePkg\Usb\UsbBus.c" | For USB can't build.
"AmiCompatibilityPkg\Board\OEMPort.c" | For remove the Recovery_SUPPORT can't build.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiCompatibilityPkg\Include\FastBoot.h" | For add the PostTime driver can't build.
"AmiCompatibilityPkg\Include\Protocol\FastBootProtocol.h" | For add the PostTime driver can't build.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\AmiCompatibilityPkg.dec" | For Build error.
"IA32FamilyCpuPkg\IA32FamilyCpuPkg.dec" | Support Intel PPM.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"AmiModulePkg\AmiModulePkg.dec" | Fix building error after adding RsdpPlus module.
"AmiModulePkg\Bds\Bds.sdl" | Fix EIP118203 problem.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMI Debug Rx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 4.6.2_AMIDebugRx_2.02.0038
eModule Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;4.6.2_AMIDebugRx_2.02.0038

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | On
AMI Build Tools:
Tools Label: 5.004_BuildTools_18, Dated: 2013-02-28
Visual eBios: RSS.7.15.0180, Dated: 2013-02-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 0.60
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.70
Intel GOP Drivers: 7.0.1020
Intel TXE version: 1.0.0.1023
Reference or 3rd Party code updated in this Release:
None
Files changed in the Reference or 3rd Party Code:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
121724 | Boot with add-on VGA card to launch non-EFI OS
122582 | Install and validate OS for BIOS release
122583 | Perform static code analysis on BayleyBay-I source
122586 | Prepare BayleyBay-I 0ACCT000 release
Files changed for EIP fixes:
EIP Ref. # Files Changed
121724
  • AmiChipsetModulePkg\NB\NbSetup\Nb.sd
  • AmiChipsetModulePkg\SB\SbInit\SbDxe.c
  • AmiChipsetModulePkg\SB\SbInit\SbDxe.inf
  • AmiModulePkg\ACPI\AcpiCore.c
  • AmiModulePkg\PCI\PciBus.c
  • AmiModulePkg\PCI\PciBus.sd
  • AmiModulePkg\PCI\PciHostBridge.c
  • BayTrailPkg\Crb.sdl
  • Vlv2DeviceRefCodePkg\Wrapper\PlatformDxe\Platform.c
122582
  • None
122583
  • None
122586
  • ReleaseNotes.chm
Known issues and limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. The system fails to resume from S3.
3. Unable to boot legacy Windows with a Matrox G550 PCIe card.
4. Incorrect text in Setup for COM settings and boot device selection.
5. BSOD occurs when installing Windows 7 (0xA5: BIOS not fully ACPI compliant)
6. USB KB/MS don't work in Fedora 18 x64.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
Initial Check-in


BIOS Information:
AMI BIOS Core: 5.007_Core
Release Date: 5/17/2013
Source Control Label: 5.007_VEB_0ACCT001
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: (BETA)5.007_VEB_1AREF003
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I
CPU ID: TBD, Microcode Version: TBD
Memory: LPDDR3, Frequency: 1066
x32 GOP Driver: 7.0.1022
x64 GOP Driver: 7.0.1020
CoreVersion 5.007_Core
CPU version: 5.007_AmiValleyViewCpuPkg_007
AmiChipsetModule version: 5.007_ValleyviewDM_002
NorthCluster version: 5.007_ValleyviewDM_NB_003
SouthCluster: version 5.007_ValleyviewDM_SB_003
Vlv2DeviceRefCodePkg version 5.007_Vlv2DeviceRefCodeDM_003a
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:
File Name | Description
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | For Implement flash the FV_PRE_BB_BLOCK
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Uhcd.c" | For Boot to OS USB can't work.
"AmiModulePkg\Usb\Rt\Xhci.h" | For USB can't build.
"AmiModulePkg\Usb\Rt\Xhci.c" | For USB can't build.
"AmiModulePkg\Usb\UsbBus.c" | For USB can't build.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"AmiModulePkg\AmiModulePkg.dec" | Fix building error after adding RsdpPlus module.
"AmiModulePkg\Bds\Bds.sdl" | Fix EIP118203 problem.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Fix build error after module update.
"AmiModulePkg\AHCI\Ahci.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmBlockIo\CsmBlockIo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmVideo\CsmVideo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmDxe.inf" | Fix build error after module update.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.inf" | Fix build error after module update.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix build error after module update.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Smm\PpmInitialization.c" | Modified p-state table for Win7 BSOD.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMI Debug Rx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 4.6.2_AMIDebugRx_2.02.0038
eModule Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;4.6.2_AMIDebugRx_2.02.0038

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | On
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 0.60
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.7.1
Intel x32 GOP Drivers: 7.0.1022
Intel x64 GOP Drivers: 7.0.1020
Intel TXE version: 1.0.0.1028
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.7.1
Intel x32 GOP Drivers: 7.0.1022
Intel TXE version: 1.0.0.1028
Files changed in the Reference or 3rd Party Code:
See Vlv2DeviceRefCodePkg\ReleaseNotes.chm
Modules update from last label:
AmiCompatibilityPkg - 5.004_AmiCompatibilityPkg_15
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_007
AmiChipsetModulePkg - 5.007_ValleyviewDM_003
Intel-NorthCluster Client - 5.007_ValleyviewDM_NB_003
Intel-SouthCluster Client - 5.007_ValleyviewDM_SB_003
Vlv2DeviceRefCodePkg Client - 5.007_Vlv2DeviceRefCodeDM_003a
Vlv2DeviceRefCodePkg Client - 5.007_Vlv2DeviceRefCodeDM_003a
AmiCryptoPkg - 5_004.CryptoPkg_012
Modules added to this label:
IA32FamilyCpuPkg - 5.007_IA32FamilyCpuPkg_001
Modules removed from last label:
IA32FamilyCpuPkg - 5.004_IA32FamilyCpuPkg_04
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
122953 | BSOD 0xA5: The BIOS in this system is not fully ACPI compliant
123210 | Integrate Bay Trail-I Framework BIOS Reference Code Alpha 0.7.1
123250 | Incorrect text in Setup
123486 | Embed legacy Option ROM for IGD
123916 | Regions not protect (reserved) for OS
123952 | Win7 does not boot with all 4 CPU threads
124113 | Prepare BayleyBay-I 0ACCT001 release
124115 | CSM build errors when updating to 5.004_AmiCompatibilityPkg_15
124239 | OS installation & validation for 0ACCT001 release
Files changed for EIP fixes:
EIP Ref. # Files Changed
122953
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
123210
  • Module update
123250
  • None
123486
  • None
123916
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
123952
  • AmiModulePkg\PCI\PciRootBridge.inf
  • CRB.sdl
124113
  • Release Notes.chm
  • CRB.sdl
124115
  • AmiModulePkg\CSM\CsmBlockIo\CsmBlockIo.inf
  • AmiModulePkg\CSM\CsmVideo\CsmVideo.inf
  • AmiModulePkg\CSM\CsmDxe.inf
124239
  • None
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. This BIOS was tested on Bayley Fab 3 with BayTrail M/D SoC.
Known issues in this label:
1. A BSOD occurs after resuming from S3.
2. Unable to boot legacy Windows with a Matrox G550 PCIe card.
3. USB KB/MS don't work in Fedora 18 x64.
4. After updating FRC ver 0.7.1 the system hangs at checkpoint 0x2A with A0 on soft resets.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 6/17/2013
Source Control Label: 5.008_VEB_0ACCT002
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: (INT)5.008_VEB_1AREF004
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I, Stepping: B0
CPU ID: 30672, Microcode Version: M023067220B
Memory: LPDDR3, Frequency: 1066
x32 GOP Driver: 7.0.1022
x64 GOP Driver: 7.0.1020
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_008
AmiChipsetModule version: 5.008_ValleyviewDM_004
NorthCluster version: 5.007_ValleyviewDM_NB_004a
SouthCluster: version 5.007_ValleyviewDM_SB_004b
Vlv2DeviceRefCodePkg version 5.007_Vlv2DeviceRefCodeDM_004b
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:
File Name | Description
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | For Implement flash the FV_PRE_BB_BLOCK
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Uhcd.c" | For Boot to OS USB can't work.
"AmiModulePkg\Usb\Rt\Xhci.h" | For USB can't build.
"AmiModulePkg\Usb\Rt\Xhci.c" | For USB can't build.
"AmiModulePkg\Usb\UsbBus.c" | For USB can't build.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Fix build error after module update.
"AmiModulePkg\AHCI\Ahci.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmBlockIo\CsmBlockIo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmVideo\CsmVideo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmDxe.inf" | Fix build error after module update.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.inf" | Fix build error after module update.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix build error after module update.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"AmiCryptoPkg\CryptoProtocols\CryptoDxe.c" | Fix building error.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.c" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiPkg\Configuration\FdfRules.txt" | Fix building error.
AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | Fix for USB not working after S3 resume in Win7.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMI Debug Rx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 4.6.2_AMIDebugRx_2.02.0038
eModule Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;4.6.2_AMIDebugRx_2.02.0038

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | On
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 0.7
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.8.0
Intel x32 GOP Drivers: 7.0.1022
Intel x64 GOP Drivers: 7.0.1020
Intel TXE version: 1.0.0.1028
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.8.0
Modules update from last label:
eCore Module - 5.008_Core
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_008
AmiChipsetModulePkg - 5.008_ValleyviewDM_004
Intel-NorthCluster Client - 5.007_ValleyviewDM_NB_004a
Intel-SouthCluster Client - 5.007_ValleyviewDM_SB_004b
Vlv2DeviceRefCodePkg Client - 5.007_Vlv2DeviceRefCodeDM_004b
RsdpPlus - 5.004_RsdpPlus_01
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
124603 | Windows 7 BSOD with 15 p-state entries
124737 | Down port ACPI 5.0 specific code to support Windows 7
123465 | USB devices not detected in Linux
125634 | USB device not working in setup and shell after enabling XHCI
126044 | USB not working after S3 resume in Windows 7
Files changed for EIP fixes:
EIP Ref. # Files Changed
124603
  • AmiValleyViewCpuPkg\Microcode\M0230671117.PDB
124737
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
123465
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c
125634
  • AmiModulePkg\Usb\Rt\Xhci.c
  • AmiModulePkg\Usb\Rt\UsbRt.mak
  • AmiModulePkg\Usb\UsbSb.c
126044
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Onboard graphics only support EFI video, not legacy. Use an offboard PCIe graphics card for booting legacy OS.
3. Wake from USB is not currently supported in Windows 7.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System hangs at checkpoint 0x31 in single DIMM configuration.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 7/19/2013
Source Control Label: 5.008_VEB_0ACCT003
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.008_VEB_1AREF006
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I, Stepping: B0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213
Memory: LPDDR3, Frequency: 1066
x32 GOP Driver: 7.0.1022
x64 GOP Driver: 7.0.1020
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_008
AmiChipsetModule version: 5.008_ValleyviewDM_006
NorthCluster version: 5.008_ValleyviewDM_NB_006
SouthCluster: version 5.008_ValleyviewDM_SB_006
Vlv2DeviceRefCodePkg version 5.008_Vlv2DeviceRefCodeDM_005
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:
File Name | Description
"Release Notes.chm" | This file.
"AmiModulePkg\AHCI\Ahci.inf" | Fix building error.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Fix building error.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Uhcd.c" | For Boot to OS USB can't work.
"AmiModulePkg\Usb\Rt\Xhci.h" | For USB can't build.
"AmiModulePkg\Usb\Rt\Xhci.c" | For USB can't build.
"AmiModulePkg\Usb\UsbBus.c" | For USB can't build.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\CSM\CsmBlockIo\CsmBlockIo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmVideo\CsmVideo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmDxe.inf" | Fix build error after module update.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.inf" | Fix build error after module update.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.c" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\EcPs2Kbd\EcPs2Kbd.inf" | For gEfiDevicePathProtocolGuid
"AmiCryptoPkg\CryptoProtocols\CryptoDxe.c" | Fix building error.
"AmiPkg\Configuration\FdfRules.txt" | Fix hang at CheckPoint 0x49.
"AmiCompatibilityPkg\CmosManager\Template.ssp" | For EIP125551
"AmiModulePkg\Console\GraphicsConsole\GraphicsConsole.c" | First boot always hang at checkpoint 0x97
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"MdeModulePkg\Core\Pei\PeiMain\PeiMain.c" | For EIP126885
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | Support Capsule
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | Add DTS setup item
"AmiValleyViewCpuPkg\Setup\Cpu.uni" | Add DTS setup strings
AmiChipsetModulePkg\SB\AcpiModeEnable\AcpiModeEnable.c" | Didn't clear SLP_SMI_EN - EIP128356
AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | Fix for USB not working after S3 resume in Win7.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | For EIP127623 - hang at 0x99

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMI Debug Rx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 4.6.2_AMIDebugRx_2.02.0038
eModule Source Control Location: SS: Alaska;$/Alaska/BIN/Modules/AMIDebugRx;4.6.2_AMIDebugRx_2.02.0038

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | On
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 0.7
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.9.0
Intel x32 GOP Drivers: 7.0.1022
Intel x64 GOP Drivers: 7.0.1020
Intel TXE version: 1.0.0.1043
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 0.9.0
Modules update from last label:
ValleyView Microcode - 5.007_AmiValleyViewMicrocode_003
AmiChipsetModulePkg - 5.008_ValleyviewDM_006
Intel-NorthCluster Client - 5.008_ValleyviewDM_NB_006
Intel-SouthCluster Client - 5.008_ValleyviewDM_SB_006
Vlv2DeviceRefCodePkg Client - 5.008_Vlv2DeviceRefCodeDM_005
Recovery - 5.004_Recovery_01
Create Secure Boot Variables - 5.004_SecureBoot_08
SecureBoot UEFI 2.3.1 - 5.004_SecureBoot_08
Modules added to this label:
OemActivation - 5.004_OemActivation_01
Modules removed from last label:
None
New features added in this label:
1. Enabled SD/eMMC UEFI support.
2. Enabled LPSS devices by default.
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
127623 | Bay Trail hang on postcode 0x99 (Super IO Initialization)
128056 | Implement Bay Trail-I Framework BIOS Reference Code Beta 0.9.0
128845 | Board hangs at 0x69 with 2 2GB dimms attached
Files changed for EIP fixes:
EIP Ref. # Files Changed
127623
  • AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c
128056
  • None
128845
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c
  • AmiChipsetModulePkg\NB\NbSetup\Nb.sd
  • AmiModulePkg\PCI\PciHostBridge.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Onboard graphics only support EFI video, not legacy. Use an offboard PCIe graphics card for booting legacy OS.
3. Wake from USB is not currently supported in Windows 7.
4. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. BSOD when using a SATA DVD drive to install UEFI Windows 8. Use a USB DVD for UEFI installs.
4. BSOD when using an external legacy video card to install UEFI Windows 8. Use onboard I.G.D. with UEFI GOP driver.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 8/14/2013
Source Control Label: 5.008_VEB_0ACCT004
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.008_VEB_1AREF007a
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I, Stepping: B0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213
CPU ID: 30673, Microcode Version: M0C3067330C
Memory: LPDDR3, Frequency: 1066
x32 GOP Driver: 7.0.1025
x64 GOP Driver: 7.0.1020
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_009
AmiChipsetModule version: 5.008_ValleyviewDM_007a
NorthCluster version: 5.008_ValleyviewDM_NB_007a
SouthCluster: version 5.008_ValleyviewDM_SB_007a
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.0.0_006b
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:
File Name | Description
"Release Notes.chm" | This file.
"AmiModulePkg\AHCI\Ahci.inf" | Fix building error.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Fix building error.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Uhcd.c" | For Boot to OS USB can't work.
"AmiModulePkg\Usb\Rt\Xhci.h" | For USB can't build.
"AmiModulePkg\Usb\Rt\Xhci.c" | For USB can't build.
"AmiModulePkg\Usb\UsbBus.c" | For USB can't build.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\CSM\CsmBlockIo\CsmBlockIo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmVideo\CsmVideo.inf" | Fix build error after module update.
"AmiModulePkg\CSM\CsmDxe.inf" | Fix build error after module update.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.inf" | Fix build error after module update.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.c" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\EcPs2Kbd\EcPs2Kbd.inf" | For gEfiDevicePathProtocolGuid
"AmiCryptoPkg\CryptoProtocols\CryptoDxe.c" | Fix building error.
"AmiPkg\Configuration\FdfRules.txt" | Fix hang at CheckPoint 0x49.
"AmiCompatibilityPkg\CmosManager\Template.ssp" | For EIP125551
"AmiModulePkg\Console\GraphicsConsole\GraphicsConsole.c" | First boot always hang at checkpoint 0x97
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"MdeModulePkg\Core\Pei\PeiMain\PeiMain.c" | For EIP126885
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | Support Capsule
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | Add DTS setup item
"AmiValleyViewCpuPkg\Setup\Cpu.uni" | Add DTS setup strings
AmiChipsetModulePkg\SB\AcpiModeEnable\AcpiModeEnable.c" | Didn't clear SLP_SMI_EN - EIP128356
AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | Fix for USB not working after S3 resume in Win7.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | For EIP132580 - Yellow bang in Win7
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | For EIP132580 - Yellow bang in Win7

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 0.7
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.0.0
Intel x32 GOP Drivers: 7.0.1025
Intel x64 GOP Drivers: 7.0.1020
Intel TXE version: 1.0.0.1049
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.0.0
Modules update from last label:
AmiChipsetModulePkg - 5.008_ValleyviewDM_007a
Vlv2DeviceRefCodePkg Client - 5.008_Vlv2RefDM_1.0.0_006b
Setup - 5.004_Setup_02
ValleyView Microcode - 5.007_AmiValleyViewMicrocode_007
Modules added to this label:
AMIDebugRx - 5.004_AMIDebugRx_3.00.003
AMIDebugRxPkg - 5.004_AMIDebugRx_3.00.003
CryptoPkg - 5.006_CryptoPkg_01
Intel Smart Connect Technology - based on 4.6.5.3_ISCT41_110_012
SdioDriver - based on 5.004_SdioDriver_01
Modules removed from last label:
None
New features added in this label:
Enabled x64 support
Disabled DEBUG_MODE by default
Added SD/MMC support
Updated PCI devices in SDL
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
130068 | Hang at 0xB2 when external graphics card attached and DEBUG_MODE = 0
130053 | Add AMI DebugRx support
130774 | S3 resume fails after enabling X64_SUPPORT
130612 | Unable to legacy boot when X64_SUPPORT enabled
128957 | Hang when enable X64_SUPPORT
128845 | Board hangs at 0x69 with 2 2GB dimms attached
132580 | Yellow bang in Win7
130606 | SD card support in UEFI & Legacy mode
Files changed for EIP fixes:
EIP Ref. # Files Changed
130068
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c
  • BayTrailPkg\CRB.sdl
130053
  • None
130774
  • BayTrailPkg\CRB.sdl
130612
  • MdeModulePkg\Core\Dxe\Gcd\Gcd.c
  • MdeModulePkg\Core\Dxe\Mem\Page.c
  • MdeModulePkg\Core\Dxe\Mem\Pool.c
  • MdeModulePkg\Core\Dxe\DxeMain.h
128957
  • None
128845
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c
  • AmiChipsetModulePkg\NB\NbSetup\Nb.sd
  • AmiModulePkg\PCI\PciHostBridge.c
132580
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl
130606
  • Added SdioDriver module
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Onboard graphics only support EFI video, not legacy. Use an offboard PCIe graphics card for booting legacy OS.
3. Wake from USB is not currently supported in Windows 7.
4. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
5. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. BSOD when using a SATA DVD drive to install UEFI Windows 8. Use a USB DVD for UEFI installs.
4. BSOD when using an external legacy video card to install UEFI Windows 8. Use onboard I.G.D. with UEFI GOP driver.
5. Board instability when using BayTrail-I B2 silicon. Microcode M0130673305 or later will fix issues with B2.
6. In DOS from USB key, format SD/EMMC using "format /s" command fails with "Insufficient memory to load system files" message.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 9/6/2013
Source Control Label: 5.008_VEB_0ACCT005
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.008_VEB_1AREF009
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name: Bayley Bay
Platform Revision: Fab3
SOC: BayTrail-I, Stepping: B0
CPU ID: 30672, Microcode Version: M0230672213
Memory: LPDDR3, Frequency: 1333
x32 GOP Driver: 7.0.1027
x64 GOP Driver: 7.0.1026
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_010
AmiChipsetModule version: 5.008_ValleyviewDM_010
NorthCluster version: 5.008_ValleyviewDM_NB_010
SouthCluster: version 5.008_ValleyviewDM_SB_010
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.0.3_011
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:
File Name | Description
"Release Notes.chm" | This file.
"AmiModulePkg\AHCI\Ahci.inf" | Fix building error.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Fix building error.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiModulePkg\Flash\SPI\SpiIdentify.c" | Support another low power flash part.
"AmiModulePkg\Flash\SPI\SpiFlash.h" | Support another low power flash part.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\UART1.ASL" | Modify uart1 as same with RC.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.inf" | Fix build error after module update.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.c" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\EcPs2Kbd\EcPs2Kbd.inf" | For gEfiDevicePathProtocolGuid
"AmiCryptoPkg\CryptoProtocols\CryptoDxe.c" | Fix building error.
"AmiPkg\Configuration\FdfRules.txt" | Fix hang at CheckPoint 0x49.
"AmiModulePkg\Console\GraphicsConsole\GraphicsConsole.c" | First boot always hang at checkpoint 0x97
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"MdeModulePkg\Core\Pei\PeiMain\PeiMain.c" | For EIP126885
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | Support Capsule
"CryptoPkg\Library\BaseCryptLib\BaseCryptLib.sdl" | Fix build error.
AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | EIP130623 PCIE X4 iisue
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Rtc.h" | for DP function
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\ForceHddPassword.c" | Fix build error.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\AHCI\AhciSmm\AhciSmm.inf" | EIP131491 - After setting HDD password, system will hang after S3 resume.
"AmiModulePkg\Include\Library\PciAccessCspLib.h" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\TCG\TCGSmm\TCGSmm.c" | EIP132975 [build error] gEfiMemoryOverwriteControlDataGuid redefine.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] gEfiMemoryOverwriteControlDataGuid redefine.
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxe.c" | EIP132975 [build error] gEfiMemoryOverwriteControlDataGuid redefine.
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | Fix for USB not working after S3 resume in Win7.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | For C1 by default for some BayleyBay boards.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"AmiValleyViewCpuPkg\Microcode\M0130672214.pdb" | Microcode for BYT-I B1
"AmiValleyViewCpuPkg\Microcode\M0130673305.pdb" | Microcode for BYT-I B2

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.0
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.0.3
Intel x32 GOP Drivers: 7.0.1027
Intel x64 GOP Drivers: 7.0.1026
Intel TXE version: 1.0.0.1058
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.0.3
Modules update from last label:
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_010
AmiChipsetModulePkg - 5.008_ValleyviewDM_010
Post Time Tuning - 5.004_FastBoot_02
Intel Smart Connect Technology - 5.008_ISCT_110_01
Usb - 5.004_AmiUsb_05
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.0.3_011
CSM - 5.004_CSM_02
Modules added to this label:
PEI Ram Boot - 5.001_PeiRamBoot_03
SynTCGAslVar - Private
TCG - 5.0.0.4_TCG_02_2
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
134597 | [WIN/WES 7]System unable to boot up after changing Active Processor Core to 1 – B2(T8XN)
134595 | On Win8 Baytrail-I platform, BIOS doesn't use the correct h/w id for eMMC card
134423 | Update BayTrail-Embedded to Client 1AREF009
133118 | Install Windows 8 on eMMC
Files changed for EIP fixes:
EIP Ref. # Files Changed
134597
  • Update to RC 1.0.3
134595
  • Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c
134423
  • N/A
133118
  • N/A
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Onboard graphics only support UEFI video, not legacy. Use an offboard PCIe graphics card for booting legacy OS until an official legacy vBIOS is released and added to this project.
3. Wake from USB is not currently supported in Windows 7.
4. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
5. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
6. This BIOS needs to be updated via an SPI programmer. AMI flash utilities can not update from BIOS 004 to 005.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. Windows 7 fails to boot after S4 resume using BayTrail-I B2.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 9/27/2013
Source Control Label: 5.008_VEB_0ACCT006
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: (BETA)5.008_VEB_1AREF011
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30673, Microcode Version: M0130673310
Memory: DDR3, Frequency: 1333
x32 GOP Driver: 7.0.1027
x64 GOP Driver: 7.0.1028
IGD legacy vBIOS: 1004
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_011
AmiChipsetModule version: 5.008_ValleyviewDM_012
NorthCluster version: 5.008_ValleyviewDM_NB_012
SouthCluster: version 5.008_ValleyviewDM_SB_012
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.1.1_014
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiModulePkg\AHCI\Ahci.inf" | Fix building error.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.c" | Modify for security.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security.
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"AmiModulePkg\EcPs2Kbd\EcPs2Kbd.inf" | For gEfiDevicePathProtocolGuid
"AmiPkg\Configuration\FdfRules.txt" | Fix hang at CheckPoint 0x49.
"AmiModulePkg\Console\GraphicsConsole\GraphicsConsole.c" | First boot always hang at checkpoint 0x97
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"MdeModulePkg\Core\Pei\PeiMain\PeiMain.c" | For EIP126885
"CryptoPkg\Library\BaseCryptLib\BaseCryptLib.sdl" | Fix build error.
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | EIP130623 PCIE X4 iisue; Add support for platform check.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Rtc.h" | for DP function
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\AHCI\AhciSmm\AhciSmm.inf" | EIP131491 - After setting HDD password, system will hang after S3 resume.
"AmiModulePkg\Include\Library\PciAccessCspLib.h" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] gEfiMemoryOverwriteControlDataGuid redefine.
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\Usb\Rt\Ehci.c" | EIP135237 USB can't work when turn on AMIDEBUG_RX_SUPPORT.
"AmiModulePkg\AmiStatusCode\StatusCodeDxe.c" | When token "SOC_UART_PRESENT" = "1" and Setup item "UartDebugEnable" = "Disable", output debug message will hang in OS.
"AmiModulePkg\AmiStatusCode\StatusCodeSmm.c" | When token "SOC_UART_PRESENT" = "1" and Setup item "UartDebugEnable" = "Disable", output debug message will hang in OS.
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error.
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | Support Capsule.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting. Support Capsule.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail.
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | For C1 by default for some BayleyBay boards.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiValleyViewCpuPkg\Microcode\M0130673310.pdb" | BayTrail-I B2/B3 micorocode
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Fix unable to legacy boot XHCI
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.0
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.1.1
Intel x32 GOP Drivers: 7.0.1027
Intel x64 GOP Drivers: 7.0.1028
Intel TXE version: 1.0.2.1060
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.1.1
Modules update from last label:
Flash - Source - 5.004_Flash_06
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_011
AmiChipsetModulePkg - 5.008_ValleyviewDM_012
TSE Binary - 5.004_AmiTse_2_16_1242
AmiCryptoPkg - 5_004.CryptoPkg_014.1
HddSecurity - 5.004_HddSecurity_03
SecureBoot,UEFI - 5.004_SecureBoot_09.1
SmiFlash - 5.001_SmiFlash_08
Vlv2DeviceRefCodePkg Client - 5.008_Vlv2RefDM_1.1.1_014
Modules added to this label:
Hardware Signature Management - 5.004_HwSignature_02
AmiNetworkPkg- 5.008_AmiNetworkPkg_03
UefiNetworkStack - 5.008_UefiNetworkStack_03
Modules removed from last label:
None
New features added in this label:
Added onboard IGD legacy vBIOS support.
General Bug Fixes:
None
EIP addressed in this label:
EIP Ref. # | Description
135727 | BIOS 0ACCT006 Release
136184 | Windows 7 fails to resume from S3 when hybrid sleep is disabled
135320 | (JP0033) When AC cable is disconnected in S3 State, board can't boot next time.
136572 | BayTrail-Embedded cannot boot on Bakersport CRB
136947 | Need AMI bios to resolve the resource conflict for Win7 on Baytrail-I
136991 | Add CPU stepping and KSC version to setup
136936 | Bakersport resumes automatically from S3
135891 | System hang up at post code 0xB2 while plug in external VGA card.
Files changed for EIP fixes:
EIP Ref. # Files Changed
135727
  • N/A
136184
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl
135320
  • BayTrailPkg\Library\PlatformHookLib\SerialPortLib.c
136572
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
  • BayTrailPkg\Crb.sdl
  • Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h
136947
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
136991
  • BayTrailPkg\CrbSetup\CrbSetup.sdl
  • BayTrailPkg\CrbSetup\Crb.sd
  • BayTrailPkg\CrbSetup\Crb.uni
  • BayTrailPkg\CrbSetup\CrbSetup.c
136936
  • AmiChipsetModulePkg\SB\SbInit\SbPei.c
135891
  • AmiModulePkg\CSM\CsmPolicy\Csm.sd
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. This BIOS needs to be updated via an SPI programmer. AMI flash utilities can not update from BIOS 005 to 006.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. For A0, B0, and B1 stepping, S3 resume can randomly hang at checkpoint 0x32.
4. Issues seen with BayTrail-I B2/B3:
  • System resets during legacy Windows 7 S4 resume.
  • System resets during legacy Windows boot when XHCI mode is enabled.
  • System resets during legacy Fedora 18 installation boot.
  • System resets during legacy USB DVD boot.

    • Note: These issues do not occur with BayTrail-I B0 and microcode M0230672213. They do occur on B0 using microcode M0230672214. This BIOS contains M0230672213 for this reason.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005


BIOS Information:
AMI BIOS Core: 5.008_Core
Release Date: 10/25/2013
Source Control Label: 5.008_VEB_0ACCT007
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.008_VEB_1AREF013
Refernce BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30673, Microcode Version: M0130673310
Memory: DDR3, Frequency: 1333
x32 GOP Driver: 7.0.1029
x64 GOP Driver: 7.0.1029
IGD legacy vBIOS: 1004
CoreVersion 5.008_Core
CPU version: 5.007_AmiValleyViewCpuPkg_011
AmiChipsetModule version: 5.008_ValleyviewDM_014
NorthCluster version: 5.008_ValleyviewDM_NB_014
SouthCluster: version 5.008_ValleyviewDM_SB_014
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.2.0_016
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High SKU + 2 channel without ECC
    2. 3 = Premium/High SKU + 1 channel with ECC
    3. 1 = Premium/High SKU + 1 channel without ECC
    4. 0 = Intermediate/Mid/Low SKU + 1 channel with ECC
    5. 1 = Intermediate/Mid/Low SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x4 = BayLake (FFRD)
    4. 0x5 = BayLake (FFRD)
    5. 0x7 = PPV-STHI
    6. 0x20 = Bayley Bay
    7. 0x30 = Bakersport
    8. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiModulePkg\AHCI\Ahci.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\ACPI\AcpiCore.c" | For add the fRC acpi table, EIP131133 - Failed to retrieve Firmware Post Time value
"MdeModulePkg\Core\PiSmmCore\Pool.c" | For enable SMM system will hang up.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciBus.sd" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiCompatibilityPkg\Smbios\SmbiosDmiEdit\SmbiosDmiEditFunc.c" | Smbios type 11 & 12 can be modified.
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\EfiOsBootOptionNames\EfiOsBootOrder.c" | for build pass without CSM module.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"AmiModulePkg\EcPs2Kbd\EcPs2Kbd.inf" | For gEfiDevicePathProtocolGuid
"AmiPkg\Configuration\FdfRules.txt" | Fix hang at CheckPoint 0x49.
"AmiModulePkg\Console\GraphicsConsole\GraphicsConsole.c" | First boot always hang at checkpoint 0x97
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"MdeModulePkg\Core\Pei\PeiMain\PeiMain.c" | For EIP126885
"CryptoPkg\Library\BaseCryptLib\BaseCryptLib.sdl" | Fix build error.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | EIP130623 PCIE X4 iisue; Add support for platform check.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Rtc.h" | for DP function
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\AHCI\AhciSmm\AhciSmm.inf" | EIP131491 - After setting HDD password, system will hang after S3 resume.
"AmiModulePkg\Include\Library\PciAccessCspLib.h" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] gEfiMemoryOverwriteControlDataGuid redefine.
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\Usb\Rt\Ehci.c" | EIP135237 USB can't work when turn on AMIDEBUG_RX_SUPPORT.
"AmiModulePkg\AmiStatusCode\StatusCodeDxe.inf" | Add patch from EIP138730
"AmiModulePkg\AmiStatusCode\StatusCodeDxe.c" | When token "SOC_UART_PRESENT" = "1" and Setup item "UartDebugEnable" = "Disable", output debug message will hang in OS.
"AmiModulePkg\AmiStatusCode\StatusCodeSmm.c" | When token "SOC_UART_PRESENT" = "1" and Setup item "UartDebugEnable" = "Disable", output debug message will hang in OS.
"AmiModulePkg\SecureFlash\SecureFlash.mak" | For build x32 mode will build error.
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | Support Capsule.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Fix BSOD in OS while debug_mode enabling and reseting. Support Capsule.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail.
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS.
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\SecureBoot\SecureBoot.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Change S0ix default value to disable.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\PpmPolicyInitDxe.c" | Eist would not work when activeCore is set to 1.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiCryptoPkg\CryptoLib\Pkcs7.c" | EIP137431 - fix for Authenticated Variable Support (UEFI 2.3.1c SCT) Test
"AmiModulePkg\SmiFlash\SmiFlashLinks.c" | EIP139070 - fix for BIOS flash update twice issue
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | EIP138569 - SSD IDE mode need delay time when S3 resume to unlock HDD password
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Fix unable to legacy boot XHCI
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-03-20
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.0
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.2.0
Intel x32 GOP Drivers: 7.0.1029
Intel x64 GOP Drivers: 7.0.1029
Intel TXE 1.25 MB version: 1.0.2.1067
Intel TXE 3 MB version: 1.0.2.1060
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.2.0
Modules update from last label:
HddSecurity - 5.004_HddSecurity_04
ValleyView Microcode - 5.007_AmiValleyViewMicrocode_015
AmiChipsetModulePkg - 5.008_ValleyviewDM_014
Create Secure Boot Variables - 5.004_SecureBoot_09.1
Vlv2DeviceRefCodePkg Client - 5.008_Vlv2RefDM_1.2.0_016
Modules added to this label:
VirtualSerial - 5.004_VirtualSerial_00
OpalSecurity - 5.004_OpalSecurity_00
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
138761 | Add debug message and redirection support when SIO_SUPPORT = 0
138429 | Board hangs at checkpoint 04h when no EC present
138282 | Board unstable with B2/B3 stepping
138071 | Add USB S5 wake support
138074 | AMI BIOS 005 doesn’t set IRQ correctly for i2C controller for WEC7
139879 | Get Bloomfield Hills booting with BayTrail-Embedded BIOS
139400 | TPM Bitlocker function not work properly
Files changed for EIP fixes:
EIP Ref. # Files Changed
138761
  • Added VirtualSerial module
  • BayTrailPkg\Crb.sdl
138429
  • BayTrailPkg\Crb.sdl
  • BayTrailPkg\CrbSetup\Crb.uni
  • BayTrailPkg\CrbSetup\CrbSetup.c
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c
138282
  • N/A
138071
  • BayTrailPkg\Crb.sdl
  • AmiModulePkg\Usb\Rt\UsbRt.mak
  • AmiModulePkg\Usb\UsbSb.c
138074
  • AmiModulePkg\PCI\PciBus.c
139879
  • BayTrailPkg\Crb.sdl
139400
  • AmiModulePkg\TCG\TcgDxe\TcgDxe.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. For A0, B0, and B1 stepping, S3 resume can randomly hang at checkpoint 0x32.
4. Issues seen with BayTrail-I B2/B3:
  • System resets during legacy Windows 7 S4 resume.
  • System resets during legacy Windows boot when XHCI mode is enabled.
  • System resets during legacy Fedora 18 installation boot.
  • System resets during legacy USB DVD boot.

    • Note: These issues do not occur with BayTrail-I B0 and microcode M0230672213. They do occur on B0 using microcode M0230672214. This BIOS contains M0230672213 for this reason.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 12/6/2013
Source Control Label: 5.009_VEB_0ACCT008
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF014a
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222B
CPU ID: 30673, Microcode Version: M0C3067331E, M013067331E
CPU ID: 30678, Microcode Version: M0130678806
Memory: DDR3, Frequency: 1333
x32 GOP Driver: 7.0.1029
x64 GOP Driver: 7.0.1029
IGD legacy vBIOS: 1004
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_012
AmiChipsetModule version: 5.008_ValleyviewDM_017
NorthCluster version: 5.008_ValleyviewDM_NB_017
SouthCluster: version 5.008_ValleyviewDM_SB_017
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.2.2_020
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 0 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\Smbios.c" | Update casting
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureBoot\SecureBoot.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS..
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Ehci.c" | EIP135237 USB can't work when turn on AMIDEBUG_RX_SUPPORT.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiValleyViewCpuPkg\Microcode\M013067222B.PDB" | Add latest BayTrail microcode.
"AmiValleyViewCpuPkg\Microcode\M013067331E.PDB" | Add latest BayTrail microcode.
"AmiValleyViewCpuPkg\Microcode\M0130678806.PDB" | Add latest BayTrail microcode.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | Set PCI graphics default.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Fix unable to legacy boot XHCI
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiChipsetModulePkg\Library\SbLibrary.cif" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\SbCmos.ssp" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.inf" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.c" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"Vlv2DeviceRefCodePkg\Wrapper\DPTF\Dxe\Dptf.c" | EIP144300 - I2C port 3 IC_COMP_VERSION register not being set by AMI BIOS 0007
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\EC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.2.1
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.2.2
Intel x32 GOP Drivers: 7.0.1029
Intel x64 GOP Drivers: 7.0.1029
Intel TXE 1.25 MB Version: 1.0.2.1067
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.2.1060
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.2.2
Modules update from last label:
AmiCompatibilityPkg - AmiCompatibilityPkg_18
Core - 5.009_Core
Flash - 5.004_Flash_09
AmiValleyViewMicrocode - 5.007_AmiValleyViewMicrocode_019
AmiChipsetModulePkg - 5.008_ValleyviewDM_017
AHCI - 5.004_AHCI_02
AmiCryptoPkg - 5_004.CryptoPkg_017
GenericSio - 5.004_GenericSio_03
ACPI - 5.004_ACPI_05
IdeBus - 5.004_IdeBus_01
PciBus - 5.004_PCI_05
SerialRedirection - 5.004_Terminal_03
AmiBoardInfo - 5.004_BoardInfo_03
RuntimeSmm - 5.004_RuntimeSmm_01
Intel Architecture Support - IntelArchitecture_03.1
SingleSegmentPciCfg2 - SingleSegmentPciCfg2_01
CryptoPkg - 5.006_CryptoPkg_03
EcPs2Kbd - 5.004_EcPs2Kbd_02
FatBin - 5.004_FatBin_02
On Flash Block Description (APTIO) - Secure Flash - 5.005_OfbdSecureFlash_002
On Flash Block Description (APTIO) - Intel ME Update - 5.005_OfbdMeUpdate_006
RsdpPlus - 5.004_RsdpPlus_02
Secure Flash,NIST SP800-147 - 5.004_SecureFlash_08
SmiFlash - 5.001_SmiFlash_09
SMM Support - Smm_05
TCG - 5.0.0.4_TCG_03
UefiCpuPkg - UefiCpuPkg_04
UsbRecovery - 5.004_Recovery_01
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.2.2_020
AmiStatusCode - 5.004_AmiStatusCode_01
On Flash Block Description (APTIO) - 5.001_OFBD_04
EFI OS BootOptionNames - 5.004_EfiOsBootOptionNames_03
PS2CTL - 5.004_Ps2Ctl_02
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_012
Modules added to this label:
RestoreSpecialBootOptions - 5.004_RestoreSpecialBootOptions_01
Modules removed from last label:
PCI Board Porting Template - 5.004_PCI_04
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
145652 | SD/eMMC not detected after updating modules
144807 | Unable to secure flash with BIOS (INT)0ACCT008c
144137 | Boot Android WW40 on BayTrail-I
143995 | Unable to boot with E3815 CPU
143327 | ULPI input/output clocks not functional
141512 | USB 3.0 ULPI device not showing up
139083 | ACPI device ACPI\33B2 changed to ACPI\33FC in BIOS 006
139069 | REF-31776.V0: PS/2 KB/MS support in windows test - Failed
139067 | REF-31774.V0: PS/2 KB/MS support test - Failed
144300 | [WEC7] I2C port 3 IC_COMP_VERSION register not being set by AMI BIOS 0007
144299 | [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
145998 | BIOS (INT)0ACCT008f hangs at 0x99 when limit to 1 core in setup
Files changed for EIP fixes:
EIP Ref. # Files Changed
145652
  • AmiModulePkg\Sdio\SdioDriver.c
144807
  • BayTrailPkg\CRB.sdl
  • BayTrailPkg\CRB.mak
  • AmiPkg\Configuration\Main.mak
144137
  • N/A
143995
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c
143327
  • BayTrailPkg\CRB.sdl
  • AmiChipsetModulePkg\SB\SbInit\SbPei.c
141512
  • RomImage\BayTrail_Desktop_8MB_TXE_3MB.xml
139083
  • N/A
139069
  • N/A
139067
  • BayTrailPkg\CRB.sdl
144300
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c
  • Vlv2DeviceRefCodePkg\Wrapper\DPTF\Dxe\Dptf.c
144299
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\EC.ASL
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL
145998
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. For A0, B0, and B1 stepping, S3 resume can randomly hang at checkpoint 0x32.
4. This BIOS cannot be upgraded from an earlier version using AMI flash utilities. Secure flash has been disabled going forward since the signing keys are no longer included in the project. An SPI programmer can be used to upgrade to this BIOS version.
5. Issues seen with BayTrail-I B2/B3:
  • System resets during legacy Windows 7 S4 resume.
  • System resets during legacy Windows boot when XHCI mode is enabled.
  • System resets during legacy Fedora 18 installation boot.
  • System resets during legacy USB DVD boot.

    • Note: These issues do not occur with BayTrail-I B0 and microcode M0230672213. They do occur on B0 using microcode M0230672214. This BIOS contains M0230672213 for this reason.
    Temporary Workaround #1: Build BIOS in 32-bit mode.
    Temporary Workaround #2: Limit # CPU cores to 1 in BIOS setup (Advanced -> CPU Configuration -> Active Processor Core = [1])
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 1/10/2014
Source Control Label: 5.009_VEB_0ACCT009
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF016
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222B
CPU ID: 30673, Microcode Version: M0C3067331E, M013067331E
CPU ID: 30678, Microcode Version: M0130678806
Memory: DDR3, Frequency: 1333
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 1007
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_012
AmiChipsetModule version: 5.008_ValleyviewDM_019
NorthCluster version: 5.008_ValleyviewDM_NB_019
SouthCluster: version 5.008_ValleyviewDM_SB_019
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.1_022
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 0 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\Smbios.c" | Update casting
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureBoot\SecureBoot.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS..
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Ehci.c" | EIP135237 USB can't work when turn on AMIDEBUG_RX_SUPPORT.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiChipsetModulePkg\Library\AmiSioPeiLib\AmiSioPeiLib.c" | CSP20131230 - program runtime registers
"Vlv2DeviceRefCodePkg\Wrapper\Include\Guid\PlatformInfo.h" | Modify for SG support
"AmiChipsetModulePkg\SB\AcpiPlatform\AcpiPlatform.c" | Modify for SG support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\SwitchableGraphicsInit.c" | Modify for SG support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\VlvInit.inf" | For AMI CSM Vedio setting.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\IgdOpRegion.c" | For AMI CSM Vedio setting.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiValleyViewCpuPkg\Microcode\M013067222B.PDB" | Add latest BayTrail microcode.
"AmiValleyViewCpuPkg\Microcode\M013067331E.PDB" | Add latest BayTrail microcode.
"AmiValleyViewCpuPkg\Microcode\M0130678806.PDB" | Add latest BayTrail microcode.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Fix unable to legacy boot XHCI
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiChipsetModulePkg\Library\SbLibrary.cif" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\SbCmos.ssp" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.inf" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.c" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\EC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\SwitchableGraphics\Pch\SgDgpuPch.asl" | Modify GPIO for PCI0 scope
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.22
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.1
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
Intel TXE 1.25 MB Version: 1.0.2.1067
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.2.1060
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.1
Modules update from last label:
AmiChipsetModulePkg - 5.008_ValleyviewDM_019
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.1_022
Intel Smart Connect Technology - 5.008_ISCT_110_02
Modules added to this label:
AmiGopPolicy - 5.004_AmiGopPolicy_02
Hash Data PEI - SHA256
Verify Boot
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
148973 | System resets on legacy boot using B2/B3 stepping
147650 | [WEC7] Bios incorrect set UART MSR register Bit 0 to 1 by using AMI 007 BIOS
147466 | Build errors when enabling IVI_PF_ENABLE
147465 | Fedora hang issue when running audio video concurrency on Bakersport
147463 | Validate Windows 8 x64 on BayTrail-IVI
147460 | No CPU power displayed and GFx frequency not changing in PTU
Files changed for EIP fixes:
EIP Ref. # Files Changed
148973
  • MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c
147650
  • BayTrailPkg\CRB.sdl
147466
  • BayTrailPkg\CRB.sdl
  • AmiModulePkg\VirtualSerial\VirtualSerial.c
147465
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.c
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.inf
147463
  • BayTrailPkg\CRB.sdl
  • AmiModulePkg\VirtualSerial\VirtualSerial.c
  • AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd
  • AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c
147460
  • None
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 2/21/2014
Source Control Label: 5.009_VEB_0ACCT010
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF018a
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222B
CPU ID: 30673, Microcode Version: M0C30673320, M013067331E
CPU ID: 30678, Microcode Version: M0C30678809, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 1007
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_021
NorthCluster version: 5.008_ValleyviewDM_NB_021
SouthCluster: version 5.008_ValleyviewDM_SB_021
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.3_024
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 0 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\Smbios.c" | Update casting
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureBoot\SecureBoot.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS..
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Ehci.c" | EIP135237 USB can't work when turn on AMIDEBUG_RX_SUPPORT.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\CSM\Csm.c" | EIP148452 - NUMLOCK always under dos.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | Modify to match PI in RC.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Fix unable to legacy boot XHCI
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiChipsetModulePkg\Library\SbLibrary.cif" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\SbCmos.ssp" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.inf" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.c" | EIP134333 - Implement SBSmmSaveRestoreStates routine in BayTrail.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"AmiChipsetModulePkg\Nb.sdl" | EIP152282 - The system hang b2 in legacy mode with HDMI LCD, EIP152283 - The resolution is wrong in legacy mode with panel.
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.32
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.3
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
Intel TXE 1.25 MB Version: 1.0.2.1067
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.2.1060
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.3
Modules update from last label:
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModulePkg - 5.008_ValleyviewDM_021
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.3_024
Intel Smart Connect Technology - 5.008_ISCT_110_03
OemActivation - 5.004_OemActivation_02
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
150085 | REF-32311.V1: Device Manager Test - Failed
154681 | Legacy Boot Options are missing after updating to RC 1.3.3
Files changed for EIP fixes:
EIP Ref. # Files Changed
150085
  • Reverted back changes for GPIO scope.
154681
  • AmiModulePkg\Bds\Bds.sdl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 2/28/2014
Source Control Label: 5.009_VEB_0ACCT011
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF019
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222B
CPU ID: 30673, Microcode Version: M0C30673320, M013067331E
CPU ID: 30678, Microcode Version: M0C30678809, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 1007
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_022
NorthCluster version: 5.008_ValleyviewDM_NB_022
SouthCluster: version 5.008_ValleyviewDM_SB_022
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.4_025
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\Smbios.c" | Update casting
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\CSM\Csm.c" | EIP148452 - NUMLOCK always under dos.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.inf" | EIP154718 BIOS will compile error if disable the token “SecurityPkg_SUPPORT”.
"Vlv2DeviceRefCodePkg\Wrapper\Wrapper.sdl" | EIP154718 BIOS will compile error if disable the token “SecurityPkg_SUPPORT”.
"Vlv2DeviceRefCodePkg\Vlv2DeviceRefCodePkg.sdl" | EIP154718 BIOS will compile error if disable the token “SecurityPkg_SUPPORT”.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Pch.asl" | CSP20140218_19 - fix XHCI auto and smart auto issue.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchXhci.asl" | CSP20140218_19 - fix XHCI auto and smart auto issue.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | CSP20140218_19 - fix XHCI auto and smart auto issue.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"AmiChipsetModulePkg\Nb.sdl" | EIP152282 - The system hang b2 in legacy mode with HDMI LCD, EIP152283 - The resolution is wrong in legacy mode with panel.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.32
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.4
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1089
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089
Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.4
Modules update from last label:
AmiChipsetModulePkg - 5.008_ValleyviewDM_022
AmiCryptoPkg - 5_004.CryptoPkg_019
SecureBoot - 5.004_SecureBoot_11
Usb - 5.004_AmiUsb_06
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.4_025
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # Description
Files changed for EIP fixes:
EIP Ref. # Files Changed
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 4/1/2014
Source Control Label: 5.009_VEB_0ACCT012a
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF021
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673321, M0130673321
CPU ID: 30678, Microcode Version: M0C30678811, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 1011
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_024
NorthCluster version: 5.008_ValleyviewDM_NB_024
SouthCluster: version 5.008_ValleyviewDM_SB_024
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.6_027
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW (Default Build)
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\CSM\Csm.c" | EIP148452 - NUMLOCK always under dos.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | EIP150193 FOTA support.
"AmiModulePkg\Recovery\FsRecovery\FsRecovery.c" | EIP153486 Fault Tolerant Function.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\ACPI\mptable.c" | EIP150568 BIOS hanged at checkpoint D9h without any boot devices if user to press "Esc" or "F4" key to exit SETUP.
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiCryptoPkg\Utils\CryptoCon.exe" | Client BIOS Label19 can't flash rom(BIOS+TXE) but rom(BIOS) can flash. Rollback Client BIOS Label18.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.c to svn 164725.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Common\PchUsbCommon.c" | Remove CSP20140218_19 solution.
"Vlv2DeviceRefCodePkg\Txe\Heci\Dxe\Hecidrv.c" | Use token to control CF9 lock bit.
"Vlv2DeviceRefCodePkg\Txe\SeCUma\SeCUma.c" | Use token to control CF9 lock bit.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Set EHCI enabled by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiChipsetModulePkg\Library\SbSmmCorePlatformHookLib\SbSmmCorePlatformHookLib.c" | For SMM save state.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.35
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.6
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
IGD legacy vBIOS: 1011

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1089
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.6
Modules update from last label:
AmiChipsetModulePkg - 5.008_ValleyviewDM_024
SecureBoot,Create Variables - 5.004_SecureBoot_11
Intel Smart Connect Technology - 5.008_ISCT_110_05
Smbios - 5.004_SmBios_03
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.6_027
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # Description
Files changed for EIP fixes:
EIP Ref. # Files Changed
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different "XHCI Mode" setup questions depending on the "OS Selection" question. If XHCI needs to be enabled, make sure to configure it AFTER changing "OS Selection".
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 4/18/2014
Source Control Label: 5.009_VEB_0ACCT013
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF022a
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673321, M0130673321
CPU ID: 30678, Microcode Version: M0C30678811, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1008
x64 GOP Driver: 7.1.1008
IGD legacy vBIOS: 3732
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_025
NorthCluster version: 5.008_ValleyviewDM_NB_025
SouthCluster: version 5.008_ValleyviewDM_SB_025
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.7_028
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\Library\AmiPciAccessCspBaseLib\AmiPciAccessCspBaseLib.c" | EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\CSM\Csm.c" | EIP148452 - NUMLOCK always under dos.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | EIP150193 FOTA support.
"AmiModulePkg\Recovery\FsRecovery\FsRecovery.c" | EIP153486 Fault Tolerant Function.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\ACPI\mptable.c" | EIP150568 BIOS hanged at checkpoint D9h without any boot devices if user to press "Esc" or "F4" key to exit SETUP.
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiCryptoPkg\Utils\CryptoCon.exe" | Client BIOS Label19 can't flash rom(BIOS+TXE) but rom(BIOS) can flash. Rollback Client BIOS Label18.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.c to svn 164725.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\CSM\CsmPolicy\Csm.sd" | EIP135891 - fix for hang when "UEFI first" is set and UEFI offboard card is attached
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiModulePkg\CSM\CsmPolicy\Csm.uni" | EIP157451 - CSM enable/disable dependency on Secure Boot is missing.
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP159341 - Blue sreen occur when test IRQ function.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\Cpu.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MemoryAttribute.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\DetectDimms.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Smm\PchInitLateSmm.c" | EIP160701 - XHCI not working in Feodra after S3 resume.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003

Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.36
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.7
Intel x32 GOP Drivers: 7.1.1008
Intel x64 GOP Drivers: 7.1.1008
IGD legacy vBIOS: 3732

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1089
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.7
Modules update from last label:
AmiChipsetModulePkg - 5.008_ValleyviewDM_025
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.7_028
SMM Support - Smm_06
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
159334 | No warning beep during POST
161915 | Unable to build with ANDROID_SUPPORT = 1
162674 | Add new vBIOS 3732 and test display switching
162700 | Caching issues after updating to latest AmiChipsetModulePkg
160701 | REF-31758.V0: Fedora x64 Installation (AHCI Mode)
Files changed for EIP fixes:
EIP Ref. # Files Changed
159334
  • AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\DetectDimms.c
161915
  • BayTrailPkg\CRB.sdl
  • AmiChipsetModulePkg\SB\SbSetup\Sb.sd
162674
  • BayTrailPkg\BYTI_36_2_4_3732.bsf
  • BayTrailPkg\BYTI_36_2_4_3732.dat
162700
  • BayTrailPkg\CSP.sdl
160701
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Smm\PchInitLateSmm.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different "XHCI Mode" setup questions depending on the "OS Selection" question. If XHCI needs to be enabled, make sure to configure it AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 5/9/2014
Source Control Label: 5.009_VEB_0ACCT014
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF023
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673321, M0130673321
CPU ID: 30678, Microcode Version: M0C30678811, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1003
x64 GOP Driver: 7.2.1003
IGD legacy vBIOS: 3732
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_026
NorthCluster version: 5.008_ValleyviewDM_NB_026
SouthCluster: version 5.008_ValleyviewDM_SB_026
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.8_029
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | EIP150193 FOTA support.
"AmiModulePkg\Recovery\FsRecovery\FsRecovery.c" | EIP153486 Fault Tolerant Function.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\ACPI\mptable.c" | EIP150568 BIOS hanged at checkpoint D9h without any boot devices if user to press "Esc" or "F4" key to exit SETUP.
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.c to svn 164725.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP159341 - Blue sreen occur when test IRQ function.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiModulePkg\ACPI\AcpiCore.c" | CSP20140424_23 - Update RC 1.3.8 cause Win7 S3 resume fail.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Smm\PchInitLateSmm.c" | EIP166185 System will show USB-hot-plug event after S3 resume.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\Cpu.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MemoryAttribute.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\DetectDimms.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MpCommon.c" | EIP164713 - System hangs during card's OpROM launch with LSI 9265.
"AmiValleyViewCpuPkg\Setup\CpuSetup.c" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail
"AmiValleyViewCpuPkg\Include\Cpu.h" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-03-31
Visual eBios: RSS.7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.37
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.8
Intel x32 GOP Drivers: 7.2.1003
Intel x64 GOP Drivers: 7.2.1003
IGD legacy vBIOS: 3732

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1089
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.8
Modules update from last label:
AmiModulePkg - AmiModulePkg_22
AmiChipsetModulePkg - 5.008_ValleyviewDM_026
Csm - Csm_7.74_03
SmiFlash - 5.001_SmiFlash_12
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.8_029
Modules added to this label:
TseDefaultBootOrder - TseDefaultBootOrder_02
Sg TPV - 5.009_SgTpv_BT_000
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
164713 | REF-33797.V6: Legacy/UEFI OpROM with CSM
162037 | Bay trail - i E3827 cpu L2 cache show fail
Files changed for EIP fixes:
EIP Ref. # Files Changed
164713
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MpCommon.c
162037
  • AmiValleyViewCpuPkg\Setup\CpuSetup.c
  • AmiValleyViewCpuPkg\Include\Cpu.h
  • AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 5/15/2014
Source Control Label: 5.009_VEB_0ACCT014a
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF023
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: B3
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673321, M0130673321
CPU ID: 30678, Microcode Version: M0C30678811, M0130678806
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1003
x64 GOP Driver: 7.2.1003
IGD legacy vBIOS: 3732
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_013
AmiChipsetModule version: 5.008_ValleyviewDM_026
NorthCluster version: 5.008_ValleyviewDM_NB_026
SouthCluster: version 5.008_ValleyviewDM_SB_026
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.8_029
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • BIOS_CONFIG_REG_VAL needs to be set based on the board ECC configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • KSC revision is displayed as N/A in setup.
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | EIP150193 FOTA support.
"AmiModulePkg\Recovery\FsRecovery\FsRecovery.c" | EIP153486 Fault Tolerant Function.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\ACPI\mptable.c" | EIP150568 BIOS hanged at checkpoint D9h without any boot devices if user to press "Esc" or "F4" key to exit SETUP.
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.c to svn 164725.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP159341 - Blue sreen occur when test IRQ function.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiModulePkg\ACPI\AcpiCore.c" | CSP20140424_23 - Update RC 1.3.8 cause Win7 S3 resume fail.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Smm\PchInitLateSmm.c" | EIP166185 System will show USB-hot-plug event after S3 resume.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\Cpu.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MemoryAttribute.c" | CSP20140329_22 - fix MTRR may cause BSOD with build x32.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c" | Updated eMMC detection for B3 stepping.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | X64_SUPPORT=0 build error when CRB add CSP20140123 solution.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\DetectDimms.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MpCommon.c" | EIP164713 - System hangs during card's OpROM launch with LSI 9265.
"AmiValleyViewCpuPkg\Setup\CpuSetup.c" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail
"AmiValleyViewCpuPkg\Include\Cpu.h" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP162037 - Bay trail - i E3827 cpu L2 cache show fail
"AmiModulePkg\CSM\CsmBsp.c" | EIP168822 - BIOS failed to build in 32bit
"AmiModulePkg\UsbRecovery\UsbRecov.inf" | Usb flash drive fix for recovery.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-03-31
Visual eBios: RSS.7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.37
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.8
Intel x32 GOP Drivers: 7.2.1003
Intel x64 GOP Drivers: 7.2.1003
IGD legacy vBIOS: 3732

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1089
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.8
Modules update from last label:
AmiModulePkg - AmiModulePkg_22
AmiChipsetModulePkg - 5.008_ValleyviewDM_026
Csm - Csm_7.74_03
SmiFlash - 5.001_SmiFlash_12
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.8_029
Modules added to this label:
TseDefaultBootOrder - TseDefaultBootOrder_02
Sg TPV - 5.009_SgTpv_BT_000
Modules removed from last label:
None
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
164713 | REF-33797.V6: Legacy/UEFI OpROM with CSM
162037 | Bay trail - i E3827 cpu L2 cache show fail
168822 | REF-31772.V0: BIOS build check
Files changed for EIP fixes:
EIP Ref. # Files Changed
164713
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MpCommon.c
162037
  • AmiValleyViewCpuPkg\Setup\CpuSetup.c
  • AmiValleyViewCpuPkg\Include\Cpu.h
  • AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c
168822
  • AmiModulePkg\CSM\CsmBsp.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014


BIOS Information:
AMI BIOS Core: 5.009_Core
Release Date: 6/27/14
Source Control Label: 5.009_VEB_0ACCT015
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.009_VEB_1AREF025
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673322
CPU ID: 30678, Microcode Version: M0C30678815, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1004
x64 GOP Driver: 7.2.1004
IGD legacy vBIOS: 3757
EC Firmware: 3.12
CoreVersion 5.009_Core
CPU version: 5.007_AmiValleyViewCpuPkg_015
AmiChipsetModule version: 5.008_ValleyviewDM_028
Vlv2DeviceRefCodePkg version 5.008_Vlv2RefDM_1.3.9b_032
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.inf" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.sdl" | Support AMI GOP policy on BayTrail
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\Bds\BootOptions.c" | EIP149754
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\Include\AhciController.h" | EIP150342
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Dxe\PeiRamBootDxe.inf" | EIP145799 - When token "PeiRamBootSupport" is enabled, AMIDEEFIx64 Can't modify "Product Name" and "Serial Number".
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\Recovery\ReFlash\ReFlashWorker.c" | Fix Recovery can flash FV_PRE_BB area and Microcode area.
"AmiModulePkg\RomLayout\RomLayout.dt" | For the BayTrail Rom layout
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\TCG\TcgCommon.c" | Add TCG_GUID_HOB build check
"AmiModulePkg\TCG\TcgDxe\EMpCallBin32.asm" | EIP132975 [build error] binary type distinguish between Ia32 and x64.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.c" | EIP132975 [build error] binary type distinguish between Ia32 and x64. EIP139219 - System always hard hang while testing fTPM items. EIP139833 - TPM 1.2 TCG OS Interface Client Test failed.
"AmiModulePkg\TCG\TcgDxe\TcgDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgLibDxe.inf" | EIP132975 [build error] binary type distinguish between Ia32 and x64
"AmiModulePkg\TCG\TcgPlatformSetupPeiPolicy\TcgPlatformSetupPeiPolicy.c" | EIP132975FTPM and DTPM select setting.
"AmiModulePkg\TCG\TcgPlatformSetupPolicy\TcgPlatformSetupPolicy.c" | EIP132975 FTPM and DTPM select setting.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiTsePkg\Core\em\AMITSE\CommonHelper.c" | EIP137341 BGRT module modification
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\Pei\Memory\MemoryServices.c" | Fix trace message problem.
"MdePkg\Library\BasePeCoffLib\BasePeCoff.c" | EIP137990 - Android Support.
"MdePkg\Library\BasePeCoffLib\BasePeCoffLib.inf" | EIP137990 - Android Support.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"MdeModulePkg\Universal\Disk\PartitionDxe\ElTorito.c" | EIP144164 - driver loop issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\Include\AmiTcg\TcgCommon.h" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\Recovery\ReFlash\ReFlash.uni" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\TCG\AmiTcgPlatformDxe\AmiTcgPlatformDxeLib.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgLegacy\TcgLegacy.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPei\TcgTcmPei.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiModulePkg\TCG\TcgPeiAfterMem\TcgTcmPeiAfterMem.c" | EIP146351, EIP146352 - WHCK TPM issue.
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - Core5.009 use fixed value to add delay time.
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\Usb\Rt\Usb.c" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\Recovery\ReFlash\ReFlash.c" | EIP150193 FOTA support.
"AmiModulePkg\Recovery\FsRecovery\FsRecovery.c" | EIP153486 Fault Tolerant Function.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\ACPI\mptable.c" | EIP150568 BIOS hanged at checkpoint D9h without any boot devices if user to press "Esc" or "F4" key to exit SETUP.
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.c to svn 164725.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiModulePkg\ACPI\AcpiCore.c" | CSP20140424_23 - Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Gcd\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocal.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"AmiTsePkg\EDK\MiniSetup\BootOnly\MiniSetupLocalx64.lib" | EIP141084 - MS USB KB couldn't work on the setup menu (notify.c)
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\Usb\EfiUsbKb.c" | EIP164769 - SCT Execution Test-fail.
"AmiModulePkg\CSM\CsmBsp.c" | EIP168822 - BIOS failed to build in 32bit
"AmiModulePkg\UsbRecovery\UsbRecov.inf" | Usb flash drive fix for recovery.
"AmiModulePkg\CSM\CsmHwInfo.c" | X32 build error.
"AmiValleyViewCpuPkg\Microcode\M0130679901.pdb" | BayTrail-I D0 microcode
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchRootPorts.c" | EIP165615 - Baytrail CRB BayleyBay Fab3 doesn't wake from S3

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-03-31
Visual eBios: RSS.7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.39
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.9
Intel x32 GOP Drivers: 7.2.1004
Intel x64 GOP Drivers: 7.2.1004
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1113
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.3.9
Modules update from last label:
AmiValleyViewCpuPkg - 5.007_AmiValleyViewCpuPkg_015
AmiChipsetModulePkg - 5.008_ValleyviewDM_028
Csm - Csm_7.75_04
Intel Smart Connect Management - 5.008_ISCT_110_06
SmiFlash - 5.001_SmiFlash_13
Vlv2DeviceRefCodePkg - 5.008_Vlv2RefDM_1.3.9b_032
Modules added to this label:
None
Modules removed from last label:
NTFS - 5.004_NTFS_00
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # | Description
167617 | TAT can not execute if MBI driver installed.
156084 | One BIOS cannot support single and dual channel memory with Bay trail CPU
175001 | Enabling Secure Flash causes error to Linux efimgr command
165615 | Baytrail CRB BayleyBay Fab3 doesn't wake from S3
Files changed for EIP fixes:
EIP Ref. # Files Changed
167617
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
156084
  • BayTrailPkg\CRB.sdl
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
175001
  • AmiModulePkg\NVRAM\NvramSmiDxe.c
165615
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchRootPorts.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 7/31/14
Source Control Label: 5.010_VEB_0ACCT016
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF027
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673322
CPU ID: 30678, Microcode Version: M0C30678815, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1004
x64 GOP Driver: 7.2.1004
IGD legacy vBIOS: 3757
EC Firmware: 3.12
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_015
AmiChipsetModule version: ValleyviewDM_029
Vlv2DeviceRefCodePkg version Vlv2RefDM_140_034
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.c" | Avoid assert issue.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiValleyViewCpuPkg\Microcode\M0130679901.pdb" | BayTrail-I D0 microcode

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.39
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.0
Intel x32 GOP Drivers: 7.2.1004
Intel x64 GOP Drivers: 7.2.1004
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.0.1115
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.0
Modules update from last label:
Core - 5.010_Core
AmiModulePkg - AmiModulePkg_23
Foundation - Foundation_06
NvRam - NVRAM_06
Bds - Bds_06
AHCI - AHCI_06
AmiGopPolicy - 5.004_AmiGopPolicy_04
AmiChipsetModulePkg - ValleyviewDM_029
AHCI - AHCI_06
TSE Binary - 5.004_AmiTse_2_17_1245
Setup - Setup_04
ACPI - ACPI_08
IdeBus - IdeBus_04
Serial Redirection - Terminal_05
AmiNetworkPkg - 5.009_AmiNetworkPkg_05
UefiNetworkStack - 5.009_UefiNetworkStack_06
Intel Architecture MdePkg - MdePkg_07
Recovery - 5.009_Recovery_03
Csm - Csm_7.76_05
HddSecurity - HddSecurity_08
PeiRamBoot - 5.001_PeiRamBoot_06
TCG2 - TCG2_02
Usb - AmiUsb_07
UefiCpuPkg - UefiCpuPkg_05
Vlv2DeviceRefCodePkg - Vlv2RefDM_140_034
Modules added to this label:
None
Modules removed from last label:
SynTCGAslVar
TCG - 5.0.0.4_TCG_03
New features added in this label:
None
EIP addressed in this label:
EIP Ref. # Description
Files changed for EIP fixes:
EIP Ref. # Files Changed
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 8/22/14
Source Control Label: 5.010_VEB_0ACCT017
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF028
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673322
CPU ID: 30678, Microcode Version: M0C30678815, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 3757
EC Firmware: 3.12
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_015
AmiChipsetModule version: ValleyviewDM_030
Vlv2DeviceRefCodePkg version Vlv2RefDM_140_035
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.c" | Avoid assert issue.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EDK2 VfrCompiler Syntax Porting Guide cause some Setup Default Value are wrong.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiValleyViewCpuPkg\Microcode\M0130679901.pdb" | BayTrail-I D0 microcode

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.40
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.0
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.1.1115
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
AmiChipsetModulePkg - ValleyviewDM_030
TSE Binary - 5.004_AmiTse_2_17_1246
Vlv2DeviceRefCodePkg - Vlv2RefDM_140_035
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
1.CSP20140805_28 - POST time is slow when VERIFY_BOOT_SUPPORT is enabled.
Files changed in this release:
1.CSP20140805
AmiModulePkg\HashDataPei\PHashDPei.c
EIP addressed in this label:
EIP Ref. # | Description
179821 | BayTrail ChipsetModulePkg Manufacturing defaults different than regular defaults.
180260 | CHIPSEC validation test fail.
177820 | Need dynamic show the EMMC product name and capacity.
180393 | AMIDebugRx loses USB communication after PchInitDxe.
180243 | Using token/elink instead hardcode in DsdtAslW7.asl.
178977 | BIOS capsule update failed with VERIFY_BOOT_SUPPORT = 1.
Files changed for EIP fixes:
EIP Ref. # Files Changed
179821
  • AmiChipsetModulePkg\NB\NbSetup\NbSetup.sdl
  • AmiChipsetModulePkg\NB\NbSetup\NbSetup.c
  • AmiChipsetModulePkg\SB\SbSetup\Sb.sd
180260
  • Vlv2DeviceRefCodePkg\Wrapper\ScBiosWriteProtect\Smm\ScBiosWriteProtect.c
  • Vlv2DeviceRefCodePkg\Wrapper\ScBiosWriteProtect\Smm\ScBiosWriteProtect.inf
177820
  • AmiChipsetModulePkg\SB\SbSetup\SbSetup.c
  • AmiChipsetModulePkg\SB\SbSetup\SbSetup.cif
  • AmiChipsetModulePkg\SB\SbSetup\SbSetup.sdl
  • BayTrailPkg\Crb.sdl
  • AmiChipsetModulePkg\SB\SbSetup\SbSetupEmmcMid.txt
180393
  • AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c
180243
  • Vlv2DeviceRefCodePkg\Wrapper\AcpiAslWrap\AcpiAslWrap.cif
  • Vlv2DeviceRefCodePkg\Wrapper\AcpiTables\DsdtAslW7.asl
  • Vlv2DeviceRefCodePkg\Wrapper\AcpiTables\DsdtAslW7.inf
  • Vlv2DeviceRefCodePkg\Wrapper\Wrapper.sdl
  • Vlv2DeviceRefCodePkg\Wrapper\AcpiAslWrap\DsdtAslW7.txt
178977
  • AmiModulePkg\HashDataPei\PHashDPei.c
  • AmiModulePkg\HashDataPei\PHashDPei.inf
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 9/12/14
Source Control Label: 5.010_VEB_0ACCT018
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF030
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673322
CPU ID: 30678, Microcode Version: M0C30678815, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 3757
EC Firmware: 3.12
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_031
Vlv2DeviceRefCodePkg version Vlv2RefDM_141_037
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0 micorocde is not included by default. Enable M0230671 to include it.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.c" | Avoid assert issue.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EDK2 VfrCompiler Syntax Porting Guide cause some Setup Default Value are wrong.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiValleyViewCpuPkg\Microcode\M0130679901.pdb" | BayTrail-I D0 microcode
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.41
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.1
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.1.1115
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.1
Modules update from last label:
AmiChipsetModulePkg - ValleyviewDM_031
AmiValleyViewCpuPkg - AmiValleyViewCpuPkg_016
Vlv2DeviceRefCodePkg - Vlv2RefDM_141_037
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
1.CSP20140829 - Correct memory information in SETUP(NbSetup.c).
2.CSP20140829 - Disable Silent(Crb.sdl).
Files changed in this release:
1.CSP20140829
AmiChipsetModulePkg\NB\NbSetup\NbSetup.c
BayTrailPkg\Crb.sdl
EIP addressed in this label:
EIP Ref. # | Description
177401 | Kernel-Power Error Event id 137 occurred in Event Viewer after S3/S4 resume.
180903 | System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
181208 | Set BIOS_LOCK_ENABLE enabled by default.
182050 | Hidden built-in EFI shell in setup.
176554 | Wrapper function for BayTrail-M project.
182829 | Support recovery if Set BIOS_LOCK_ENABLE enabled.
180881 | System is hanged in POST 0xA0 when SATA Mode is AHCI.
182845 | Change AmiGopPolicySetupData setup GUID from SETUP_GUID to AMI_GOP_POLICY_VARIABLE_GUID.
178977 | Correct the name from "MICROCODE_ADDRESS" to "HASH_DATA_ADDRESS" for PHashDPei function.
184032 | Set token "TCG2Support" to 1 will cause compile error
Files changed for EIP fixes:
EIP Ref. # Files Changed
177401
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\CpuInit\Dxe\MpCommon.c
180903
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
  • Vlv2DeviceRefCodePkg\Vlv2DeviceRefCodePkg.sdl
181208
  • BayTrailPkg\Crb.sdl
182050
  • BayTrailPkg\Crb.sdl
176554
  • AmiChipsetModulePkg\Include\Library\NbCspLib.h
  • AmiChipsetModulePkg\Include\Library\SbCspLib.h
  • AmiChipsetModulePkg\Include\Library\SbHdaVerbTableLib.h
  • AmiChipsetModulePkg\Include\Sb.h
  • AmiChipsetModulePkg\Include\SbInclude.cif
  • AmiChipsetModulePkg\Library\AmiCspLib\NbGeneric.c
  • AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c
  • AmiChipsetModulePkg\Library\SbHdaVerbTableLib\SbHdaVerbTableLib.c
  • AmiChipsetModulePkg\Library\SbHdaVerbTableLib\SbHdaVerbTableLib.inf
  • AmiChipsetModulePkg\Library\SbLibrary.cif
  • AmiChipsetModulePkg\AmiChipsetModulePkg.dec
  • AmiChipsetModulePkg\AmiChipsetModulePkg.sdl
  • AmiChipsetModulePkg\AmiCspLib.mak
  • AmiChipsetModulePkg\Nb.sdl
  • AmiChipsetModulePkg\Sb.sdl
  • BayTrailPkg\Crb.mak
  • Vlv2DeviceRefCodePkg\Wrapper\Include\Library\ScPolicyInitDxe.h
  • Vlv2DeviceRefCodePkg\Wrapper\Include\AzaliaVerbTable.h
  • Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.c
  • Vlv2DeviceRefCodePkg\Wrapper\Library\ScPolicyInit\Dxe\ScPolicyInitDxe.inf
  • Vlv2DeviceRefCodePkg\Vlv2DeviceRefCodePkg.dec
  • Vlv2DeviceRefCodePkg\Vlv2DeviceRefCodePkg.sdl
182829
  • AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c
  • AmiChipsetModulePkg\Library\SbGetSetupData\SbGetSetupData.inf
  • AmiChipsetModulePkg\Library\SbGetSetupData\SbPeiGetSetupData.inf
180881
  • AmiChipsetModulePkg\SB\SbInit\SbDxe.c
  • AmiChipsetModulePkg\SB\SbInit\SbDxe.inf
  • AmiChipsetModulePkg\SB\SbSetup\SbSetup.c
  • AmiModulePkg\AHCI\AhciBus.c
  • AmiModulePkg\HardwareSignature\HardwareChangeDetect.c
182845
  • Vlv2DeviceRefCodePkg\Wrapper\IntelSaGopSetup\IntelSaGopSetup.sd
178977
  • AmiModulePkg\HashDataPei\PHashDPei.c
184032
  • AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 11/14/14
Source Control Label: 5.010_VEB_0ACCT019
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF031
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673324
CPU ID: 30678, Microcode Version: M0C30678829, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.1.1005
x64 GOP Driver: 7.1.1005
IGD legacy vBIOS: 3757
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_031
Vlv2DeviceRefCodePkg version Vlv2RefDM_141_037
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\OemActivation\OA2\PubKey.bin" | EIP152307 - AFUDOS (Previous BIOS to Test BIOS) fail.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.c" | Avoid assert issue.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP186354:Recovery Update not working anymore.
"AmiChipsetModulePkg\Include\Sb.h" | Incorrect LPSS device ID In Sb.h, device id of LPSS devices.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"AmiValleyViewCpuPkg\Microcode\M0130679902.pdb" | BayTrail-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130673324.pdb" | BayTrail-I B3 microcode

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.41
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.1
Intel x32 GOP Drivers: 7.1.1005
Intel x64 GOP Drivers: 7.1.1005
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.1.1115
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
1.CSP20141009 - S3 resume fail if enable verify boot support.
2.CSP20140829 - EIP186354:Recovery Update not working anymore.
Files changed in this release:
1.CSP20141009
AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c
2.CSP20140829
AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c
EIP addressed in this label:
EIP Ref. # | Description
186471 | Incorrect LPSS device ID In Sb.h, device id of LPSS devices : SPI, HSUART, PWM, DMAC0 are incorrect (it shows 0X1D, should be 0x1E).
186458 | MaxTolud Setting issue in Nb.sd.
185806 | Windows 8 Firmware Update Test-fail / BQA_5.0.0.9_VEB_1AREF024.
180903 | System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
186355 | BYT E3845 CPU frequency can't down to 500MHz
187577 | Exception happens when LEGACY_TO_EFI_DEFAULT = 1
Files changed for EIP fixes:
EIP Ref. # Files Changed
186471
  • AmiChipsetModulePkg\Include\Sb.h
186458
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c
  • AmiChipsetModulePkg\NB\NbSetup\Nb.sd
  • AmiModulePkg\PCI\PciHostBridge.c
185806
  • AmiModulePkg\Recovery\ReFlash\Esrt.c
  • BayTrailPkg\Crb.sdl
180903
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl
186355
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c
187577
  • AmiModulePkg\CSM\Csm.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
8. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. Microcode M0130679902 hangs at 0x31 on Bakersport. It works on Bayley Bay, so M0130679902 is included but disabled by default.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 12/19/14
Source Control Label: 5.010_VEB_0ACCT020
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF033
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673322, M0130673324
CPU ID: 30678, Microcode Version: M0C30678829, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1011
IGD legacy vBIOS: 3757
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_032
Vlv2DeviceRefCodePkg version Vlv2RefDM_142_039
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. BYTI_E3805_WA enables a workaround for the BayTrail-I E3805 headless SKU.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\Usb\Rt\UsbRt.mak" | EIP148801 SUT S5 wake by USB KB/MS issue.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HddSecurity\AmiTseHddSecurity\AmiTseHddSecurity.c" | Avoid assert issue.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\BootScriptHide\BootScriptHideSmm.c" | EIP187331 For Add BootScriptHide Module.
"AmiModulePkg\Include\AmiTcg\TCGMisc.h" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPeiAfterMem\xTcgPeiAfterMem.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPei\xTcgPei.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL" | EIP144299 - [WIN7] Yellow Bang on GPIO device with latest v007 AMI BIOS
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"AmiValleyViewCpuPkg\Microcode\M0130679902.pdb" | BayTrail-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130673324.pdb" | BayTrail-I B3 microcode
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP193988 - Atom E3805 no graphic SKU will hang at 0x69

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.42
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1011
IGD legacy vBIOS: 3757

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.2.1120
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.2
Modules update from last label:
Vlv2DeviceRefCodePkg - Vlv2RefDM_142_039
AmiChipsetModulePkg - ValleyviewDM_032
AmiModulePkg_24
Modules added to this label:
BootScriptHide - BootScriptHide_01
Nvme - NVMe_02
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
192726 | Update TXE firmware to 1.1.2.1120 for 1.375M
190823 | UEFI variables can exceed the maximum value.
188729 | Improve for the fTPM and TPM 1.2 with TCG2.
170031 | Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
187331 | For Add BootScriptHide Module.
Files changed for EIP fixes:
EIP Ref. # Files Changed
192726
  • RomImage\TXE_Region_1.375MB.bin
190823
  • AmiModulePkg\NVRAM\NvramSmiDxe.c
188729
  • AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c
  • AmiModulePkg\TCG2\Common\TcgPei\xTcgPei.c
  • AmiModulePkg\TCG2\Common\TcgPeiAfterMem\xTcgPeiAfterMem.c
  • AmiModulePkg\Include\AmiTcg\TCGMisc.h
170031
  • MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c
  • MdePkg\Library\UefiDevicePathLib\DevicePathToText.c
187331
  • AmiModulePkg\BootScriptHide\BootScriptHideSmm.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. It is expected to have yellow bangs for I2C and SPI in Windows 7 using D0 stepping.
8. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. Microcode M0130679902 hangs at 0x31 on Bakersport. It works on Bayley Bay, so M0130679902 is included but disabled by default.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 1/23/15
Source Control Label: 5.010_VEB_0ACCT021
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF034
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673324, M0130673324
CPU ID: 30678, Microcode Version: M0C3067882D, M0130678806
CPU ID: 30679, Microcode Version: M0130679901
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1011
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_032
Vlv2DeviceRefCodePkg version Vlv2RefDM_142_039.1
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AHCI\AhciBus.c" | SUT hang and restart issue while POST with connecting HDD device if X64_SUPPORT is disabled
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\BootScriptHide\BootScriptHideSmm.c" | EIP187331 For Add BootScriptHide Module.
"AmiModulePkg\Include\AmiTcg\TCGMisc.h" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPeiAfterMem\xTcgPeiAfterMem.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPei\xTcgPei.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"AmiValleyViewCpuPkg\Microcode\M0130679901.PDB" | BayTrail-I D0 uCode
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Usb\Uhcd.c" | EIP194959 - Fix build error if X64_SUPPORT is 0

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.42
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1011
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.2.1120
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
SMM Support - Smm_07
TSE Binary - AmiTse_2_17_1249
HddSecurity - HddSecurity_11
Usb - AmiUsb_10
Modules added to this label:
AmiBufferValidationLib - AmiBufferValidationLib_00
AtaPassThru - 5.004_AtaPassThru_03
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
197680 | Bay Trail M/D Security Vulnerabilities status BAR Issue update
187886 | POST 90h hang during cold boot cycle test
197231 | Review BIOS Writer’s Guide Addendum 1.8
197157 | REF-31771.V25: Source Code Check (Run it First)
199445 | Yellow bangs for GPIO in Windows 7 when GPIO devices are visible
171675 | Enable Console
194648 | Support E3805 BayTrail-I headless CPU SKU
Files changed for EIP fixes:
EIP Ref. # Files Changed
197680
  • AmiModulePkg\Usb\UsbPort.c
  • AmiModulePkg\Usb\UsbSb.c
  • AmiModulePkg\Usb\Rt\Xhci.
  • AmiTsePkg\Core\em\AMITSE\commonoem.c
187886
  • Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c
197231
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c
197157
  • N/A
199445
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c
  • Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PCI_DRC.ASL
171675
  • AmiModulePkg\Terminal\Terminal.sd
194648
  • BayTrailPkg\CRB.sdl
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. Microcode M0130679903 hangs at 0x31 on Bakersport. M0130679903 is included but disabled by default.
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 3/27/15
Source Control Label: 5.010_VEB_0ACCT022
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF037
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678831, M0130678806
CPU ID: 30679, Microcode Version: M0130679903
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1011
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_035
Vlv2DeviceRefCodePkg version Vlv2RefDM_143_041.1
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariable.inf" | Fix build error
"AmiModulePkg\SecureBoot\AuthenticatedVariable\AuthVariableLink.inf" | Fix build error.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\BootScriptHide\BootScriptHideSmm.c" | EIP187331 For Add BootScriptHide Module.
"AmiModulePkg\Include\AmiTcg\TCGMisc.h" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPeiAfterMem\xTcgPeiAfterMem.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPei\xTcgPei.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\Usb\Uhcd.c" | EIP194959 - Fix build error if X64_SUPPORT is 0
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\ConfigMem.c" | EIP204216 and EIP204217 - BWG Addendum 1.9
"AmiModulePkg\Usb\EfiUsbMass.c" | EIP209536 - Run SCT 2.4a on label (INT)0ACCT022a
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;5.004_AMIDebugRx_3.00.003
eModule Reference Name: AMIDebugRxPkg
eModule Source Control Label: 5.004_AMIDebugRx_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Source\Interfaces\AMIDebugRxPkg;5.004_AMIDebugRx_3.00.003
eModule Title: Debugger
eModule Reference Name: Debugger
eModule Source Control Label: 5.004_Debugger_3.00.003
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;5.004_Debugger_3.00.003
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | Off
AMI Build Tools:
Tools Label: 5.004_BuildTools_24_6, Dated: 2014-05-27
Visual eBios: RSS.7.16.0270, Dated: 2014-05-27
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.42
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.3
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1011
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.2.1120
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.4.3
Modules update from last label:
ValleyView Microcode - AmiValleyViewMicrocode_038
AmiChipsetModulePkg - ValleyviewDM_035
AHCI - AHCI_09
Nvme - NVMe_03
Vlv2DeviceRefCodePkg Client - Vlv2RefDM_143_041.1
SdioDriver - SdioDriver_07
Legacy Serial Redirection - LegacySreDir_04
Modules added to this label:
FLASH SMI - FlashSmi_00
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
1. CSP20150121 : Remove unnecessary log message to avoid confusion when PCHS3 entry point is matched
2. CSP20150325: BayTrail-I BWG Addendum 1.9 section A.3 - Fix for system hangs with ECC memory and microcode M0130679903 or above
Files changed in this release:
1. CSP20150121
AmiModulePkg\BootScriptHide\BootScriptHideSmm.c
2. CSP20150325
AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
EIP addressed in this label:
EIP Ref. # | Description
200288 | [Bay Trail- M/D] Security Vulnerabilities status SMM Buffer Issue update
198839 | [AptioV] ASSERT error if connecting SATA controller twice under AHCI mode.
187266 | [BSW] Implement Switchable Graphics module for Braswell platform
203548 | Integrate Bay Trail-M/D Framework BIOS Reference Code Package 1.4.3 for Windows* 10 Beta
205589 | Bay Trail M/D CRB BIOS Rev.93.38 comparison (Setup/policies)
202736 | BayTrail memory ceiling does not raise
204216 | Single channel memory compensation values weren’t initialized correctly
204217 | DDR REFRESH maintenance commands are not being sent during the Initialize Memory
208639 | Change to default XHCI smart auto for Windows 7 mode
208640 | Make eMMC secure erase question based on RC MMC support
209224 | REF-35825.V9: UEFI Windows 8.1 x64 Install - AHCI Mode test failed /(INT)5.010_VEB_1AREF037
209235 | REF-40178.V5: UEFI Win 8.1 x64 Install -PCIe SSD (NVMe Mode) test failed /(INT)5.010_VEB_1AREF037
209256 | REF-42056.V1: Windows 8.1 x64 Install - PCIe SSD (NVMe Mode) test failed /(INT)5.010_VEB_1AREF037
209448 | REF-35822.V6: Windows8.1 x86 installation - AHCI Mode test failed /(INT)5.010_VEB_1AREF037
209536 | Run SCT 2.4a on label (INT)0ACCT022a
Files changed for EIP fixes:
EIP Ref. # Files Changed
200288
  • AmiModulePkg\AHCI\AhciController.c
198839
  • AmiModulePkg\HddSecurity\HddSecurity.c
187266
  • BayTrailPkg\Crb.sdl
203548
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
205589
  • BayTrailPkg\Crb.sdl
202736
  • AmiModulePkg\PCI\PciHostBridge.c
204216
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\ConfigMem.c
204217
  • Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\ConfigMem.c
208639
  • AmiChipsetModulePkg\SB\SbSetup\Sb.sd
208640
  • AmiChipsetModulePkg\SB\SbSetup\Sb.sd
  • BayTrailPkg\Crb.sdl
209224
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
209235
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
209256
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
209448
  • AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
209536
  • AmiModulePkg\Usb\EfiUsbMass.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 7/24/15
Source Control Label: 5.010_VEB_0ACCT023
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF039
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679903
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.1
Vlv2DeviceRefCodePkg version Vlv2RefDM_150_043
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.sdl" | EIP145560 - AFU tool Flash bios not Reserve DMI(get SVN #236191).
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\Bds\Bds.sdl" | EIP144150
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\Setup\TcgSetup.sd" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\TCG2\Common\Tpm20PlatformDxe\Tpm20PlatformDxe.c" | EIP173375 Fix some TPM issues.
"AmiModulePkg\Include\AmiTcg\TcgPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Include\AmiTcg\TcmPc.h" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.cif" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\ShaLib.sdl" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\IA32AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\IA32\Ia32CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemCpy.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64AsmLib\MemSet.asm" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\x64\x64CLib.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\Memory.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\CommonLibraries\ShaLib\TcgMemLib\TcgMemLib.inf" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\Include\AmiTcg\TCGMisc.h" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPeiAfterMem\xTcgPeiAfterMem.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgPei\xTcgPei.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP188729 Improve for the fTPM and TPM 1.2 with TCG2.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\Usb\Uhcd.c" | EIP194959 - Fix build error if X64_SUPPORT is 0
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"AmiModulePkg\TCG2\Common\Setup\TcgPwdTseHook.c" | EIP184032 - Build error when enable TCG2Support
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Usb\EfiUsbMass.c" | EIP209536 - Run SCT 2.4a on label (INT)0ACCT022a
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.0
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.0
Modules update from last label:
ValleyView Microcode - AmiValleyViewMicrocode_040
AmiChipsetModulePkg - ValleyviewDM_036.1
AMIDebugRx - AMIDebugRx_3_02_21
Vlv2DeviceRefCodePkg Client - Vlv2RefDM_150_043
BlockS3Var - BlockS3Var_00
SecureBoot - SecureBoot_14
Modules added to this label:
SerialDebugger - SerialDebugger_3_02_21_01
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
1. CSP20150121 : Remove unnecessary log message to avoid confusion when PCHS3 entry point is matched
2. CSP20150325: BayTrail-I BWG Addendum 1.9 section A.3 - Fix for system hangs with ECC memory and microcode M0130679903 or above
Files changed in this release:
1. CSP20150121
AmiModulePkg\BootScriptHide\BootScriptHideSmm.c
2. CSP20150325
AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm
EIP addressed in this label:
EIP Ref. # | Description
217784 | Integrate Bay Trail-M/D Framework BIOS Reference Code Package 1.5.0 for Windows* 10 Production Version
195032 | GOP driver boots always with default configuration
201247 | [Generic]Building error with Serial Debugger for Baytrail_1AREF033
212613 | Systemic coding errors in AMI BIOS code
212334 | 32bit UEFI Win8(Win8.1) install fail on Baytrail + Legacy vBIOS.
Files changed for EIP fixes:
EIP Ref. # Files Changed
217784
  • N/A
195032
  • AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c
  • AmiModulePkg\Bds\Bds.c
201247
  • PlatformHookLib.inf/SerialPortLib.c/Crb.sdl
212613
  • Terminal.c/ps2main.c/SerialIo.c
212334
  • UefiBiosVideo.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 8/28/15
Source Control Label: 5.010_VEB_0ACCT024
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF040
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679905
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_150_043.1
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\Usb\Uhcd.c" | EIP194959 - Fix build error if X64_SUPPORT is 0
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Usb\EfiUsbMass.c" | EIP209536 - Run SCT 2.4a on label (INT)0ACCT022a
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.0
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.0
Modules update from last label:
AmiModulePkg - AmiModulePkg_28
AmiChipsetModulePkg - ValleyviewDM_036.3
Bds - Bds_08
Vlv2DeviceRefCodePkg Client - Vlv2RefDM_150_043.1
Smbios - Smbios_08
SmiFlash - SmiFlash_17
TCG2 - TCG2_04
Modules added to this label:
None
Modules removed from last label:
SerialDebugger - SerialDebugger_3_02_21_01
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
226550 | Update TCG02 module to label04.
232196/232188 | Build Issue
232100 | Windows selftest Issue
232071 | Speed up finding public and marker binaries when recovery
Files changed for EIP fixes:
EIP Ref. # Files Changed
226550
  • Crb.sdl
232196/232188
  • Misc.c/AmiDxeLib.inf/IsSecRecoveryPEI.inf/S3Resume.inf
232100
  • AmiCpuSmbios.c
232071
  • oa2.c/Crb.sdl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 8/5/16
Source Control Label: 5.010_VEB_0ACCT025
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF042
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_151_044
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Modules update from last label:
BootScriptHide - BootScriptHide_02
OemActivation - OemActivation_05
Ofbd - OFBD_08
Vlv2DeviceRefCodePkg Client - Vlv2RefDM_151_044
Smbios - Smbios_09
SmiFlash - SmiFlash_18
On Flash Block Description (APTIO) - Intel ME Update - Meud_17
SecureFlash,NIST SP800-147 - SecureFlash_13
USB - AmiUsb_16
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
275983 | Update Baytrail I to latest client BIOS
277314 | Build issue when adding SMM FV recovery changes
283273 | SAx0011 CRB Update
Files changed for EIP fixes:
EIP Ref. # Files Changed
275983
  • SmbiosBoard.inf/SmbiosGetFlashData.c/SmmCoreAmiPerformanceProfilingLib.c/IsSecRecovery.c/IsSecRecoveryPEI.inf/SecSMIFlash.c/VerifyFwCapsule.c/VlvInitPeim.inf
277314
  • Csp.sdl
283273
  • N/A
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 8/24/16
Source Control Label: 5.010_VEB_0ACCT026
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF042
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_151_044
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP286007

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
286008 | Ctrl+Alt+Del does not work from EFI Shell
286007 | Check if "Reset System With ME disable Mode" question works on CRB
Files changed for EIP fixes:
EIP Ref. # Files Changed
286008
  • AmiModulePkg\Console\ConSplitter\ConSplit.c
286007
  • AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
1. Validated CTRL+ALT+DEL from EFI Shell
2. Valiated Reset System With ME disable Mode
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 9/23/16
Source Control Label: 5.010_VEB_0ACCT027
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF042
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_151_044
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiCryptoPkg\CryptoLib\PeiCryptLib.inf" | Remove DEBUG_TRACE
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\AmiGopPolicy\AmiGopPolicySetup.c" | Support AMI GOP policy on BayTrail
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiTsePkg\Core\em\AMITSE\commonoem.c" | EIP120622 - The system always hang on PWD prompt after setting power-on PWD.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiModulePkg\HddSecurity\HddSecurity.c" | EIP198839 Fix assert issue when DEBUG_MODE is on.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP141084 - MS USB KB couldn't work on the setup menu
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP286007
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.0.1089
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP Ref. # | Description
285762 | "Reset System With ME disable Mode" menu does not work
288953 | FV_BB is not updated with "AFU /p /b /n" option
289352 | SMBIOS Type16/17/19/20 become invalid.
291241 | Setting token "OA2_SUPPORT" or "GenericSIO_SUPPORT" to 0, codebase 0ACCT built failed
Files changed for EIP fixes:
EIP Ref. # Files Changed
285762
  • AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c
  • AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c
  • Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c
288953
  • AmiModulePkg\SmiFlash\SmiFlash.c
289352
  • AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf
  • AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c
291241
  • BayTrailPkg\CRB.sdl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 1/13/17
Source Control Label: 5.010_VEB_0ACCT028
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF044
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_151_044
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP285762
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Modules update from last label:
TSE Binary - AMITSE_2_18_1263
AmiCryptoPkg - AmiCryptoPkg_026.1
AmiGopPolicy - AmiGopPolicy_07
IdeBus - IdeBus_06
HddSecurity - HddSecurity_19
NVMe - NVMe_13
SdioDriver - SdioDriver_11
Usb - AmiUsb_17
Modules added to this label:
SerialDebugger - Debugger_3_02_21
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP283153 - SAx0011 Vulnerability
EIP283224 - [BayTrail_Client] SAx0011 Vulnerability
EIP288237 - [SA50026][SA50027] Aptio V eModules need to be updated for security issues
EIP295828 - [BayTrail_Client] Modules Update/Function implementation/Bug fixed on BayTrail_Client CRB043 project label
EIP306158 - The board will not boot after updating with AFUEFI /p /b /n when X64_SUPPORT = 0
EIP302680 - [BayTrail_Client] Modules Update/Function implementation/Bug fixed on BayTrail_Client CRB044 project label
EIP312196 - Need to update TXE FW and validate
EIP309084 - BayTrail-I BWG Addendum update A.9
Files changed for EIP fixes:
EIP283153 - N/A
EIP283224 - N/A
EIP288237 - N/A
EIP295828 - N/A
EIP306158 - N/A
EIP302680 - N/A
EIP312196 - TODO
EIP309084 - PchInit.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 3/10/17
Source Control Label: 5.010_VEB_0ACCT029
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF044
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_151_044
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. System May Experience Failure of LPC, USB 2.0 And SD Card Circuitry in Embedded And Industrial Use Conditions. The following tokens can be enabled to extend the LPC circuit life by clock gating when appropriate:
    1. LPC_CIRCUIT_LIFE_EXTENSION_WA: Main switch to enable the LPC circuit life extension workaround by clock gating when appropriate. This is based on the erratum draft published 2/16/17.
    2. LPC_WA_ENABLE_LPC_CLKRUN: Enable LPC CLKRUN# by setting LPC Control Register ILB offset 84h[2] to 1b.
    3. LPC_WA_SET_SERIRQ_QUIET_MODE: Set LPC SCNT (SERIRQ Control) Mode to Quiet Mode in SCNT register ILB offset 10h[7] to 0b.
    4. LPC_WA_DISABLE_SERIRQ: If SERIRQ is unused, set Other Interrupt Control Register ILB offset 60h[12] to 0b.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA2\OA2.c" | EIP232071 - Speed up finding public and marker binaries when recovery
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\NB\NbSetup\Nb.sd" | EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.inf" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchScc.c" | EIP314665
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP320598

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.1
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
Re-enabled USB PEI support by default
Files changed in this release:
None
EIP addressed in this label:
EIP307181 - BayTrail-I BWG Addendum update A.12
EIP315754 - Cannot read/write SD card when eMMC is disabled.
EIP320598 - LPC/USB/SD card circuit issue
Files changed for EIP fixes:
EIP307181 - PchLpss.c
EIP315754 - PchScc.c
EIP320598 - GetSetupData.c, SbPeiBoard.c, CRB.sdl, CrbSetup.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027
5.010_VEB_0ACCT028


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 6/2/17
Source Control Label: 5.010_VEB_0ACCT030
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF046
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679907
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_152_045
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. System May Experience Failure of LPC, USB 2.0 And SD Card Circuitry in Embedded And Industrial Use Conditions. The following tokens can be enabled to extend the LPC circuit life by clock gating when appropriate:
    1. LPC_CIRCUIT_LIFE_EXTENSION_WA: Main switch to enable the LPC circuit life extension workaround by clock gating when appropriate. This is based on the erratum draft published 2/16/17.
    2. LPC_WA_ENABLE_LPC_CLKRUN: Enable LPC CLKRUN# by setting LPC Control Register ILB offset 84h[2] to 1b.
    3. LPC_WA_SET_SERIRQ_QUIET_MODE: Set LPC SCNT (SERIRQ Control) Mode to Quiet Mode in SCNT register ILB offset 10h[7] to 0b.
    4. LPC_WA_DISABLE_SERIRQ: If SERIRQ is unused, set Other Interrupt Control Register ILB offset 60h[12] to 0b.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiModulePkg\CSM\CsmHwInfo.c" | Update it for EIP324741, EIP184371
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"AmiValleyViewCpuPkg\Microcode\M0130679905.pdb" | Latest BYT-I D0 microcode
"AmiValleyViewCpuPkg\Microcode\M0130679907.pdb" | Latest BYT-I D0 microcode
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchScc.c" | EIP314665
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP320598

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.2
Modules update from last label:
Vlv2DeviceRefCodePkg Client: 'Vlv2RefDM_152_045'
Intel-NorthCluster Client: 'ValleyviewDM_NB_033.7'
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
None
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP330232 - [Implement] USB 2.0 Device Lost During System Cold Boot Technical Advisory Rev. 1.1 March 2017
Files changed for EIP fixes:
EIP330232 - Flat32.asm
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027
5.010_VEB_0ACCT028
5.010_VEB_0ACCT029


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 7/21/17
Source Control Label: 5.010_VEB_0ACCT031
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF047
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0130679908
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_152_045
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. System May Experience Failure of LPC, USB 2.0 And SD Card Circuitry in Embedded And Industrial Use Conditions. The following tokens can be enabled to extend the LPC circuit life by clock gating when appropriate:
    1. LPC_CIRCUIT_LIFE_EXTENSION_WA: Main switch to enable the LPC circuit life extension workaround by clock gating when appropriate. This is based on the erratum draft published 2/16/17.
    2. LPC_WA_ENABLE_LPC_CLKRUN: Enable LPC CLKRUN# by setting LPC Control Register ILB offset 84h[2] to 1b.
    3. LPC_WA_SET_SERIRQ_QUIET_MODE: Set LPC SCNT (SERIRQ Control) Mode to Quiet Mode in SCNT register ILB offset 10h[7] to 0b.
    4. LPC_WA_DISABLE_SERIRQ: If SERIRQ is unused, set Other Interrupt Control Register ILB offset 60h[12] to 0b.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiModulePkg\CSM\CsmHwInfo.c" | Update it for EIP324741, EIP184371
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | Removed IRQ programming to allow PCI bus driver to handle.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchScc.c" | EIP314665
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP320598
"AmiValleyViewCpuPkg\Microcode\M0130679908.PDB" | Updated to newest uCode.
"AmiModulePkg\FlashDriver\Flash.c" | EIP344144
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" | EIP347466

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
Updated to uCode 908.
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP344144 - [Bay Trail_Embedded] SA50037 - BIOS update failure vulnerability
EIP347098 - A.13 UART Not Functional on Win* 8.1 64 bit
EIP342491 - REF-32310.V4: PXE Boot
EIP347466 - Some physical memory address is cleared to 0 after S3 resume.
EIP348699 - Build fails if USB_DEBUG_MESSAGES = 1
Files changed for EIP fixes:
EIP344144 - Flash.c
EIP347098 - PchLpss.c
EIP342491 - PxeBcDhcp6.c
EIP347466 - SbDxe.c
EIP348699 - Xhci.c
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027
5.010_VEB_0ACCT028
5.010_VEB_0ACCT029
5.010_VEB_0ACCT030


Appendix A

BIOS Update Instructions

Intel EDKII BIOS present on board:

AMI flash utilities cannot update from and EDKII BIOS to an AMI AptioV BIOS, or vice versa. A dediprog can be used via Bayley Bay header J7A2.

AMI AptioV BIOS Update (AFUEFI):

Note: A BIOS setup option needs to be enabled to flash the TXE region (via the /me AFU tag). Enter BIOS setup and enable Advanced->Security Configuration->TXE HMRFPO.

1. Place AFUEFI and the BIOS image on removable media and attach to system
2. Boot to EFI Shell
3. Run AFUEFI with the following command: "AFUEFI 0ACCT0xx.bin /p /b /n /k /me" where 'xx' is the BIOS version
4. Reboot


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2014 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


BayTrail Release Notes: C:/Aptio/Projects/BayTrail/CHM/Files Directory Reference

BayTrail Release Notes
  • Main Page
  • CHM
  • Files
Files Directory Reference

Files

file | 0ACCT000 Unit Test.htm
file | 0ACCT001 Unit Test.htm
file | 0ACCT002 Unit Test.htm
file | 0ACCT003 Unit Test.htm
file | 0ACCT004 Unit Test.htm
file | 0ACCT005 Unit Test.htm
file | 0ACCT006 Unit Test.htm
file | 0ACCT007 Unit Test.htm
file | 0ACCT008 Unit Test.htm
file | 0ACCT009 Unit Test.htm
file | 0ACCT010 Unit Test.htm
file | 0ACCT011 Unit Test.htm
file | 0ACCT012 Unit Test.htm
file | 0ACCT013 Unit Test.htm
file | 0ACCT014 Unit Test.htm
file | 0ACCT015 Unit Test.htm
file | 0ACCT016 Unit Test.htm
file | 0ACCT017 Unit Test.htm
file | 0ACCT018 Unit Test.htm
file | 0ACCT019 Unit Test.htm
file | 0ACCT020 Unit Test.htm
file | 0ACCT021 Unit Test.htm
file | 0ACCT022 Unit Test.htm
file | 0ACCT023 Unit Test.htm
file | 0ACCT024 Unit Test.htm
file | 0ACCT025 Unit Test.htm
file | 0ACCT027 Unit Test.htm
file | 0ACCT028 Unit Test.htm
file | 0ACCT029 Unit Test.htm
file | 0ACCT030 Unit Test.htm
file | 0ACCT031 Unit Test.htm
file | 0ACCT032 Unit Test.htm
file | 5.007_VEB_0ACCT000.htm
file | 5.007_VEB_0ACCT001.htm
file | 5.008_VEB_0ACCT002.htm
file | 5.008_VEB_0ACCT003.htm
file | 5.008_VEB_0ACCT004.htm
file | 5.008_VEB_0ACCT005.htm
file | 5.008_VEB_0ACCT006.htm
file | 5.008_VEB_0ACCT007.htm
file | 5.009_VEB_0ACCT008.htm
file | 5.009_VEB_0ACCT009.htm
file | 5.009_VEB_0ACCT010.htm
file | 5.009_VEB_0ACCT011.htm
file | 5.009_VEB_0ACCT012.htm
file | 5.009_VEB_0ACCT013.htm
file | 5.009_VEB_0ACCT014.htm
file | 5.009_VEB_0ACCT014a.htm
file | 5.009_VEB_0ACCT015a.htm
file | 5.010_VEB_0ACCT016.htm
file | 5.010_VEB_0ACCT017.htm
file | 5.010_VEB_0ACCT018.htm
file | 5.010_VEB_0ACCT019.htm
file | 5.010_VEB_0ACCT020.htm
file | 5.010_VEB_0ACCT021.htm
file | 5.010_VEB_0ACCT022.htm
file | 5.010_VEB_0ACCT023.htm
file | 5.010_VEB_0ACCT024.htm
file | 5.010_VEB_0ACCT025.htm
file | 5.010_VEB_0ACCT026.htm
file | 5.010_VEB_0ACCT027.htm
file | 5.010_VEB_0ACCT028.htm
file | 5.010_VEB_0ACCT029.htm
file | 5.010_VEB_0ACCT030.htm
file | 5.010_VEB_0ACCT031.htm
file | ami.jpg
file | Appendix A.htm
file | Copyright.htm
file | icon_box_nda.jpg
file | Release Notes.htm
file | style.css
Generated on Mon Nov 13 2017 09:07:06 for BayTrail Release Notes by doxygen 1.8.10


BayTrail Release Notes: C:/Aptio/Projects/BayTrail/CHM Directory Reference

BayTrail Release Notes
  • Main Page
  • CHM
CHM Directory Reference

Directories

directory Files
Generated on Mon Nov 13 2017 09:07:06 for BayTrail Release Notes by doxygen 1.8.10


BIOS Information:
AMI BIOS Core: 5.010_Core
Release Date: 11/17/17
Source Control Label: 5.010_VEB_0ACCT032
Source Control Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Embedded/;
Reference BIOS Label: 5.010_VEB_1AREF048
Reference BIOS Location: SS: AptioV_SS;$/AptioV/Projects/Intel/BayTrail/BayTrail_Client/;
Platform Information:
Platform Name 1: Bayley Bay, Revision: 3
Platform Name 2: Bakersport, Revision: 2
SOC: BayTrail-I, Stepping: D0
CPU ID: 30671, Microcode Version: M0230671117
CPU ID: 30672, Microcode Version: M0230672213, M0C30672216, M013067222D
CPU ID: 30673, Microcode Version: M0C30673325, M0130673324
CPU ID: 30678, Microcode Version: M0C30678833, M0130678806
CPU ID: 30679, Microcode Version: M0F30679909
Memory: DDR3, Frequency: 1066 / 1333 (CPU determine memory frequency)
x32 GOP Driver: 7.2.1011
x64 GOP Driver: 7.2.1013
IGD legacy vBIOS: 3798
EC Firmware: 3.14
CoreVersion 5.010_Core
CPU version: 5.007_AmiValleyViewCpuPkg_016
AmiChipsetModule version: ValleyviewDM_036.3
Vlv2DeviceRefCodePkg version Vlv2RefDM_152_045
Project Use:
1. Module "Embedded Controller" is for the CRB EC, customers can disable or remove the module for their board.
2. When EC_SUPPORT or CRB_EC_SUPPORT is disabled:
  • KSC revision is displayed as N/A in setup.
  • EC_TIMEOUT_VAL is set to 0. This token specifies the timeout value when checking if an EC is present.
  • ENABLE_OVERRIDE_SUPPORT is set to 1. When this token is enabled the BoardId, BoardRev, and MemCfgId are controlled by tokens OVERRIDE_BOARD_ID, OVERRIDE_BOARD_REV, and OVERRIDE_MEMCFG_ID. Possible values for OVERRIDE_BOARD_ID:
    1. 0x0 = Alpine Valley
    2. 0x2 = BayLake (RVP)
    3. 0x3 = BayLake (FFRD8)
    4. 0x4 = BayLake (FFRD)
    5. 0x5 = BayLake (RVP_DDR3L)
    6. 0x7 = PPV-STHI
    7. 0x20 = Bayley Bay
    8. 0x30 = Bakersport
    9. 0x90 = Crestview Hills
  • The BIOS_CONFIG register in the Punit needs to be configured based on ECC support and the # of memory channels supported by the CPU SKU. This can be accomplished by one of the two methods below. Method 1 takes precedence when enabled.

    Method 1 - ECC support is defined at build time and the # of memory channels is detected during runtime:
    Enable NO_EC_AUTO_DETECT_SKU and set ECC_SUPPORTED based on the board configuration.
    Method 2 - Both ECC support and # of memory channels are defined at build time:
    Set BIOS_CONFIG_REG_VAL based on the board configuration:
    1. 0 = Premium/High/Intermediate SKU + 2 channel without ECC
    2. 3 = Premium/High/Intermediate SKU + 1 channel with ECC
    3. 1 = Premium/High/Intermediate SKU + 1 channel without ECC
    4. 2 = Mid/Entry SKU + 1 channel with ECC
    5. 1 = Mid/Entry SKU + 1 channel without ECC
3. BayTrail A0, B0, and B1 microcode are not included by default. Enable M0230671 and/or M0230672 and/or M0130672 to include them.
4. PCIE_VGA_WORKAROUND enables a 1 second delay when detecting offboard PCIe graphics cards.
5. IVI_PF_ENABLE enables support for the BayTrail IVI platform.
6. PLATFORM_GUID and FW_VERSION_GUID tokens must be set to unique values for each customer project.
7. For memory down suppport set MRC_MEMORY_DOWN_SUPPORT = 2 and configure the following tokens:
    1. OEM_RANK_EN = Ranks Present / {[Channel_0][Rank_0], [Channel_0][Rank_1], [Channel_1][Rank_0], [Channel_1][Rank_1]}
    2. OEM_DIMM_DWIDTH = DRAM device data width 00:x8, 01:x16, 02:x32 / {Channel_0, Channel_1}
    3. OEM_DIMM_DENSITY = DRAM device data density 00:1Gbit, 01:2Gbit,02:4Gbit,03:8Gbit / {Channel_0, Channel_1}
    4. OEM_DRAM_SPEED = DRAM speed / 00:800, 01:1066, 02:1333, 03:1600
    5. OEM_DRAM_TYPE = DRAM type / 00:DDR3, 01:DDR3L, 02:DDR3U, 03:DDR3All, 04:LPDDR2, 05:LPDDR3, 06:DDR4
    6. OEM_DIMM_MEMDOWM = Memory down support / 0:DIMM, 1:Memory Down
    7. OEM_DIMM_BUSWIDTH = DRAM Bus Width 00:8 bits; 01:16bits, 02:32bits, 03:64bits / {Channel_0, Channel_1}
    8. OEM_DIMM_SIDES = DRAM ranks per dimm 00:1rank, 01:2ranks, 02:3ranks, 03:4ranks / {Channel_0, Channel_1}
    9. OEM_DRAM_TCL = Actual CL
    10. OEM_DRAM_TRP_TRCD = TRP and tRCD in dram clk
    11. OEM_DRAM_TWR = Dram Clock for tWR
    12. OEM_DRAM_TWTR = Dram Clock for tWTR
    13. OEM_DRAM_TRRD = Dram Clock for tRRD
    14. OEM_DRAM_TRTP = Dram Clock for tRTP
    15. OEM_DRAM_TFAW = Dram Clock for tFAW
8. Default GPIOs are configured via tokens in GPIO.sdl and programmed in InitGpio() in SbPei.c. These can be overriden in higher priority SDL files. These following GPIOs are modified during runtime after programming the token values:
  • When the Board ID is configured for Bakersport: ConfigureUSBULPI() and DisableRTD3() in SbPei.c set up GPIOs for ULPI and RTD3.
  • If ADJUST_GPIO_SUPPORT is enabled then customers can port the following GPIO settings in Sb.sdl:
    1. ADJUST_AUDIO_TABLE
    2. ADJUST_OSSELECT_TABLE
    3. ADJUST_I2C5_TABLE
    4. ADJUST_I2C6_TABLE
    5. ADJUST_UART0_TABLE
    6. ADJUST_UART1_TABLE
    7. ADJUST_MISC0_TABLE
    8. ADJUST_MISC1_TABLE
  • MMC GPIOs are configured in ConfigureSoCGpio() in SbPeiBoard.c.
  • PWM, HSUART, SPI, I2C, SDIO, and SDCARD GPIOs are configured in ConfigureLpssAndSccGpio() in SbPeiBoard.c.
  • Internal SoC UART and additional HSUART GPIOs are configured in UARTInit() in SbPeiBoard.c.
9. Intel Trusted Execution Engine (TXE) Firmware is included with each release in the "Rom Image" component. Customers should port the respective XML files for their requirements and hardware. The following tokens can be enabled to build full 8MB binaries that include the BIOS and different TXE FW:
    1. TXE_1_25MB_SUPPORT: BayTrail-M/D Thin FW
    2. TXE_1_375MB_SUPPORT: BayTrail-M/D PR FW
    3. TXE_1_5MB_SUPPORT: BayTrail-M/D FW
    4. TXE_3MB_SUPPORT: BayTrail-M/D Full FW
    5. BYTI_FEAT_TXE_SUPPORT: BayTrail-I Feature FW
    6. BYTI_SLIM_TXE_SUPPORT: BayTrail-I Slim FW
    7. BYTI_DUAL_BOOT_TXE_SUPPORT: BayTrail-I Dual Boot FW (Default Build)
10. System May Experience Failure of LPC, USB 2.0 And SD Card Circuitry in Embedded And Industrial Use Conditions. The following tokens can be enabled to extend the LPC circuit life by clock gating when appropriate:
    1. LPC_CIRCUIT_LIFE_EXTENSION_WA: Main switch to enable the LPC circuit life extension workaround by clock gating when appropriate. This is based on the erratum draft published 2/16/17.
    2. LPC_WA_ENABLE_LPC_CLKRUN: Enable LPC CLKRUN# by setting LPC Control Register ILB offset 84h[2] to 1b.
    3. LPC_WA_SET_SERIRQ_QUIET_MODE: Set LPC SCNT (SERIRQ Control) Mode to Quiet Mode in SCNT register ILB offset 10h[7] to 0b.
    4. LPC_WA_DISABLE_SERIRQ: If SERIRQ is unused, set Other Interrupt Control Register ILB offset 60h[12] to 0b.
Secure Flash:
Secure flash signing keys are removed from the project.
OEM's are supposed to generate their own keys to build secure binaries. To generate the keys and build secure binaries the steps below should be followed:
  1. Generate a Unique Platform Root Signing Key (.prikey, .pubkey files) using KeyGen.exe available in AmiCryptoPkg. Use the command: $(PROJECT_DIR)\AmiCryptoPkg\Utils\keygen .prikey .pubkey
  2. Copy the .prikey and .pubkey files to folder path $(PROJECT_DIR)\Keys\FW
  3. Enable the SecureMod_SUPPORT token
  4. Start the build process
With Secure Flash enabled, BIOS update on top of previous labels using AFU tools will fail if new signing keys are generated for the new label. Retaining the same signing keys that are used in previous releases will not cause this failure. If new keys are generated for every release then the steps below should be followed before updating the BIOS:
  1. Copy the .prikey file from the previous label source, rename it as Old.prikey and add it to the $(PROJECT_DIR)\Keys\FW folder of the new label source.
  2. Enable the SDL token Secure_Key_Update.
  3. Build new label source and use this BIOS image as input to AFU utilities.
It is recommended to retain signing keys while updating the source with new BayTrail labels.
Platform File List:
File Name | Description
BayTrail.cif | Platform component information file
ReleaseNotes.chm | This file for release notes

Platform Module | Description
Bay Trail Client | Chipset Reference Board module
AmiValleyViewCpuPkg | ValleyView CPU support

Platform File Update in this Release:
File Name | TAG | Description
None | N/A | N/A

Private File List:

[Show file list]

[Hide file list]

File Name | Description
"ReleaseNotes.chm" | This file.
"AmiPkg\Configuration\Main.mak" | Add support for Notebook and Desktop build
"AmiChipsetPkg\AmiChipsetPkg.dec" | for DP function
"AmiChipsetPkg\Include\Guid\Guid.cif" | for DP function
"AmiChipsetPkg\Include\Guid\TscFrequency.h" | for DP function
"AmiChipsetPkg\Include\Ppi\SbPpi.h" | For Customer Ppi support
"AmiCompatibilityPkg\Board\OemPort.c" | EIP148452 - After Core5.009, the function use fixed value to add delay time.
"AmiCompatibilityPkg\Smbios\SmbiosBoard\SmbiosBoard.inf" | EIP131027 - SMBIOS type 17 memory manufacturer shows wrong information.
"AmiCompatibilityPkg\Smbios\SmbiosGetFlashData\SmbiosGetFlashData.c" | BayTrail Build x32 hang at 0x70.
"AmiModulePkg\ACPI\ACPI.inf" | Didn't need gEfiCpuArchProtocolGuid.
"AmiModulePkg\ACPI\ACPI.sd" | Didn't support S1
"AmiModulePkg\ACPI\BootScriptExecuter.c" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptPrivate.h" | For S3 data save.
"AmiModulePkg\ACPI\BootScriptSave.c" | For S3 data save.
"AmiModulePkg\ACPI\DsdtAsl.inf" | For add the fRC acpi table
"AmiModulePkg\ACPI\S3Resume.c" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\S3Resume.inf" | EIP135119 Improve POST Time & S3 Resume Time.
"AmiModulePkg\ACPI\AcpiBaseLib.c" | CSP20140424_23 Update RC 1.3.8 cause Win7 S3 resume fail.
"AmiModulePkg\AHCI\AhciController.c" | EIP132329 The OS can't be installed from SATA ODD in X32 build
"AmiModulePkg\Bds\Bds.c" | For connect the efi system.
"AmiModulePkg\Bds\Bds.inf" | Modify for security.
"AmiModulePkg\FastBoot\FastBoot.c" | Improve POST time. ; EIP132936 AptioV ErrorDisplayFramework hang up on BayTrail platform while "SIO_SUPPORT" is set to "0".
"AmiModulePkg\Flash\SPI\ICHx\SPIFlash.c" | EIP137034 Sync up SPI initialization code in BYT-DM CRB BIOS with BYT-DM Reference Code.
"AmiModulePkg\Flash\FlashLib.inf" | EIP157825 Baytrail build issue for FlashDeviceWriteEnable().
"AmiModulePkg\GenericSio\GenericSio.c" | Fix "reconnect -r" issue.
"AmiModulePkg\GenericSio\PS2_KB.ASL" | Fix PS2 keyboard can't work.
"AmiModulePkg\GenericSio\PS2_MS.ASL" | Fix PS2 mouse can't work.
"AmiModulePkg\GenericSio\SioDynamicSetup.inf" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\GenericSio\SioDynamicSetup.c" | EIP156767 Dynamic SIO Configuration link in setup disappers after disabling all SIO devices available => SioDynamicSetup.inf to latest.
"AmiModulePkg\NVRAM\NvramDxe.c" | EIP136901 - Authorized Timestamps (DBT) won't be installed when install default Secure Boot Keys. Secure Boot will be disabled after flashing BIOS. EIP137431 AuthVar_Func test failed. CSP20131017 WHCK test TPM fail..
"AmiModulePkg\NVRAM\NvramDxe.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmm.inf" | Modify for security. ; EIP135354 update NvramDxe function
"AmiModulePkg\NVRAM\NvramSmiDxe.c" | EIP151328 The system has weak performance in UEFI PXE LAN download.
"AmiModulePkg\OemActivation\OA3\OA3.c" | EIP140254 Update T_ACPI_OEM_ID and T_ACPI_OEM_TBL_ID in OA module
"AmiModulePkg\PCI\PciBus.c" | Fix system hang while plugging PCIe card.
"AmiModulePkg\PCI\PciHostBridge.c" | Fix allocate memory method, EIP126704 Implement the function for the dynamic MMIO size change on BayTrail D/M platform, EIP132395 Full EMMC support on BYT-DM platform.
"AmiModulePkg\PCI\PciRootBridge.inf" | Fix allocate memory method.
"AmiModulePkg\PCI\PciStaticSetup.sd" | Default disable HW Auto Width/Speed
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBootPei.inf" | Fix building error.
"AmiModulePkg\PeiRamBoot\Pei\PeiRamBoot.c" | EIP141743
"AmiModulePkg\PS2CTL\PS2Ctl.inf" | Fix building error.
"AmiModulePkg\RomLayout\RomLayout.sdl" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutHooks.txt" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.inf" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutDxe.c" | Update file to newer check-in version.
"AmiModulePkg\RomLayout\RomLayoutPei.c" | Update file to newer check-in version.
"AmiModulePkg\SecureFlash\SecSMIFlash\SecSMIFlash.c" | Support Capsule feature.
"AmiModulePkg\SecureFlash\SecSMIFlash\VerifyFwCapsule.c" | Avoid flash fail
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecovery.c" | EIP144785 - Support Windows 8.x firmware update (ESRT).
"AmiModulePkg\SecureFlash\SecFlashUpd\FwCapsuleInfo.c" | EIP153486 Fault Tolerant Function.
"AmiModulePkg\SmiFlash\SmiFlash.c" | For implement flash the FV_PRE_BB_BLOCKS and Microcode Blocks.
"AmiModulePkg\Recovery\UpdateCapsule.c" | EIP155099 Fixing Windows firmware update when FWCAPSULE_FILE_FORMAT=0.
"AmiModulePkg\Usb\Rt\Xhci.c" | Use periodic SMI for XHCI.
"AmiModulePkg\Usb\UsbPort.c" | EIP128872 Need CSM support in Bay Trail M/D.
"AmiModulePkg\Usb\UsbSb.c" | Add periodic SMI support for XHCI.
"AmiModulePkg\BoardInfo\AmiBoardInfo2.c" | EIP148558 - RC 1.3.1.
"AmiModulePkg\IdeBus\IdeBus.c" | CSP20140330_22 - Fix some VerifyBoot Function issue.
"AmiValleyViewCpuPkg\Dxe\AmiPpmPolicy\AmiPpmPolicy.sd" | Refer to Intel BIOS, change S0ix default value to disbale.
"AmiValleyViewCpuPkg\Library\PlatformSecLib\Ia32\Flat32.asm" | Add CRB check to program BIOS_CONFIG register dynamically
"AmiValleyViewCpuPkg\Library\PlatformSecLib\PlatformSecLib.inf" | EIP153486 Fault Tolerant Function.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.c" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCommunication\PiSmmCommunicationSmm.inf" | EIP135016 UEFI (IA32FamilyCpuPkg) modification.
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.c" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\SmmFeatures.h" | Enable SMRR
"IA32FamilyCpuPkg\PiSmmCpuDxeSmm\PiSmmCpuDxeSmm.inf" | Enable SMRR
"MdeModulePkg\Core\DxeIplPeim\X64\VirtualMemory.c" | EIP148973 - System resets on legacy boot using B2/B3 stepping.
"MdeModulePkg\Universal\Capsule.sdl" | Fix build error when X64_SUPPORT is "0".
"AmiModulePkg\Recovery\ReFlash\TempRomLayout.c" | Update temp romlayout for BayTrail-DM.
"AmiModulePkg\HardwareSignature\HardwareChangeDetect.c" | EIP180881 - System is hanged in POST 0xA0 when SATA Mode is AHCI.
"AmiModulePkg\Recovery\ReFlash\Esrt.c" | EIP185806- Windows 8 Firmware Update Test-fail.
"MdePkg\Library\UefiDevicePathLib\DevicePathFromText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"MdePkg\Library\UefiDevicePathLib\DevicePathToText.c" | EIP170031 Fix UEFI SCT 2.4 DevicePathToTextProcotolTest and DevicePathFromTextProcotolTest.
"AmiValleyViewCpuPkg\Setup\Cpu.sd" | EIP205589
"AmiModulePkg\AtaPassThru\AtaPassThru.c" | x32 build fix
"AmiModulePkg\AmiGopPolicy\AmiGopPolicy.c" | EIP195032
"AmiModulePkg\Terminal\Terminal.c" | EIP212613
"AmiModulePkg\PS2CTL\ps2main.c" | EIP212613
"AmiModulePkg\Terminal\SerialIo.c" | EIP212613
"AmiModulePkg\CSM\CsmVideo\UefiBiosVideo.c" | EIP212334
"AmiModulePkg\TCG2\Common\AmiTcgPlatformPei\AmiTpm20PlatformPei.c" | EIP226550
"AmiModulePkg\Include\AmiTcg\Tpm20Pei.h" | EIP226550
"AmiModulePkg\TCG2\Common\TcgPei\TrEEPei.inf" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\tpm.asl" | EIP226550
"AmiModulePkg\TCG2\Common\Tpm20Acpi\Tpm20Acpi.c" | EIP226550
"AmiModulePkg\AmiModulePkg.dec" | EIP226550
"SecurityPkg\SecurityPkg.sdl" | EIP226550
"AmiModulePkg\TCG2\Common\TcgDxe\xTcgDxe.c" | EIP226550
"AmiCompatibilityPkg\Library\Misc.c" | EIP232196/EIP232188 : Fix build issue
"AmiCompatibilityPkg\Library\AmiDxeLib.inf" | EIP232196/EIP232188 : Fix build issue
"AmiModulePkg\SecureFlash\SecFlashUpd\IsSecRecoveryPEI.inf" | EIP232196/EIP232188 : Fix build issue
"AmiValleyViewCpuPkg\Dxe\AmiCpuSmbios\AmiCpuSmbios.c" | EIP232100 smbios 3.0 fix
"AmiModulePkg\Library\SmmCoreAmiPerformanceProfilingLib\SmmCoreAmiPerformanceProfilingLib.c" | EIP259936
"AmiChipsetModulePkg\Library\SbRuntimeServiceLib\SbRuntimeServiceLib.c" | EIP265304
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\PiSmmCore.inf" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmCore.sdl" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.c" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.h" | EIP288532
"MdeModulePkg\Core\PiSmmCore\SmmMemLib.inf" | EIP288532
"Keys\Variables\dbx" | EIP286667
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp4.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcDhcp6.h" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\PxeBcImpl.c" | EIP288237
"AmiNetworkPkg\UefiNetworkStack\Common\UefiPxeBcDxe\UefiPxeBcDxe.inf" | EIP288237
"AmiModulePkg\Ofbd\Meud\Platform\CspMeud.c" | EIP131757 - Afu update TXE fail. Error message: BIOS does not support ME Entire Firmware update .
"AmiModulePkg\Ofbd\Meud\Setup\InitMeudString.c" | EIP285762
"AmiModulePkg\Console\ConSplitter\ConSplit.c" | EIP285753
"AmiCompatibilityPkg\Smbios\Smbios.c" | EIP296850
"AmiModulePkg\Library\SmmAmiBufferValidationLib\SmmAmiBufferValidationLib.c" | EIP288953, EIP306158
"MdePkg\MdePkg.dec" | EIP302680
"MdePkg\Include\Protocol\DiskInfo.h" | EIP302680
"MdePkg\Include\Library\DebugLib.h" | EIP302680
"AmiModulePkg\CSM\CsmHwInfo.c" | Update it for EIP324741, EIP184371
"AmiModulePkg\FlashDriver\Flash.c" | EIP341497 - [Bay Trail_Client] SA50037 - BIOS update failure vulnerability.
"AmiModulePkg\PCI\PciBus.inf" | EIP357397 - [SAx0039][FSRT] Security Disclosures from Intel
"AmiModulePkg\Bds\Bds.sdl" | EIP357397 - [SAx0039][FSRT] Security Disclosures from Intel
"AmiChipsetModulePkg\SB\SbInit\SbDxe.c" 1. EIP357393 - [SAx0039] SPI opcode Security Vulnerability
2. EIP355841 - [Bay Trail_Client] Some physical memory address is cleared to 0 after S3 resume.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInitDxe.inf" | EIP357393 - [SAx0039] SPI opcode Security Vulnerability
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchInit.c" | EIP357393 - [SAx0039] SPI opcode Security Vulnerability
"AmiModulePkg\TCG2\Common\TcgDxe\TcgDxe.c" | Fix building error when X64_SUPPORT is "0".
"AmiChipsetModulePkg\SB\SbSetup\Sb.sd" | Enabled devices for BayTrail-I by default.
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\Platform.asl" | Fix for ACPI 5.0 ASL that caused Win7 BSOD. System could not resume from S3 after VERIFY_BOOT_SUPPORT is set to 1.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Pei\MemoryInit.c" | For EIP128845 - hang with 2 dimms. EIP186458 - MaxTolud Setting issue in Nb.sd.
"AmiChipsetModulePkg\Library\AmiCspLib\SbGeneric.c" | fix CPP check error.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\VlvInitPeim.c" | For EIP130068 - hang at 0xB2 with DEBUG_MODE disabled
"AmiValleyViewCpuPkg\Microcode\M0230671117.PDB" | Add latest BayTrail A0 microcode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchPm.c" | Fix for USB not working in Linux.
"MdeModulePkg\Core\Dxe\Gcd\Gcd.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Page.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\Mem\Pool.c" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"MdeModulePkg\Core\Dxe\DxeMain.h" | For EIP130612 - Unable to legacy boot when X64_SUPPORT enabled
"Vlv2DeviceRefCodePkg\Wrapper\LpssDxe\LpssDxe.c" | For EIP134595 - eMMC fix for legacy Windows
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchScc.asl" | Backport ACPI 5.0 code for Windows 7
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\Platform.c" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\MemoryInit\Src32\Imemory.h" | EIP136572 - fix for Bakersport platform check
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\PchLpss.asl" | Enable AuthenTec AES2750
"Vlv2DeviceRefCodePkg\Wrapper\PlatformPei\PlatformPei.inf" | Include PeiKscLib for getting BoardId
"AmiChipsetModulePkg\SB\SbInit\SbPei.c" | Bakersport specific changes
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchLpss.c" | Fix to only configure resources when ACPI mode is enabled, otherwise PCI bus driver handles it.
"AmiChipsetModulePkg\SB\SbInit\SbPeiBoard.c" | Fixed LPSS Interrupts enabling in PCI mode.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchSmiDispatcher\Smm\PchSmmUsb.c" | EIP141653 - Bay Trail with KbcEmulation
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnPDxe.h" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.c" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\Pnp\Dxe\PnpDxe.inf" | EIP147465 - Fedora hang issue when running audio video concurrency on Bakersport
"AmiModulePkg\VirtualSerial\VirtualSerial.c" | EIP147463 - Validate Windows 8 x64 on BayTrail-IVI
"Vlv2DeviceRefCodePkg\AcpiTablesPCAT\HOST_BUS.ASL" | Revert back M1MX subtraction so Windows 7 doesn't reboot.
"AmiModulePkg\AmiStatusCode\StatusCodeMapPei.c" | EIP159334 - If the system boot up without memory, there isn't warning beep.
"Vlv2DeviceRefCodePkg\ValleyView2Soc\CPU\PowerManagement\Library\Silvermont\Smm\SilvermontPpmLib.c" | EIP186355 - BYT E3845 CPU frequency can't down to 500MHz
"AmiModulePkg\CSM\Csm.c" | EIP187577 - Exception happens when LEGACY_TO_EFI_DEFAULT = 1
"Vlv2DeviceRefCodePkg\Wrapper\SmmPTDispatch2OnSmmPTDispatchThunk\SmmPTDispatch2OnSmmPTDispatchThunk.c" | SMM Timer Dispatch 2 Protocol not PI compliant
"AmiValleyViewCpuPkg\Dxe\CpuDxeBoard\CpuDxeBoard.c" | EIP194241 - AP's micrcode is not loaded with BayTrail-I E3805 CPU
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Dxe\GraphicsDxeInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"Vlv2DeviceRefCodePkg\Wrapper\Library\NcPolicyInit\Pei\NcPolicyInitPei.c" | EIP187886 - POST 90h hang during cold boot cycle test
"Vlv2DeviceRefCodePkg\ValleyView2Soc\NorthCluster\VlvInit\Pei\GraphicsInit.c" | EIP194648 - Support E3805 BayTrail-I headless CPU SKU
"AmiModulePkg\Terminal\Terminal.sd" | EIP171675 - Enable Console
"AmiModulePkg\Sdio\SdioController.c" | Removed unneeded delay.
"AmiModulePkg\Sdio\SdioDriver.c" | Removed unneeded delay.
"Vlv2DeviceRefCodePkg\Wrapper\SeCPolicyInitDxe\SeCPolicyInitDxe.c" | EIP285762
"Vlv2DeviceRefCodePkg\ValleyView2Soc\SouthCluster\PchInit\Dxe\PchScc.c" | EIP314665
"AmiChipsetModulePkg\Library\SbGetSetupData\GetSetupData.c" | EIP320598
"AmiValleyViewCpuPkg\Microcode\M0130679908.PDB" | BayTrail-I uCode.
"AmiValleyViewCpuPkg\Microcode\M0F30679909.PDB" | BayTrail-I uCode.

AMI DebugRX & AMI Debugger Support:
Required eModule(s)
eModule Title: AMIDebugRx
eModule Reference Name: AMIDebugRx
eModule Source Control Label: AMIDebugRx_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\AMIDebugRx;AMIDebugRx_3_02_21
eModule Reference Name: Debugger
eModule Source Control Label: Debugger_3_02_21
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\Debugger;Debugger_3_02_21
Token Setting
Token Name | Value
AMIDEBUG_RX_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
SeriaI Debugger Support:
Required eModule(s)
eModule Title: SerialDebugger
eModule Reference Name: SerialDebugger
eModule Source Control Label: SerialDebugger_3_02_21_01
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\SerialDebugger;SerialDebugger_3_02_21_01
eModule Reference Name: RxAuthentication
eModule Source Control Label: 5.004_AMIDebugRx_3.01.0011
eModule Source Control Location: SS: AptioV: $\AptioV\Binary\Modules\RxAuthentication; 5.004_AMIDebugRx_3.01.0011
Token Setting
Token Name | Value
SERIAL_DEBUGGER_SUPPORT | ON
DEBUG_MODE | ON
Notes: None
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-30
Visual eBios: RSS.7.17.0325, Dated: 2015-03-30
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Intel BIOS Writer’s Guide and BIOS Specification Update in this Release:
RS - Valleyview - M and D SoC BIOS Writer's Guide(BWG): 1.43
Reference or 3rd Party code in this Release:
Bay Trail-M/D Framework BIOS Reference Code: 1.5.2
Intel x32 GOP Drivers: 7.2.1011
Intel x64 GOP Drivers: 7.2.1013
IGD legacy vBIOS: 3798

BayTrail-M/D TXE FW:
Intel TXE 1.25 MB Version: 1.0.4.1089
Intel TXE 1.375 MB Version: 1.1.4.1145
Intel TXE 1.5 MB Version: 1.1.0.1073
Intel TXE 3 MB Version: 1.0.4.1089

BayTrail-I TXE FW:
Intel TXE Slim 1.25 MB Version: 1.0.2.1067
Intel TXE Dual Boot 1.375 MB Version: 1.1.5.1162
Intel TXE Feature 3 MB Version: 1.0.2.1060v5

Reference or 3rd Party code updated in this Release:
None
Modules update from last label:
None
Modules added to this label:
None
Modules removed from last label:
None
New features added in this label:
Updated to M0F30679909 microcode
General Bug Fixes:
None
Files changed in this release:
None
EIP addressed in this label:
EIP #355841 [Bay Trail_Client] Some physical memory address is cleared to 0 after S3 resume.
EIP #357393 [SAx0039] SPI opcode Security Vulnerability
EIP #358409 [SAx0039][5.004_Flash_14/11/10/09/08] SPI security update
EIP #357397 [SAx0039][FSRT] Security Disclosures from Intel
EIP #365588 REF-46694.V5: BIOS Basic Test failed
EIP #373470 Duplicate CRST table
Files changed for EIP fixes:
EIP #355841 - SbDxe.c
EIP #357393 - PchInitDxe.inf, PchInit.c
EIP #358409 - SPIFlash.c
EIP #357397 - PciBus.c
EIP #365588 - Crb.sdl
EIP #373470 - Crb.sdl
Limitations in this label:
1. The serial port of Bayley Bay is used via SoC, not nine pin COM port.
2. Windows 7 doesn't natively support XHCI. EHCI or XHCI Smart Auto should be used for Windows 7.
3. The top USB port of Bayley Bay J1A2 only works in XHCI mode.
4. There are two different EHCI and XHCI mode setup questions depending on the "OS Selection" question. USB should be configured AFTER changing "OS Selection".
5. The system will hang at 0x92 when disabling all LPSS/SCC devices except SD Card.
6. It is expected to have yellow bangs for HS-UARTs in Windows 8.x and WES 8.
7. BayTrail CPU SKUs that only support single channel memory will fail S3 resume when both DIMM channels are populated on the CRB. This is expected behavior.
Known issues in this label:
1. Unable to boot legacy Windows with a Matrox G550 PCIe card.
2. System hangs at checkpoint 0x2A with BayTrail A0 on soft resets.
3. System will hang at blinking cursor when executing "reconnect -r" in EFI Shell.
4. AMI Debug Rx in checkpoint mode can cause the system to boot slowly after trace from Debug Rx fails to output (EIP175924).
Remaining Issues:
None
Unit Testing:
Refer to Unit Tests
Validation Testing:
None
BIOS Update Instructions:
Refer to Appendix A
Release History:
5.007_VEB_0ACCT000
5.007_VEB_0ACCT001
5.008_VEB_0ACCT002
5.008_VEB_0ACCT003
5.008_VEB_0ACCT004
5.008_VEB_0ACCT005
5.008_VEB_0ACCT006
5.008_VEB_0ACCT007
5.009_VEB_0ACCT008
5.009_VEB_0ACCT009
5.009_VEB_0ACCT010
5.009_VEB_0ACCT011
5.009_VEB_0ACCT012
5.009_VEB_0ACCT013
5.009_VEB_0ACCT014
5.009_VEB_0ACCT014a
5.009_VEB_0ACCT015a
5.010_VEB_0ACCT016
5.010_VEB_0ACCT017
5.010_VEB_0ACCT018
5.010_VEB_0ACCT019
5.010_VEB_0ACCT020
5.010_VEB_0ACCT021
5.010_VEB_0ACCT022
5.010_VEB_0ACCT023
5.010_VEB_0ACCT024
5.010_VEB_0ACCT025
5.010_VEB_0ACCT026
5.010_VEB_0ACCT027
5.010_VEB_0ACCT028
5.010_VEB_0ACCT029
5.010_VEB_0ACCT030
5.010_VEB_0ACCT031