American Megatrends, Inc.

RomImageReleaseNotes

Copyright

Release Notes

© American Megatrends, Inc.


Release Notes - NDA Required

Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-07-30
TXE FW Version: 1.0.0.1049
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop.bat" | For generating Desktop 8MB bin files.
"fitcbuildNotebook.bat" | For generating Notebook 8MB bin files.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.0.0.7.000
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE Region.bin" | TXE Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-04-18
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:

© American Megatrends Inc.


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-08-19
TXE FW Version: 1.0.0.1058
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop.bat" | For generating Desktop 8MB bin files.
"fitcbuildNotebook.bat" | For generating Notebook 8MB bin files.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.0.0.7.000
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE Region.bin" | TXE Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-04-18
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-09-13
TXE FW Version: 1.0.2.1060
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop.bat" | For generating Desktop 8MB bin files.
"fitcbuildNotebook.bat" | For generating Notebook 8MB bin files.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.0.0.7.000
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE Region.bin" | TXE Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-04-18
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-10-18
TXE FW Version: 1.0.2.1067
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop.bat" | For generating Desktop 8MB bin files.
"fitcbuildNotebook.bat" | For generating Notebook 8MB bin files.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.0.0.7.000
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE Region.bin" | TXE Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-04-18
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-11-05
Intel TXE 1.25MB version: 1.0.2.1067
Intel TXE 1.5MB version: 1.1.0.1073
Intel TXE 3MB version: 1.0.2.1060
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop8MB_TXE1.5MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.5MB.
"fitcbuildDesktop8MB_TXE1.25MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.25MB.
"fitcbuildDesktop8MB_TXE3MB.bat" | For generating Desktop 8MB bin files inculde TXE 3MB.
"fitcbuildNotebook8MB_TXE1.5MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.5MB.
"fitcbuildNotebook8MB_TXE1.25MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.25MB.
"fitcbuildNotebook8MB_TXE3MB.bat" | For generating Notebook 8MB bin files inculde TXE 3MB.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.1.0.1073
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE_Region_1.5MB.bin" | TXE 1.5MB Region
"TXE_Region_1.25MB.bin" | TXE 1.25MB Region
"TXE_Region_3MB.bin" | TXE 3MB Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_22, Dated: 2013-10-09
Visual eBios: RSS.7.15.0244, Dated: 2013-10-09
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
Release History:


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2013-12-30
Intel TXE 1.25MB version: 1.0.2.1067
Intel TXE 1.5MB version: 1.1.0.1073
Intel TXE 3MB version: 1.0.2.1060
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop8MB_TXE1.5MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.5MB.
"fitcbuildDesktop8MB_TXE1.25MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.25MB.
"fitcbuildDesktop8MB_TXE3MB.bat" | For generating Desktop 8MB bin files inculde TXE 3MB.
"fitcbuildNotebook8MB_TXE1.5MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.5MB.
"fitcbuildNotebook8MB_TXE1.25MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.25MB.
"fitcbuildNotebook8MB_TXE3MB.bat" | For generating Notebook 8MB bin files inculde TXE 3MB.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.1.0.1073
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE_Region_1.5MB.bin" | TXE 1.5MB Region
"TXE_Region_1.25MB.bin" | TXE 1.25MB Region
"TXE_Region_3MB.bin" | TXE 3MB Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region”
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft’s Windows Driver Kit (WDK) Ver. 7600.16385.1
EIP addressed in this label:
1.EIP143190 - Implement Verified Boot function
Files changed for EIP fixes:
1.EIP143190 - Implement Verified Boot function
RomImage\BayTrail_Notebook_8MB_TXE_3MB.xml
RomImage\BayTrail_Notebook_8MB_TXE_1_25MB.xml
RomImage\BayTrail_Notebook_8MB_TXE_1_5MB.xml
RomImage\BayTrail_Desktop_8MB_TXE_3MB.xml
RomImage\BayTrail_Desktop_8MB_TXE_1_25MB.xml
RomImage\BayTrail_Desktop_8MB_TXE_1_5MB.xml
Release History:


Component Information:
Component Title: Intel ROM Image
Component Reference Name: None
Component Type: eModule
Release Date: 2015-07-01
Intel TXE 1.25MB version: 1.0.4.1089
Intel TXE 1.375MB version: 1.1.4.1145
Intel TXE 1.5MB version: 1.1.0.1073
Intel TXE 3MB version: 1.0.4.1089
Release Note:
None
Component Description:
Tell what the Component does.
This is a caption
Filename | Description
"ROMIMAGE.SDL" | This SDL file
"fitcbuildDesktop8MB_TXE1.5MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.5MB.
"fitcbuildDesktop8MB_TXE1.25MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.25MB.
"fitcbuildDesktop8MB_TXE1.375MB.bat" | For generating Desktop 8MB bin files inculde TXE 1.375MB.
"fitcbuildDesktop8MB_TXE3MB.bat" | For generating Desktop 8MB bin files inculde TXE 3MB.
"fitcbuildNotebook8MB_TXE1.5MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.5MB.
"fitcbuildNotebook8MB_TXE1.25MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.25MB.
"fitcbuildNotebook8MB_TXE1.375MB.bat" | For generating Notebook 8MB bin files inculde TXE 1.375MB.
"fitcbuildNotebook8MB_TXE3MB.bat" | For generating Notebook 8MB bin files inculde TXE 3MB.
"fitc.exe" | Integrated the latest FITC tool from the kit. version 1.1.0.1089
"fitctmpl.xml" | Updated the XML file to generate temp images from the kit.
"newfiletmpl.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_1.375MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Desktop_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.5MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.25MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_1.375MB.xml" | Updated the XML file to generate temp images from the kit.
"BayTrail_Notebook_8MB_TXE_3MB.xml" | Updated the XML file to generate temp images from the kit.
"fitc.ini" | Fitc ini file
"TXE_Region_1.5MB.bin" | TXE 1.5MB Region
"TXE_Region_1.25MB.bin" | TXE 1.25MB Region
"TXE_Region_1.375MB.bin" | TXE 1.25MB Region
"TXE_Region_3MB.bin" | TXE 3MB Region
"vsccommn.bin" | vsccommn.bin
"RomImageReleaseNotes.chm" | release note
Firmware Binaries:
VLV_SEC_REGION.bin: TXE Region
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft Windows Driver Kit (WDK) Ver. 7600.16385.1
EIP addressed in this label:
None
Files changed for EIP fixes:
Update Intel TXE 1.375MB version from 1.1.2.1120 to 1.1.4.1145
Release History:

©?American Megatrends Inc.


Function by File Name

AMIBIOS Function Reference

By File Name

The following is a list of the source files.
For a list in alphabetical order, see In Alphabetical Order.

Built on 12:24:04 11/20/14


Functions in Alphabetical Order

AMIBIOS Function Reference

In Alphabetical Order

The following topics provide a list in alphabetical order.
For a list by file name, see By File Name.

Built on 12:24:04 11/20/14


AMIBIOS Function Reference

General Information

Built on 12:24:04 11/20/14


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2011 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.