AmiChipsetPkg: Data Structures

AmiChipsetPkg AmiChipsetPkg_13
Data Structures
Here are the data structures with brief descriptions:
C _ACPI_DISPATCH_LINK
C _AMI_GNB_PCI_SSID_TABLE_STRUCT
C _AMI_GPIO_INIT_PPI
C _AMI_PEI_GNB_CUSTOM_PPI
C _AMI_PEI_NBINIT_POLICY_PPI
C _AMI_PEI_SB_CUSTOM_PPI
C _AMI_PEI_SBINIT_POLICY_PPI
C _AMI_SB_PCI_SSID_TABLE_STRUCT
C _EFI_ACPI_DISPATCH_PROTOCOL
C _EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL
C _EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL
C _EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL
C _GENERIC_LINK
C _NB_ECC_INFO
C _NB_ERROR_INFO
C _NB_ERROR_LOG_DISPATCH_LINK
C _NB_PCIE_INFO
C _PEI_BASE_MEMORY_TEST_PPI
C _SB_PCIE_ERR
C _SB_PCIE_ERROR_LOG_DISPATCH_LINK
C AMI_CSP_SMBUS_HOB
C AMI_MEMORY_ARRAY_INFO
C AMI_MEMORY_INFO
C CMOS_BAD_HOB
C MEMORY_SLOT_INFO
C RTC_DATE_ALARM_REG
C RTC_MONTH_ALARM_REG
C RTC_REG_A
C RTC_REG_B
C RTC_REG_C
C RTC_REG_D
C SB_HDD_POLICY_PROTOCOL
C TIME_VARIABLE
Generated by doxygen 1.8.14


AmiChipsetPkg: _ACPI_DISPATCH_LINK Struct Reference

Data Fields
_ACPI_DISPATCH_LINK Struct Reference

Data Fields

IN ACPI_DISPATCH_LINK * | Link
IN EFI_ACPI_DISPATCH | Function
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/AcpiModeEnable.h


AmiChipsetPkg: _AMI_GNB_PCI_SSID_TABLE_STRUCT Struct Reference

Data Fields
_AMI_GNB_PCI_SSID_TABLE_STRUCT Struct Reference

Data Fields

UINT64 | PciAddr
UINT32 | Sid
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/GnbPpi.h


AmiChipsetPkg: _AMI_GPIO_INIT_PPI Struct Reference

Data Fields
_AMI_GPIO_INIT_PPI Struct Reference

Data Fields

UINT32 | GpioBaseAddr
VOID * | GpioTable
UINTN | TableSize
BOOLEAN | InitDefaultGpioSetting
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/SbPpi.h


AmiChipsetPkg: _AMI_PEI_GNB_CUSTOM_PPI Struct Reference

Data Fields
_AMI_PEI_GNB_CUSTOM_PPI Struct Reference

#include <GnbPpi.h>

Data Fields

AMI_GNB_PCI_SSID_TABLE_STRUCT * SsidTable

Detailed Description

The AMI_PEI_GNB_CUSTOM_PPI interfaces are used to provide AMI interface for customer

The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/GnbPpi.h


AmiChipsetPkg: _AMI_PEI_NBINIT_POLICY_PPI Struct Reference

Data Fields
_AMI_PEI_NBINIT_POLICY_PPI Struct Reference

Data Fields

UINTN unFlag
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/NbPpi.h


AmiChipsetPkg: _AMI_PEI_SB_CUSTOM_PPI Struct Reference

Data Fields
_AMI_PEI_SB_CUSTOM_PPI Struct Reference

Data Fields

AMI_GPIO_INIT_PPI * | GpioInit
AMI_SB_PCI_SSID_TABLE_STRUCT * | SsidTable
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/SbPpi.h


AmiChipsetPkg: _AMI_PEI_SBINIT_POLICY_PPI Struct Reference

Data Fields
_AMI_PEI_SBINIT_POLICY_PPI Struct Reference

Data Fields

UINTN unFlag
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/SbPpi.h


AmiChipsetPkg: _AMI_SB_PCI_SSID_TABLE_STRUCT Struct Reference

Data Fields
_AMI_SB_PCI_SSID_TABLE_STRUCT Struct Reference

Data Fields

UINT64 | PciAddr
UINT32 | Sid
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/SbPpi.h


AmiChipsetPkg: _EFI_ACPI_DISPATCH_PROTOCOL Struct Reference

Data Fields
_EFI_ACPI_DISPATCH_PROTOCOL Struct Reference

Data Fields

EFI_ACPI_REGISTER | Register
EFI_ACPI_UNREGISTER | UnRegister
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/AcpiModeEnable.h


AmiChipsetPkg: _EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL Struct Reference

Data Fields
_EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL Struct Reference

Data Fields

EFI_NB_ERROR_LOG_REGISTER | Register
EFI_NB_ERROR_LOG_UNREGISTER | UnRegister
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h


AmiChipsetPkg: _EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL Struct Reference

Data Fields
_EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL Struct Reference

Data Fields

EFI_SB_PCIE_ERROR_LOG_REGISTER | Register
EFI_SB_PCIE_ERROR_LOG_UNREGISTER | UnRegister
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/SbSmiProtocol.h


AmiChipsetPkg: _EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL Struct Reference

Data Fields
_EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL Struct Reference

Data Fields

EFI_SMM_BIOS_WRITE_REGISTER | Register
EFI_SMM_BIOS_WRITE_UNREGISTER | UnRegister
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/SmmBiosWriteDispatch.h


AmiChipsetPkg: _GENERIC_LINK Struct Reference

Data Fields
_GENERIC_LINK Struct Reference

Data Fields

void * Link
The documentation for this struct was generated from the following files:
  • AmiChipsetPkg/Include/Protocol/AcpiModeEnable.h
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h
  • AmiChipsetPkg/Include/Protocol/SbSmiProtocol.h


AmiChipsetPkg: _NB_ECC_INFO Struct Reference

Data Fields
_NB_ECC_INFO Struct Reference

Data Fields

UINT32 | Correctable:1
UINT32 | UnCorrectable:1
UINT32 | EccErrDimmNum:2
UINT32 | Reserved:28
UINT32 | EccErrLog0
UINT32 | EccErrLog1
UINT32 | Ch0EccErrLog0
UINT32 | Ch0EccErrLog1
UINT32 | Ch1EccErrLog0
UINT32 | Ch1EccErrLog1
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h


AmiChipsetPkg: _NB_ERROR_INFO Struct Reference

Data Fields
_NB_ERROR_INFO Struct Reference

Data Fields

UINT8 | ErrorType
NB_ECC_INFO | EccErrorInfo
NB_PCIE_INFO | PcieErrorInfo
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h


AmiChipsetPkg: _NB_ERROR_LOG_DISPATCH_LINK Struct Reference

Data Fields
_NB_ERROR_LOG_DISPATCH_LINK Struct Reference

Data Fields

IN NB_ERROR_LOG_DISPATCH_LINK * | Link
IN EFI_NB_ERROR_LOG_DISPATCH | Function
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h


AmiChipsetPkg: _NB_PCIE_INFO Struct Reference

Data Fields
_NB_PCIE_INFO Struct Reference

Data Fields

UINT8 | Bus
UINT8 | Dev
UINT8 | Fun
UINT16 | VendorId
UINT16 | DeviceId
UINT16 | PciCommand
UINT16 | PciStatus
UINT16 | PciCCode
UINT16 | PcieStatus
UINT32 | PortType
UINT8 | Version
UINT16 | SecondaryStatus
UINT16 | BridgeControl
BOOLEAN | Correctable
BOOLEAN | NonFatal
BOOLEAN | Fatal
BOOLEAN | ParityError
BOOLEAN | SystemError
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h


AmiChipsetPkg: _PEI_BASE_MEMORY_TEST_PPI Struct Reference

Data Fields
_PEI_BASE_MEMORY_TEST_PPI Struct Reference

Data Fields

PEI_BASE_MEMORY_TEST BaseMemoryTest
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Ppi/BaseMemoryTest.h


AmiChipsetPkg: _SB_PCIE_ERR Struct Reference

Data Fields
_SB_PCIE_ERR Struct Reference

Data Fields

UINT32 | PcieAddress
UINT8 | Bus
UINT8 | Dev
UINT8 | Fun
UINT16 | VendorId
UINT16 | DeviceId
UINT16 | PciCommand
UINT16 | PciStatus
UINT16 | PciCCode
UINT16 | PcieStatus
UINT32 | PortType
UINT8 | Version
UINT16 | SecondaryStatus
UINT16 | BridgeControl
BOOLEAN | Correctable
BOOLEAN | NonFatal
BOOLEAN | Fatal
BOOLEAN | ParityError
BOOLEAN | SystemError
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/SbSmiProtocol.h


AmiChipsetPkg: _SB_PCIE_ERROR_LOG_DISPATCH_LINK Struct Reference

Data Fields
_SB_PCIE_ERROR_LOG_DISPATCH_LINK Struct Reference

Data Fields

IN SB_PCIE_ERROR_LOG_DISPATCH_LINK * | Link
IN EFI_SB_PCIE_ERROR_LOG_DISPATCH | Function
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/SbSmiProtocol.h


AmiChipsetPkg: AMI_CSP_SMBUS_HOB Struct Reference

Data Fields
AMI_CSP_SMBUS_HOB Struct Reference

Data Fields

EFI_HOB_GUID_TYPE | Header
UINT8 | BoardReservedAddressCount
UINT32 | BoardReservedAddressList
UINT8 | ArpDeviceCount
UINT8 | ArpDeviceList [1]
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Guid/AmiCspHobs.h


AmiChipsetPkg: AMI_MEMORY_ARRAY_INFO Struct Reference

Data Fields
AMI_MEMORY_ARRAY_INFO Struct Reference

Data Fields

MEMORY_TYPE_INFO | RamType
UINT32 | MaxCapacity
UINT32 | TotalMemory
UINT32 | Speed
MEMORY_SLOT_INFO | Slot [DIMM_SLOT_NUM]
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/AmiMemInfo.h


AmiChipsetPkg: AMI_MEMORY_INFO Struct Reference

Data Fields
AMI_MEMORY_INFO Struct Reference

Data Fields

AMI_MEMORY_ARRAY_INFO MemoryArray [MEMORY_ARRAY_NUM]
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/AmiMemInfo.h


AmiChipsetPkg: CMOS_BAD_HOB Struct Reference

Data Fields
CMOS_BAD_HOB Struct Reference

Data Fields

EFI_HOB_GUID_TYPE | Header
BOOLEAN | Health
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: MEMORY_SLOT_INFO Struct Reference

Data Fields
MEMORY_SLOT_INFO Struct Reference

Data Fields

UINT32 | Size
BOOLEAN | DoubleSide
BOOLEAN | Ecc
UINT8 | SpdAddr
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/AmiMemInfo.h


AmiChipsetPkg: RTC_DATE_ALARM_REG Union Reference

Data Fields
RTC_DATE_ALARM_REG Union Reference

Data Fields

UINT8 REG_DATE_ALARM
struct {
UINT8 DateAlarm: 6
UINT8 Reserved: 2
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: RTC_MONTH_ALARM_REG Union Reference

Data Fields
RTC_MONTH_ALARM_REG Union Reference

Data Fields

UINT8 REG_MONTH_ALARM
struct {
UINT8 MonthAlarm: 6
UINT8 Reserved: 2
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: RTC_REG_A Union Reference

Data Fields
RTC_REG_A Union Reference

Data Fields

UINT8 REG_A
struct {
UINT8 RateSel: 4
UINT8 Divisor: 3
UINT8 UpdInProgr: 1
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: RTC_REG_B Union Reference

Data Fields
RTC_REG_B Union Reference

Data Fields

UINT8 REG_B
struct {
UINT8 DaylightSav: 1
UINT8 Mode: 1
UINT8 Format: 1
UINT8 SquareWave: 1
UINT8 UpdateInt: 1
UINT8 AlarmInt: 1
UINT8 PeriodicInt: 1
UINT8 Set: 1
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: RTC_REG_C Union Reference

Data Fields
RTC_REG_C Union Reference

Data Fields

UINT8 REG_C
struct {
UINT8 Reserved: 4
UINT8 UpdEndFlag: 1
UINT8 AlarmFlag: 1
UINT8 PeriodicFlag: 1
UINT8 IrqFlag: 1
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: RTC_REG_D Union Reference

Data Fields
RTC_REG_D Union Reference

Data Fields

UINT8 REG_D
struct {
UINT8 DateAlarm: 6
UINT8 Reserved: 1
UINT8 DataValid: 1
};
The documentation for this union was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: SB_HDD_POLICY_PROTOCOL Struct Reference

Data Fields
SB_HDD_POLICY_PROTOCOL Struct Reference

Data Fields

GENERATE_PORT_NUMBER GeneratePortNumber
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Protocol/SbSataProtocol.h


AmiChipsetPkg: TIME_VARIABLE Struct Reference

Data Fields
TIME_VARIABLE Struct Reference

Data Fields

INT16 | TimeZone
UINT8 | Daylight
The documentation for this struct was generated from the following file:
  • AmiChipsetPkg/Include/Guid/Rtc.h


AmiChipsetPkg: Data Structure Index

Data Structure Index
_ | a | c | m | r | s | t
_
_ACPI_DISPATCH_LINK
_AMI_GNB_PCI_SSID_TABLE_STRUCT
_AMI_GPIO_INIT_PPI
_AMI_PEI_GNB_CUSTOM_PPI
_AMI_PEI_NBINIT_POLICY_PPI
_AMI_PEI_SB_CUSTOM_PPI
_AMI_PEI_SBINIT_POLICY_PPI
_AMI_SB_PCI_SSID_TABLE_STRUCT
_EFI_ACPI_DISPATCH_PROTOCOL
_EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL
_EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL
_EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL
_GENERIC_LINK
_NB_ECC_INFO
_NB_ERROR_INFO
_NB_ERROR_LOG_DISPATCH_LINK
_NB_PCIE_INFO
_PEI_BASE_MEMORY_TEST_PPI
_SB_PCIE_ERR
_SB_PCIE_ERROR_LOG_DISPATCH_LINK
a
AMI_CSP_SMBUS_HOB
AMI_MEMORY_ARRAY_INFO
AMI_MEMORY_INFO
c
CMOS_BAD_HOB
m
MEMORY_SLOT_INFO
r
RTC_DATE_ALARM_REG
RTC_MONTH_ALARM_REG
RTC_REG_A
RTC_REG_B
RTC_REG_C
RTC_REG_D
s
SB_HDD_POLICY_PROTOCOL
t
TIME_VARIABLE
_ | a | c | m | r | s | t


AmiChipsetPkg: File List

File List
Here is a list of all documented files with brief descriptions:
[detail level 1234]
▼ AmiChipsetPkg
▼ Include
▼ Guid
AmiCspHobs.h
Rtc.h
▼ Library
AmiChipsetIoLib.h
AmiChipsetRuntimeServiceLib.h
▼ Ppi
BaseMemoryTest.h
GnbPpi.h
NbPpi.h
SbPpi.h
▼ Protocol
AcpiModeEnable.h
AmiMemInfo.h
NbSmiProtocol.h
SbSataProtocol.h
SbSmiProtocol.h
SmmBiosWriteDispatch.h
▼ Library
▼ AmiChipsetIoLib
AmiChipsetIoLib.c
▼ AmiCspSmmBootScriptLibNull
AmiCspSmmBootScriptLibNull.c


AmiChipsetPkg: AmiChipsetPkg Directory Reference

  • AmiChipsetPkg
AmiChipsetPkg Directory Reference


AmiChipsetPkg: AmiChipsetPkg/Include Directory Reference

  • AmiChipsetPkg
  • Include
Include Directory Reference

Directories

Generated by doxygen 1.8.14


AmiChipsetPkg: AmiChipsetPkg/Include/Guid Directory Reference

  • AmiChipsetPkg
  • Include
  • Guid
Guid Directory Reference

Files

file | AmiCspHobs.h
file | Rtc.h


AmiChipsetPkg: AmiChipsetPkg/Include/Guid/AmiCspHobs.h File Reference

  • AmiChipsetPkg
  • Include
  • Guid
Data Structures
AmiCspHobs.h File Reference

Data Structures

struct AMI_CSP_SMBUS_HOB

Detailed Description

Definitions of AMI Chipset specific Hobs.


AmiChipsetPkg: AmiChipsetPkg/Include/Guid/Rtc.h File Reference

  • AmiChipsetPkg
  • Include
  • Guid
Data Structures | Variables
Rtc.h File Reference

Data Structures

struct | TIME_VARIABLE
union | RTC_REG_A
union | RTC_REG_B
union | RTC_REG_C
union | RTC_REG_D
union | RTC_DATE_ALARM_REG
union | RTC_MONTH_ALARM_REG
struct | CMOS_BAD_HOB

Variables

EFI_GUID | gEfiTimeVariableGuid
EFI_GUID | gAmiCmosBadHobGuid

Detailed Description

Real Time Clock and CMOS Data bank register definitions.


AmiChipsetPkg: AmiChipsetPkg/Include/Library Directory Reference

  • AmiChipsetPkg
  • Include
  • Library
Library Directory Reference

Files

file | AmiChipsetIoLib.h
file | AmiChipsetRuntimeServiceLib.h


AmiChipsetPkg: AmiChipsetPkg/Include/Library/AmiChipsetIoLib.h File Reference

  • AmiChipsetPkg
  • Include
  • Library
Functions
AmiChipsetIoLib.h File Reference

Functions

UINTN | CspGetPciExpressBaseAddress (VOID)
UINT8 EFIAPI | FindCapPtr (IN UINTN PciAddress, IN UINT8 CapId)
UINT16 EFIAPI | FindExtendedCapPtr (IN UINTN PciAddress, IN UINT16 CapId)
UINT8 EFIAPI | ReadIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8)
VOID EFIAPI | WriteIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8, IN UINT8 WriteValue8)
VOID EFIAPI | RwIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | WriteIo8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT8 WriteValue8)
VOID EFIAPI | WriteIo16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT16 WriteValue16)
VOID EFIAPI | WriteIo32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT32 WriteValue32)
VOID EFIAPI | RwIo8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwIo16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwIo32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBaseReg16, IN UINT32 SetBit32, IN UINT32 ResetBit32)
VOID EFIAPI | WriteIo8IdxDataS3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBase16, IN UINT8 IoReg8, IN UINT8 Value8)
VOID EFIAPI | RwIo8IdxDataS3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT16 IoBase16, IN UINT8 IoReg8, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | WritePci8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT8 WriteValue8)
VOID EFIAPI | WritePci16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT16 WriteValue16)
VOID EFIAPI | WritePci32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT32 WriteValue32)
VOID EFIAPI | RwPci8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwPci16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwPci32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT32 SetBit32, IN UINT32 ResetBit32)
VOID EFIAPI | WriteMem8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT8 Value)
VOID EFIAPI | WriteMem16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT16 Value)
VOID EFIAPI | WriteMem32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT32 Value)
VOID EFIAPI | RwMem8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwMem16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwMem32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *mBootScriptSave, IN UINTN Address, IN UINT32 SetBit32, IN UINT32 ResetBit32)

Detailed Description

This file contains AMI chipset porting I/O Library functions and data structure definitions.

Function Documentation

◆ FindCapPtr()

UINT8 EFIAPI FindCapPtr | ( | IN UINTN | PciAddress,
 |  | IN UINT8 | CapId
 | ) |  |

This function searches the PCI address space for the PCI device specified for a particular capability ID and returns the Capability ID Offset if one found

Parameters
PciAddress | - The PCI-E MMIO address of the register.
CapId | - CAPID to search for, CAPID list: 0x01 = PCI Power Management Interface 0x10 = PCI Express Capability
Return values
Capability ID Offset if one found. Otherwise returns 0

◆ FindExtendedCapPtr()

UINT16 EFIAPI FindExtendedCapPtr | ( | IN UINTN | PciAddress,
 |  | IN UINT16 | CapId
 | ) |  |

This function Search and return the offset of desired PCI Express Capability ID

Parameters
PciAddress | - The PCI-E MMIO address of the register.
CapId | - CAPID to search for, CAPID list: 0x0001 = Advanced Error Reporting Capability 0x0002 = Virtual Channel Capability 0x0003 = Device Serial Number Capability 0x0004 = Power Budgeting Capability
Return values
Extended Capability ID Offset if one found, Otherwise returns 0

◆ ReadIo8IdxData()

UINT8 EFIAPI ReadIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data port.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register offset
Return values
An 8Bit data read from the specific Index/Data I/O port.
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "++IoBase16".

◆ RwIo16S3()

VOID EFIAPI RwIo16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit16 | - Mask of 16bits to set (1 = Set)
ResetBit16 | - Mask of 16bits to reset (1 = Reset)
Return values
VOID

◆ RwIo32S3()

VOID EFIAPI RwIo32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit32 | - Mask of 32bits to set (1 = Set)
ResetBit32 | - Mask of 32bits to reset (1 = Reset)
Return values
VOID

◆ RwIo8IdxData()

VOID EFIAPI RwIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data port, then applies Set/Reset masks and writes it back.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify IoRead8IdxData and IoWrite8IdxData's "++IoBase16".

◆ RwIo8IdxDataS3()

VOID EFIAPI RwIo8IdxDataS3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBase16,
 |  | IN UINT8 | IoReg8,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data ports, then applies Set/Reset masks, and writes it back. Also writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
An 8Bit data read from the specific Index/Data I/O port after applying Set/Reset masks.
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "IoBase16 + 1" and IoWrite8IdxData's "++IoBase16".

◆ RwIo8S3()

VOID EFIAPI RwIo8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
VOID

◆ RwMem16S3()

VOID EFIAPI RwMem16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit16 | - Mask of bits to set (1 = Set)
ResetBit16 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwMem32S3()

VOID EFIAPI RwMem32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit32 | - Mask of bits to set (1 = Set)
ResetBit32 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwMem8S3()

VOID EFIAPI RwMem8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit8 | - Mask of bits to set (1 = Set)
ResetBit8 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci16S3()

VOID EFIAPI RwPci16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save ProtocOl
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit16 | - Mask of bits to set (1 = Set)
ResetBit16 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci32S3()

VOID EFIAPI RwPci32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit32 | - Mask of bits to set (1 = Set)
ResetBit32 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci8S3()

VOID EFIAPI RwPci8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit8 | - Mask of bits to set (1 = Set)
ResetBit8 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ WriteIo16S3()

VOID EFIAPI WriteIo16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
Value16 | - A 16 Bit Value to write.
Return values
VOID

◆ WriteIo32S3()

VOID EFIAPI WriteIo32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
Value32 | - a 32 Bit Value to write.
Return values
VOID

◆ WriteIo8IdxData()

VOID EFIAPI WriteIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O Index/Data port.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
Value8 | - An 8 Bit Value to write.
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "++IoBase16".

◆ WriteIo8IdxDataS3()

VOID EFIAPI WriteIo8IdxDataS3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBase16,
 |  | IN UINT8 | IoReg8,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O Index/Data ports and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
Value8 | - An 8 Bit Value to write.
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "IoBase16 + 1".

◆ WriteIo8S3()

VOID EFIAPI WriteIo8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save ProtocOl
IoBaseReg16 | - A 16 Bit I/O Port Address
Value8 | - An 8 Bit Value to write.
Return values
VOID

◆ WriteMem16S3()

VOID EFIAPI WriteMem16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value16 | - A 16Bits data writes to the address.
Return values
VOID

◆ WriteMem32S3()

VOID EFIAPI WriteMem32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value32 | - A 32Bits data writes to the address.
Return values
VOID

◆ WriteMem8S3()

VOID EFIAPI WriteMem8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value8 | - An 8Bits data writes to the address.
Return values
VOID

◆ WritePci16S3()

VOID EFIAPI WritePci16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value16 | - A 16 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID

◆ WritePci32S3()

VOID EFIAPI WritePci32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value32 | - A 32 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID

◆ WritePci8S3()

VOID EFIAPI WritePci8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value8 | - An 8 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID


AmiChipsetPkg: AmiChipsetPkg/Include/Library/AmiChipsetRuntimeServiceLib.h File Reference

  • AmiChipsetPkg
  • Include
  • Library
Functions
AmiChipsetRuntimeServiceLib.h File Reference

Functions

typedef | EFI_STATUS (EFIAPI SB_RUN_RESET_CALLBACK)(IN EFI_RESET_TYPE ResetType)
typedef | VOID (EFIAPI SB_INIT_RTC_CALLBACK)(VOID)
EFI_STATUS EFIAPI | AmiChipsetResetSystem (IN EFI_RESET_TYPE ResetType, IN EFI_STATUS ResetStatus, IN UINTN DataSize, IN CHAR16 *ResetData OPTIONAL)
EFI_STATUS EFIAPI | AmiChipsetGetTime (OUT EFI_TIME *Time, OUT EFI_TIME_CAPABILITIES *Capabilities OPTIONAL)
EFI_STATUS EFIAPI | AmiChipsetSetTime (IN EFI_TIME *Time)
EFI_STATUS EFIAPI | AmiChipsetGetWakeupTime (OUT BOOLEAN *Enabled, OUT BOOLEAN *Pending, OUT EFI_TIME *Time)
EFI_STATUS EFIAPI | AmiChipsetSetWakeupTime (IN BOOLEAN Enable, IN EFI_TIME *Time OPTIONAL)
VOID EFIAPI | InitRtc (VOID)

Detailed Description

This file contains AMI chipset porting runtime server library functions and data structure definitions.

Function Documentation

◆ AmiChipsetGetTime()

EFI_STATUS EFIAPI AmiChipsetGetTime | ( | OUT EFI_TIME * | Time,
 |  | OUT EFI_TIME_CAPABILITIES *Capabilities | OPTIONAL
 | ) |  |

Return the current date and time

Parameters
Time | Current time filled in EFI_TIME structure
Capabilities | Time capabilities (OPTIONAL)
Return values
EFI_SUCCESS Always
Note

Here is the control flow of this function:
  1. Read the original time format 12/24 hours and BCD/binary.
  2. Set the format to 24 hrs and binary.
  3. Read the 2 digit year.
  4. Add either 1900 or 2000, so the year is between 1998 - 2097.
  5. Read the month, day, hour, minute, second.
  6. Set the nanosecond to 0.
  7. Set the time to zone to unspecified.
  8. Set daylight savings value to 0.
  9. Restore the original time format.
  10. Set Capabilities with 1 second Resolution, 0 Accuracy (Unknown), and False SetsToZero.
  11. Return EFI_SUCCESS.

◆ AmiChipsetGetWakeupTime()

EFI_STATUS EFIAPI AmiChipsetGetWakeupTime | ( | OUT BOOLEAN * | Enabled,
 |  | OUT BOOLEAN * | Pending,
 |  | OUT EFI_TIME * | Time
 | ) |  |

Read the wake time. Read the status if it is enabled or if the system has woken up.

Parameters
Enabled | Flag indicating the validity of wakeup time
Pending | Check if wake up time has expired.
Time | Current wake up time setting
Return values
EFI_SUCCESS (Always)
Note

Here is the control flow of this function:
  1. Read the original time format 12/24 hours and BCD/binary.
  2. Set the format to 24 hrs and binary.
  3. Read the status if the wake up time is enabled or if it has expired.
  4. Set the wakeup time.
  5. Restore the original time format.
  6. Return EFI_SUCCESS.

◆ AmiChipsetResetSystem()

EFI_STATUS EFIAPI AmiChipsetResetSystem | ( | IN EFI_RESET_TYPE | ResetType,
 |  | IN EFI_STATUS | ResetStatus,
 |  | IN UINTN | DataSize,
 |  | IN CHAR16 *ResetData | OPTIONAL
 | ) |  |

This function is the interface for the reset function.

Parameters
ResetType | Type of reset to perform
ResetStatus | System status that caused the reset. if part of normal operation then this should be EFI_SUCCESS, Otherwise it should reflect the state of the system that caused it.
DataSize | Size in bytes of the data to be logged
ResetData | Pointer to the data buffer that is to be logged - OPTIONAL
Return values
EFI_DEVICE_ERROR Even though it should never get that far

◆ AmiChipsetSetTime()

EFI_STATUS EFIAPI AmiChipsetSetTime ( IN EFI_TIME * Time )

Sets the RTC time

Parameters
Time Time to set
Return values
EFI_SUCCESS | Time is Set
EFI_INVALID_PARAMETER | Time to Set is not valid.
Note

Here is the control flow of this function:
  1. Read the original time format 12/24 hours and BCD/binary.
  2. Set the format to 24 hrs and binary.
  3. Verify the time to set. If it is an invalid time, restore the time format and return EFI_INVALID_PARAMETER.
  4. Change the 4 digit year to a 2 digit year.
  5. Stop the RTC time.
  6. Store time and data on the RTC.
  7. Read the month, day, hour, minute, second.
  8. Start the RTC time.
  9. Restore the original time format.
  10. Return EFI_SUCCESS.

◆ AmiChipsetSetWakeupTime()

EFI_STATUS EFIAPI AmiChipsetSetWakeupTime | ( | IN BOOLEAN | Enable,
 |  | IN EFI_TIME *Time | OPTIONAL
 | ) |  |

Enable/disable and set wakeup time

Parameters
Enable | Flag indicating whether to enable/disable the time
Time | Time to set as the wake up time - OPTIONAL
Return values
EFI_SUCCESS | Time is Set and/or Enabled/Disabled.
EFI_INVALID_PARAMETER | Invalid time or enabling with a NULL Time.
Note

Here is the control flow of this function:
  1. Read the original time format 12/24 hours and BCD/binary.
  2. If Time is not NULL, a. Verify the wakeup time to set. If it is an invalid time, restore the time format and return EFI_INVALID_PARAMETER. b. Set the wakeup time.
  3. If Time is NULL and Enable is true, restore original time format and return EFI_INVALID_PARAMETER.
  4. Enable/Disable wakeup.
  5. Restore the original time format.
  6. Return EFI_SUCCESS.

◆ InitRtc()

VOID EFIAPI InitRtc ( VOID )

This function initializes RTC

Parameters
VOID
Return values
VOID


AmiChipsetPkg: AmiChipsetPkg/Include/Ppi Directory Reference

  • AmiChipsetPkg
  • Include
  • Ppi
Ppi Directory Reference

Files

file | BaseMemoryTest.h
file | GnbPpi.h
file | NbPpi.h
file | SbPpi.h


AmiChipsetPkg: AmiChipsetPkg/Include/Ppi/BaseMemoryTest.h File Reference

  • AmiChipsetPkg
  • Include
  • Ppi
Data Structures | Typedefs | Enumerations | Variables
BaseMemoryTest.h File Reference

Data Structures

struct _PEI_BASE_MEMORY_TEST_PPI

Typedefs

typedef struct _PEI_BASE_MEMORY_TEST_PPI | PEI_BASE_MEMORY_TEST_PPI
typedef EFI_STATUS(EFIAPI * | PEI_BASE_MEMORY_TEST) (IN EFI_PEI_SERVICES **PeiServices, IN PEI_BASE_MEMORY_TEST_PPI *This, IN EFI_PHYSICAL_ADDRESS BeginAddress, IN UINT64 MemoryLength, IN PEI_MEMORY_TEST_OP Operation, OUT EFI_PHYSICAL_ADDRESS *ErrorAddress)

Enumerations

enum PEI_MEMORY_TEST_OP { Ignore, Quick, Sparse, Extensive }

Variables

EFI_GUID gPeiBaseMemoryTestPpiGuid

Detailed Description

This header file contains the PPI definition for the Base Memory Test


AmiChipsetPkg: AmiChipsetPkg/Include/Ppi/GnbPpi.h File Reference

  • AmiChipsetPkg
  • Include
  • Ppi
Data Structures | Typedefs | Variables
GnbPpi.h File Reference

Data Structures

struct | _AMI_GNB_PCI_SSID_TABLE_STRUCT
struct | _AMI_PEI_GNB_CUSTOM_PPI

Typedefs

typedef struct _AMI_GNB_PCI_SSID_TABLE_STRUCT | AMI_GNB_PCI_SSID_TABLE_STRUCT
typedef struct _AMI_PEI_GNB_CUSTOM_PPI | AMI_PEI_GNB_CUSTOM_PPI

Variables

EFI_GUID gAmiPeiGnbCustomPpiGuid

Detailed Description

This header file contains GNB protocol definitions and structure definitions.


AmiChipsetPkg: AmiChipsetPkg/Include/Ppi/NbPpi.h File Reference

  • AmiChipsetPkg
  • Include
  • Ppi
Data Structures | Typedefs | Variables
NbPpi.h File Reference

Data Structures

struct _AMI_PEI_NBINIT_POLICY_PPI

Typedefs

typedef struct _AMI_PEI_NBINIT_POLICY_PPI AMI_PEI_NBINIT_POLICY_PPI

Variables

EFI_GUID | gAmiPeiNbInitPolicyGuid
EFI_GUID | gAmiPeiMrcDefaultGuid
EFI_GUID | gAmiPeiBeforeMrcGuid
EFI_GUID | gAmiPeiAfterMrcGuid
EFI_GUID | gAmiPeiEndOfMemDetectGuid

Detailed Description

This header file contains the PPI definition for the NB.


AmiChipsetPkg: AmiChipsetPkg/Include/Ppi/SbPpi.h File Reference

  • AmiChipsetPkg
  • Include
  • Ppi
Data Structures | Typedefs | Variables
SbPpi.h File Reference

Data Structures

struct | _AMI_PEI_SBINIT_POLICY_PPI
struct | _AMI_SB_PCI_SSID_TABLE_STRUCT
struct | _AMI_GPIO_INIT_PPI
struct | _AMI_PEI_SB_CUSTOM_PPI

Typedefs

typedef struct _AMI_PEI_SBINIT_POLICY_PPI | AMI_PEI_SBINIT_POLICY_PPI
typedef struct _AMI_SB_PCI_SSID_TABLE_STRUCT | AMI_SB_PCI_SSID_TABLE_STRUCT
typedef struct _AMI_GPIO_INIT_PPI | AMI_GPIO_INIT_PPI
typedef struct _AMI_PEI_SB_CUSTOM_PPI | AMI_PEI_SB_CUSTOM_PPI

Variables

EFI_GUID | gAmiPeiSbCustomPpiGuid
EFI_GUID | gAmiPeiSbInitPolicyGuid

Detailed Description

This header file contains the PPI definition for the SB.


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol Directory Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Protocol Directory Reference

Files

file | AcpiModeEnable.h
file | AmiMemInfo.h
file | NbSmiProtocol.h
file | SbSataProtocol.h
file | SbSmiProtocol.h
file | SmmBiosWriteDispatch.h


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/AcpiModeEnable.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Typedefs | Variables
AcpiModeEnable.h File Reference

Data Structures

struct | _GENERIC_LINK
struct | _ACPI_DISPATCH_LINK
struct | _EFI_ACPI_DISPATCH_PROTOCOL

Typedefs

typedef struct _EFI_ACPI_DISPATCH_PROTOCOL | EFI_ACPI_DISPATCH_PROTOCOL
typedef struct _GENERIC_LINK | GENERIC_LINK
typedef VOID(EFIAPI * | EFI_ACPI_DISPATCH) (IN EFI_HANDLE DispatchHandle)
typedef struct _ACPI_DISPATCH_LINK | ACPI_DISPATCH_LINK
typedef EFI_STATUS(EFIAPI * | EFI_ACPI_REGISTER) (IN EFI_ACPI_DISPATCH_PROTOCOL *This, IN EFI_ACPI_DISPATCH DispatchFunction, OUT EFI_HANDLE *DispatchHandle)
typedef EFI_STATUS(EFIAPI * | EFI_ACPI_UNREGISTER) (IN EFI_ACPI_DISPATCH_PROTOCOL *This, IN EFI_HANDLE DispatchHandle)

Variables

EFI_GUID | gEfiAcpiEnDispatchProtocolGuid
EFI_GUID | gEfiAcpiDisDispatchProtocolGuid

Detailed Description

Define all the ACPI mode equates and structures in this file.


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/AmiMemInfo.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Enumerations | Variables
AmiMemInfo.h File Reference

Data Structures

struct | MEMORY_SLOT_INFO
struct | AMI_MEMORY_ARRAY_INFO
struct | AMI_MEMORY_INFO

Enumerations

enum MEMORY_TYPE_INFO {
UnknownType, DDR1, DDR2, DDR3,
DDR3L, DDR3U, LPDDR3, DDR4,
LPDDR4, OtherType
}

Variables

EFI_GUID gAmiMemoryInfoGuid

Detailed Description

The header file for AMI Memory Information


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/NbSmiProtocol.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Typedefs | Enumerations | Variables
NbSmiProtocol.h File Reference

Data Structures

struct | _NB_ECC_INFO
struct | _NB_PCIE_INFO
struct | _NB_ERROR_INFO
struct | _GENERIC_LINK
struct | _NB_ERROR_LOG_DISPATCH_LINK
struct | _EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL

Typedefs

typedef struct _NB_ECC_INFO | NB_ECC_INFO
typedef struct _NB_PCIE_INFO | NB_PCIE_INFO
typedef struct _NB_ERROR_INFO | NB_ERROR_INFO
typedef struct _EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL | EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL
typedef struct _GENERIC_LINK | GENERIC_LINK
typedef VOID(EFIAPI * | EFI_NB_ERROR_LOG_DISPATCH) (IN EFI_HANDLE DispatchHandle, IN NB_ERROR_INFO NbErrorInfo)
typedef struct _NB_ERROR_LOG_DISPATCH_LINK | NB_ERROR_LOG_DISPATCH_LINK
typedef EFI_STATUS(EFIAPI * | EFI_NB_ERROR_LOG_REGISTER) (IN EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL *This, IN EFI_NB_ERROR_LOG_DISPATCH DispatchFunction, OUT EFI_HANDLE *DispatchHandle)
typedef EFI_STATUS(EFIAPI * | EFI_NB_ERROR_LOG_UNREGISTER) (IN EFI_NB_ERROR_LOG_DISPATCH_PROTOCOL *This, IN EFI_HANDLE DispatchHandle)

Enumerations

enum AMI_NB_ERROR_LOG_TYPE { NbErrorNone, NbEccError, NbPcieError, NbErrorMax }

Variables

EFI_GUID gNbErrorLogDispatchProtocolGuid

Detailed Description

This file contains all definitions for North Bridge SMI driver.


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/SbSataProtocol.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Typedefs | Variables
SbSataProtocol.h File Reference

Data Structures

struct SB_HDD_POLICY_PROTOCOL

Typedefs

typedef EFI_STATUS(* GENERATE_PORT_NUMBER) (IN UINT8 DeviceNumber, IN UINT8 FunctionNumber, IN UINT32 IdeChannel, IN UINT32 IdeDevice, OUT UINT32 *PortNumber)

Variables

EFI_GUID gAmiSbHddPolicyProtocolGuid

Detailed Description

South Bridge SATA Protocol header.


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/SbSmiProtocol.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Typedefs | Variables
SbSmiProtocol.h File Reference

Data Structures

struct | _GENERIC_LINK
struct | _SB_PCIE_ERR
struct | _SB_PCIE_ERROR_LOG_DISPATCH_LINK
struct | _EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL

Typedefs

typedef struct _GENERIC_LINK | GENERIC_LINK
typedef struct _SB_PCIE_ERR | SB_PCIE_ERR
typedef struct _EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL | EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL
typedef VOID(EFIAPI * | EFI_SB_PCIE_ERROR_LOG_DISPATCH) (IN EFI_HANDLE DispatchHandle, IN SB_PCIE_ERR SbPcieErrorInfo)
typedef struct _SB_PCIE_ERROR_LOG_DISPATCH_LINK | SB_PCIE_ERROR_LOG_DISPATCH_LINK
typedef EFI_STATUS(EFIAPI * | EFI_SB_PCIE_ERROR_LOG_REGISTER) (IN EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL *This, IN EFI_SB_PCIE_ERROR_LOG_DISPATCH DispatchFunction, OUT EFI_HANDLE *DispatchHandle)
typedef EFI_STATUS(EFIAPI * | EFI_SB_PCIE_ERROR_LOG_UNREGISTER) (IN EFI_SB_PCIE_ERROR_LOG_DISPATCH_PROTOCOL *This, IN EFI_HANDLE DispatchHandle)

Variables

EFI_GUID | gSbPcieErrorLogDispatchProtocolGuid
EFI_GUID | gAmiSbSmiProtocolGuid
EFI_GUID | gAmiSmbusSmmProtocolGuid

Detailed Description

South Bridge SMI Dispatch Protocol header.


AmiChipsetPkg: AmiChipsetPkg/Include/Protocol/SmmBiosWriteDispatch.h File Reference

  • AmiChipsetPkg
  • Include
  • Protocol
Data Structures | Typedefs | Variables
SmmBiosWriteDispatch.h File Reference

Data Structures

struct _EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL

Typedefs

typedef struct _EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL | EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL
typedef VOID(EFIAPI * | EFI_SMM_BIOS_WRITE_DISPATCH) (IN EFI_HANDLE DispatchHandle, IN VOID *DispatchContext)
typedef EFI_STATUS(EFIAPI * | EFI_SMM_BIOS_WRITE_REGISTER) (IN EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL *This, IN EFI_SMM_BIOS_WRITE_DISPATCH DispatchFunction, OUT EFI_HANDLE *DispatchHandle)
typedef EFI_STATUS(EFIAPI * | EFI_SMM_BIOS_WRITE_UNREGISTER) (IN EFI_SMM_BIOS_WRITE_DISPATCH_PROTOCOL *This, IN EFI_HANDLE DispatchHandle)

Variables

EFI_GUID gEfiSmmBiosWriteDispatchProtocolGuid

Detailed Description

SMM BIOS Write Dispatch Protocol header.


AmiChipsetPkg: AmiChipsetPkg/Library Directory Reference

  • AmiChipsetPkg
  • Library
Library Directory Reference

Directories

Generated by doxygen 1.8.14


AmiChipsetPkg: AmiChipsetPkg/Library/AmiChipsetIoLib Directory Reference

  • AmiChipsetPkg
  • Library
  • AmiChipsetIoLib
AmiChipsetIoLib Directory Reference

Files

file AmiChipsetIoLib.c


AmiChipsetPkg: AmiChipsetPkg/Library/AmiChipsetIoLib/AmiChipsetIoLib.c File Reference

  • AmiChipsetPkg
  • Library
  • AmiChipsetIoLib
Functions
AmiChipsetIoLib.c File Reference

Functions

UINT8 EFIAPI | FindCapPtr (IN UINTN PciAddress, IN UINT8 CapId)
UINT16 EFIAPI | FindExtendedCapPtr (IN UINTN PciAddress, IN UINT16 CapId)
VOID EFIAPI | WriteIo8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT8 Value8)
VOID EFIAPI | WriteIo16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT16 Value16)
VOID EFIAPI | WriteIo32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT32 Value32)
VOID EFIAPI | RwIo8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwIo16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwIo32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBaseReg16, IN UINT32 SetBit32, IN UINT32 ResetBit32)
VOID EFIAPI | WriteIo8IdxDataS3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBase16, IN UINT8 IoReg8, IN UINT8 Value8)
UINT8 EFIAPI | ReadIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8)
VOID EFIAPI | WriteIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8, IN UINT8 Value8)
VOID EFIAPI | RwIo8IdxData (IN UINT16 IoBase16, IN UINT8 RegIdx8, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwIo8IdxDataS3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT16 IoBase16, IN UINT8 IoReg8, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | WritePci8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT8 Value8)
VOID EFIAPI | WritePci16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT16 Value16)
VOID EFIAPI | WritePci32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT32 Value32)
VOID EFIAPI | RwPci8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwPci16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwPci32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINT8 Bus, IN UINT8 Dev, IN UINT8 Fun, IN UINT16 Reg, IN UINT32 SetBit32, IN UINT32 ResetBit32)
VOID EFIAPI | WriteMem8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT8 Value8)
VOID EFIAPI | WriteMem16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT16 Value16)
VOID EFIAPI | WriteMem32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT32 Value32)
VOID EFIAPI | RwMem8S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT8 SetBit8, IN UINT8 ResetBit8)
VOID EFIAPI | RwMem16S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT16 SetBit16, IN UINT16 ResetBit16)
VOID EFIAPI | RwMem32S3 (IN EFI_S3_SAVE_STATE_PROTOCOL *BootScriptSave, IN UINTN Address, IN UINT32 SetBit32, IN UINT32 ResetBit32)

Detailed Description

This file contains implementation of Ami Chipset Io Library

Function Documentation

◆ FindCapPtr()

UINT8 EFIAPI FindCapPtr | ( | IN UINTN | PciAddress,
 |  | IN UINT8 | CapId
 | ) |  |

This function searches the PCI address space for the PCI device specified for a particular capability ID and returns the Capability ID Offset if one found

Parameters
PciAddress | - The PCI-E MMIO address of the register.
CapId | - CAPID to search for, CAPID list: 0x01 = PCI Power Management Interface 0x10 = PCI Express Capability
Return values
Capability ID Offset if one found. Otherwise returns 0

◆ FindExtendedCapPtr()

UINT16 EFIAPI FindExtendedCapPtr | ( | IN UINTN | PciAddress,
 |  | IN UINT16 | CapId
 | ) |  |

This function Search and return the offset of desired PCI Express Capability ID

Parameters
PciAddress | - The PCI-E MMIO address of the register.
CapId | - CAPID to search for, CAPID list: 0x0001 = Advanced Error Reporting Capability 0x0002 = Virtual Channel Capability 0x0003 = Device Serial Number Capability 0x0004 = Power Budgeting Capability
Return values
Extended Capability ID Offset if one found, Otherwise returns 0

◆ ReadIo8IdxData()

UINT8 EFIAPI ReadIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data port.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register offset
Return values
An 8Bit data read from the specific Index/Data I/O port.
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "++IoBase16".

◆ RwIo16S3()

VOID EFIAPI RwIo16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit16 | - Mask of 16bits to set (1 = Set)
ResetBit16 | - Mask of 16bits to reset (1 = Reset)
Return values
VOID

◆ RwIo32S3()

VOID EFIAPI RwIo32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit32 | - Mask of 32bits to set (1 = Set)
ResetBit32 | - Mask of 32bits to reset (1 = Reset)
Return values
VOID

◆ RwIo8IdxData()

VOID EFIAPI RwIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data port, then applies Set/Reset masks and writes it back.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify IoRead8IdxData and IoWrite8IdxData's "++IoBase16".

◆ RwIo8IdxDataS3()

VOID EFIAPI RwIo8IdxDataS3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBase16,
 |  | IN UINT8 | IoReg8,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O Index/Data ports, then applies Set/Reset masks, and writes it back. Also writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
An 8Bit data read from the specific Index/Data I/O port after applying Set/Reset masks.
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "IoBase16 + 1" and IoWrite8IdxData's "++IoBase16".

◆ RwIo8S3()

VOID EFIAPI RwIo8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bit value from a specific I/O port, then applies Set/Reset masks, and writes it back, then writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
SetBit8 | - Mask of 8bits to set (1 = Set)
ResetBit8 | - Mask of 8bits to reset (1 = Reset)
Return values
VOID

◆ RwMem16S3()

VOID EFIAPI RwMem16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit16 | - Mask of bits to set (1 = Set)
ResetBit16 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwMem32S3()

VOID EFIAPI RwMem32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit32 | - Mask of bits to set (1 = Set)
ResetBit32 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwMem8S3()

VOID EFIAPI RwMem8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bits data from a specific memory (or MMIO) address, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
SetBit8 | - Mask of bits to set (1 = Set)
ResetBit8 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci16S3()

VOID EFIAPI RwPci16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT16 | SetBit16,
 |  | IN UINT16 | ResetBit16
 | ) |  |

This function reads a 16bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save ProtocOl
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit16 | - Mask of bits to set (1 = Set)
ResetBit16 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci32S3()

VOID EFIAPI RwPci32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT32 | SetBit32,
 |  | IN UINT32 | ResetBit32
 | ) |  |

This function reads a 32bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit32 | - Mask of bits to set (1 = Set)
ResetBit32 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ RwPci8S3()

VOID EFIAPI RwPci8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT8 | SetBit8,
 |  | IN UINT8 | ResetBit8
 | ) |  |

This function reads an 8bits data from the specific PCI register, applies masks, and writes it back, also writes it to Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
SetBit8 | - Mask of bits to set (1 = Set)
ResetBit8 | - Mask of bits to clear (1 = clear)
Return values
VOID

◆ WriteIo16S3()

VOID EFIAPI WriteIo16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
Value16 | - A 16 Bit Value to write.
Return values
VOID

◆ WriteIo32S3()

VOID EFIAPI WriteIo32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBaseReg16 | - A 16 Bit I/O Port Address
Value32 | - a 32 Bit Value to write.
Return values
VOID

◆ WriteIo8IdxData()

VOID EFIAPI WriteIo8IdxData | ( | IN UINT16 | IoBase16,
 |  | IN UINT8 | RegIdx8,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O Index/Data port.

Parameters
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
Value8 | - An 8 Bit Value to write.
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "++IoBase16".

◆ WriteIo8IdxDataS3()

VOID EFIAPI WriteIo8IdxDataS3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBase16,
 |  | IN UINT8 | IoReg8,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O Index/Data ports and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
IoBase16 | - A 16 Bit I/O Address for Index I/O Port
RegIdx8 | - An 8 Bit Register Index
Value8 | - An 8 Bit Value to write.
Return values
VOID
Note
The default Data I/O Port is the Index I/O Port plus 1, if your Data I/O Port is not that, please modify below "IoBase16 + 1".

◆ WriteIo8S3()

VOID EFIAPI WriteIo8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT16 | IoBaseReg16,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bit value to a specific I/O port and writes a copy to Boot Script Table.

Parameters
BootScriptSave | - Pointer to Boot Script Save ProtocOl
IoBaseReg16 | - A 16 Bit I/O Port Address
Value8 | - An 8 Bit Value to write.
Return values
VOID

◆ WriteMem16S3()

VOID EFIAPI WriteMem16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value16 | - A 16Bits data writes to the address.
Return values
VOID

◆ WriteMem32S3()

VOID EFIAPI WriteMem32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value32 | - A 32Bits data writes to the address.
Return values
VOID

◆ WriteMem8S3()

VOID EFIAPI WriteMem8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINTN | Address,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bits data to a specific memory (or MMIO) address and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Address | - A 64Bits Memory (or MMIO) address
Value8 | - An 8Bits data writes to the address.
Return values
VOID

◆ WritePci16S3()

VOID EFIAPI WritePci16S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT16 | Value16
 | ) |  |

This function writes a 16bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value16 | - A 16 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID

◆ WritePci32S3()

VOID EFIAPI WritePci32S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT32 | Value32
 | ) |  |

This function writes a 32bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value32 | - A 32 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID

◆ WritePci8S3()

VOID EFIAPI WritePci8S3 | ( | IN EFI_S3_SAVE_STATE_PROTOCOL * | BootScriptSave,
 |  | IN UINT8 | Bus,
 |  | IN UINT8 | Dev,
 |  | IN UINT8 | Fun,
 |  | IN UINT16 | Reg,
 |  | IN UINT8 | Value8
 | ) |  |

This function writes an 8bits data to the specific PCI register and Boot Script.

Parameters
BootScriptSave | - Pointer to Boot Script Save Protocol
Bus | - PCI Bus number.
Dev | - PCI Device number.
Fun | - PCI Function number.
Reg | - PCI Register number.
Value8 | - An 8 Bits data will be written to the specific PCI register and Boot Script.
Return values
VOID


AmiChipsetPkg: AmiChipsetPkg/Library/AmiCspSmmBootScriptLibNull Directory Reference

  • AmiChipsetPkg
  • Library
  • AmiCspSmmBootScriptLibNull
AmiCspSmmBootScriptLibNull Directory Reference

Files

file AmiCspSmmBootScriptLibNull.c


AmiChipsetPkg: AmiChipsetPkg/Library/AmiCspSmmBootScriptLibNull/AmiCspSmmBootScriptLibNull.c File Reference

  • AmiChipsetPkg
  • Library
  • AmiCspSmmBootScriptLibNull
Functions
AmiCspSmmBootScriptLibNull.c File Reference

Functions

BOOLEAN EFIAPI | CspIsSwitchBootScriptToSmm ()
EFI_STATUS EFIAPI | CspSaveBootScriptToSmm (IN CONST EFI_S3_SAVE_STATE_PROTOCOL *This, IN UINT16 OpCode,...)
EFI_S3_SAVE_STATE_PROTOCOL *EFIAPI | CspGetBootScriptWrapper ()
RETURN_STATUS EFIAPI | AmiCspSmmBootScriptLibNullConstructor (VOID)

Detailed Description

This file contains code for AmiCspSmmBootScriptLibNull base library.

Function Documentation

◆ AmiCspSmmBootScriptLibNullConstructor()

RETURN_STATUS EFIAPI AmiCspSmmBootScriptLibNullConstructor ( VOID )

The constructor function initialize the AmiCspSmmBootScriptLibNull Library

Return values
EFI_SUCCESS The constructor always returns RETURN_SUCCESS.

◆ CspGetBootScriptWrapper()

EFI_S3_SAVE_STATE_PROTOCOL* EFIAPI CspGetBootScriptWrapper ( )

Return a wrapper function.

Return values
NULL Not support.

◆ CspIsSwitchBootScriptToSmm()

BOOLEAN EFIAPI CspIsSwitchBootScriptToSmm ( )

Check if SMM lock

Return values
TRUE | SMM is locked.
FALSE | SMM is not locked.

◆ CspSaveBootScriptToSmm()

EFI_STATUS EFIAPI CspSaveBootScriptToSmm | ( | IN CONST EFI_S3_SAVE_STATE_PROTOCOL * | This,
 |  | IN UINT16 | OpCode,
 |  |  | ...
 | ) |  |

Redirect S3 boot script to SMM

Parameters
This | A pointer to the EFI_S3_SAVE_STATE_PROTOCOL instance.
OpCode | The operation code (opcode) number.
... Argument list that is specific to each opcode.
Return values
EFI_SUCCESS NULL library just return.


AmiChipsetPkg: Globals

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • AmiChipsetGetTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetGetWakeupTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetResetSystem() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetSetTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetSetWakeupTime() : AmiChipsetRuntimeServiceLib.h
  • AmiCspSmmBootScriptLibNullConstructor() : AmiCspSmmBootScriptLibNull.c

- c -

  • CspGetBootScriptWrapper() : AmiCspSmmBootScriptLibNull.c
  • CspIsSwitchBootScriptToSmm() : AmiCspSmmBootScriptLibNull.c
  • CspSaveBootScriptToSmm() : AmiCspSmmBootScriptLibNull.c

- f -

  • FindCapPtr() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • FindExtendedCapPtr() : AmiChipsetIoLib.h , AmiChipsetIoLib.c

- i -

  • InitRtc() : AmiChipsetRuntimeServiceLib.h

- r -

  • ReadIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8IdxDataS3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c

- w -

  • WriteIo16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8IdxDataS3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c


AmiChipsetPkg: Globals

- a -

  • AmiChipsetGetTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetGetWakeupTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetResetSystem() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetSetTime() : AmiChipsetRuntimeServiceLib.h
  • AmiChipsetSetWakeupTime() : AmiChipsetRuntimeServiceLib.h
  • AmiCspSmmBootScriptLibNullConstructor() : AmiCspSmmBootScriptLibNull.c

- c -

  • CspGetBootScriptWrapper() : AmiCspSmmBootScriptLibNull.c
  • CspIsSwitchBootScriptToSmm() : AmiCspSmmBootScriptLibNull.c
  • CspSaveBootScriptToSmm() : AmiCspSmmBootScriptLibNull.c

- f -

  • FindCapPtr() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • FindExtendedCapPtr() : AmiChipsetIoLib.h , AmiChipsetIoLib.c

- i -

  • InitRtc() : AmiChipsetRuntimeServiceLib.h

- r -

  • ReadIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8IdxDataS3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwIo8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwMem8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • RwPci8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c

- w -

  • WriteIo16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8IdxData() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8IdxDataS3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteIo8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WriteMem8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci16S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci32S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c
  • WritePci8S3() : AmiChipsetIoLib.h , AmiChipsetIoLib.c


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2013-04-29
Source Control Label: 5.007_AmiChipsetPkg_01
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:

AmiChipsetPkg.cif
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Source Control Label: 5.007_AmiChipsetPkg_01
Component Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-05-20
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
First release

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2013-06-07
Source Control Label: 5.007_AmiChipsetPkg_02
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-05-20
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:

[TAG] NONE
[Category] Improvement
[Description] The GPIO definition sync the AMD-CPM.
[Files] SbPpi.h
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
5.007_AmiChipsetPkg_01.htm

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2013-06-20
Source Control Label: 5.007_AmiChipsetPkg_03
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_20, Dated: 2013-04-18
Visual eBios: RSS.7.15.0184, Dated: 2013-05-20
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:

[TAG] EIP126546
[Category] Improvement
[Description] ElinkGet () returns invalid Address when system has 4GB RAM
[Files] ElinkLib\ElinkPeiLib.c
ElinkLib\ElinkLib.c
ElinkLib.h
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
5.007_AmiChipsetPkg_01.htm
5.007_AmiChipsetPkg_02.htm

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2013-10-28
Source Control Label: 5.007_AmiChipsetPkg_04
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_22, Dated: 2013-10-10
Visual eBios: RSS.7.15.0244, Dated: 2013-10-08
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:

[TAG] NONE
[Category] Improvement
[Description] sync Intel/AmiChipsetPkg.
[Files] Protocol.cif, AmiMemInfo.h, SbsataProtocol.h
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
5.007_AmiChipsetPkg_01.htm
5.007_AmiChipsetPkg_02.htm
5.007_AmiChipsetPkg_03.htm

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2014-01-17
Source Control Label: 5.007_AmiChipsetPkg_05
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_23, Dated: 2013-11-16
Visual eBios: RSS.7.15.0248, Dated: 2013-11-13
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:

[TAG] NONE
[Category] Improvement
[Description] make changes to meet latest AMD CPM.
[Files] SbPpi.h
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
5.007_AmiChipsetPkg_01.htm
5.007_AmiChipsetPkg_02.htm
5.007_AmiChipsetPkg_03.htm
5.007_AmiChipsetPkg_04.htm

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2014-05-21
Source Control Label: AmiChipsetPkg_06
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-04-01
Visual eBios: 7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP154988
[Category] Improvement
[Description] Sync AmiChipsetIoLib with Intel Platform.
(5.007_AmiChipsetPkg_05)
[Files] AmiChipsetPkg.sdl
AmiChipsetPkg.dec
AmiChipsetPkg.cif
AmiS3BootScriptLib\AmiS3BootScriptLib.inf
AmiS3BootScriptLib\BootScriptLib.c
AmiChipsetIoLib\AmiChipsetIoLib.c
LibraryInstances.cif

[TAG] NONE
[Category] Improvement
[Description] Update for Doxygen.
[Files] Rtc.h
BaseMemoryTest.h
GnbPpi.h
NbPpi.h
SbPpi.h
AcpiModeEnable.h
AmiMemInfo.h
NbSmiProtocol.h
SbSmiProtocol.h
SbSataProtocol.h
SmmBiosWriteDispatch.h
AmiChipsetRuntimeServiceLib.h
AmiChipsetIoLib.h
ElinkLib.h
AmiChipsetIoLib\AmiChipsetIoLib.c
ElinkLib\ElinkPeiLib.c
ElinkLib\ElinkLib.c
ElinkLib\ElinkTableLib.c
AmiS3BootScriptLib\BootScriptLib.c
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
5.007_AmiChipsetPkg_05.htm
5.007_AmiChipsetPkg_04.htm
5.007_AmiChipsetPkg_03.htm
5.007_AmiChipsetPkg_02.htm
5.007_AmiChipsetPkg_01.htm

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2014-08-20
Source Control Label: AmiChipsetPkg_07
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-04-01
Visual eBios: 7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP173178
[Category] Improvement
[Description] Remove TODO.
[Files] AmiChipsetPkg.sdl
Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2014-11-27
Source Control Label: AmiChipsetPkg_08
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: 5.004_BuildTools_24, Dated: 2014-04-01
Visual eBios: 7.16.0267, Dated: 2014-03-31
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP192589
[Category] Improvement
[Description] dynamic/token PCIe base address.
[Files] AmiChipsetIoLib.h
AmiChipsetIoLib\AmiChipsetIoLib.inf

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2015-04-22
Source Control Label: AmiChipsetPkg_09
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
N0NE
Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: BuildTools_26, Dated: 2015-03-31
Visual eBios: 7.17.0325, Dated: 2015-03-30

Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP210352
[Category] Improvement
[Severity] Normal
[Description] Sync and implement x86 and ARM for AMD generic.
[Files] AmiChipsetPkg.sdl
AmiChipsetPkg.cif
AmiChipsetIoLib\AmiChipsetIoLib.c
ElinkLib\ElinkPeiLib.inf
AmiChipsetIoLib.h

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_08
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2015-11-24
Source Control Label: AmiChipsetPkg_10
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
ONE
Dependent Component Title: AmiChipsetModulePkg
Dependent Component Reference Name: AmiChipsetModulePkg
Dependent Source Control Label: AmiChipsetModulePkg_07
Dependent Source Control Location: AptioV;$/AptioV/Source/Hardware/Chipset/Template/AmiChipsetModulePkg;

TWO
Dependent Component Title: ACPI
Dependent Component Reference Name: AmiModulePkg.ACPI
Dependent Source Control Label: ACPI_10
Dependent Source Control Location: AptioV;$/AptioV/Source/Modules/ACPI

Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: BuildTools_27, Dated: 2015-08-22
Visual eBios: 7.17.0393, Dated: 2015-08-04

Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP216499
[Category] Improvement
[Severity] Normal
[Description] AmiCspSmmBootScriptLib interface support for smm lock.
[Files] AmiChipsetPkg.sdl
AmiChipsetIoLib\AmiChipsetIoLib.inf
AmiChipsetIoLib\AmiChipsetIoLib.c
AmiCspSmmBootScriptLibNull\AmiCspSmmBootScriptLibNull.inf
AmiCspSmmBootScriptLibNull\AmiCspSmmBootScriptLibNull.c
LibraryInstances.cif
AmiChipsetIoLib.h

The following item sync Intel-AmiChipsetPkg_07 :
EIP 216913: Create CmosBadHob while RTC power is invalid.
EIP 238525: Update MEMORY_TYPE_INFO for new DDR Type.
EIP 245811: Update AMI_GPIO_INIT_PPI since it cannot be used properly in most of the on-going Intel projects.

The following item sync Intel-AmiChipsetPkg_06 :
EIP 192368: Retire ElinkPei driver and all the related code.
EIP 199848: Remove unused Pcd from AmiChipsetPkg.
EIP 202424: gSbErrorLogDispatchProtocolGuid should be changed to gSbPcieErrorLogDispatchProtocolGuid in SbSmiProtocol.h.

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_09
AmiChipsetPkg_08
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2016-10-06
Source Control Label: AmiChipsetPkg_11
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
ONE
Dependent Component Title: AmiChipsetModulePkg
Dependent Component Reference Name: AmiChipsetModulePkg
Dependent Source Control Label: AmiChipsetModulePkg_07
Dependent Source Control Location: AptioV;$/AptioV/Source/Hardware/Chipset/Template/AmiChipsetModulePkg;

TWO
Dependent Component Title: ACPI
Dependent Component Reference Name: AmiModulePkg.ACPI
Dependent Source Control Label: ACPI_10
Dependent Source Control Location: AptioV;$/AptioV/Source/Modules/ACPI

Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
ElinkLib.h | This file contains the definitions used by ElinkLib and the interfaces provided by ElinkLib.
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
ModulePart ElinkPeiLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkPeiLib.c | This file implements the functions defined in in ElinkLib.h for PEI drivers.
ModulePart ElinkLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkLib.c | This file implements the functions defined in ElinkLib.h for non-PEI drivers.
ModulePart ElinkTableLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
ElinkTableLib.c | This file implements mAmiElinkTable and mAmiHookTable used for AMI Elink.
AMI Build Tools:
Tools Label: BuildTools_27, Dated: 2015-08-22
Visual eBios: 7.17.0393, Dated: 2015-08-04

Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP269905
[Category] Improvement
[Severity] Important
[Description] [Aptio V][Chipset Template] Change "~bReset" to "~(bReset)" in AmiChipsetIoLib.h.
[Files] AmiChipsetIoLib.h

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_10
AmiChipsetPkg_09
AmiChipsetPkg_08
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2017-03-09
Source Control Label: AmiChipsetPkg_12
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
ONE
Dependent Component Title: AmiChipsetModulePkg
Dependent Component Reference Name: AmiChipsetModulePkg
Dependent Source Control Label: AmiChipsetModulePkg_07
Dependent Source Control Location: AptioV;$/AptioV/Source/Hardware/Chipset/Template/AmiChipsetModulePkg;

TWO
Dependent Component Title: ACPI
Dependent Component Reference Name: AmiModulePkg.ACPI
Dependent Source Control Label: ACPI_10
Dependent Source Control Location: AptioV;$/AptioV/Source/Modules/ACPI

Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
AmiChipsetIoLibEx.h | This file contains all equates and functions provided by AmiChipsetIoLib. (extra definition than template)
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
AMI Build Tools:
Tools Label: BuildTools_30.7, (BuildTools_29) Dated: 2017-01-14
Visual eBios: 7.19.0478, Dated: 2017-01-13

Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP310737
[Category] Improvement
[Severity] Normal
[Description] 1. Sync Chipset Template label 08.
2. Update file header.
[Files] AmiChipsetPkg.sdl
SbPpi.h
AmiChipsetIoLib\AmiChipsetIoLib.inf
AmiChipsetIoLib\AmiChipsetIoLib.c
AmiCspSmmBootScriptLibNull\AmiCspSmmBootScriptLibNull.c
AcpiModeEnable.h
AmiMemInfo.h
SmmBiosWriteDispatch.h
Rtc.h
AmiChipsetRuntimeServiceLib.h
AmiChipsetIoLib.h
AmiChipsetIoLibEx.h
Library.cif

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
NONE
Validation Testing:
NONE
Release History:
AmiChipsetPkg_11
AmiChipsetPkg_10
AmiChipsetPkg_09
AmiChipsetPkg_08
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.


Copyright

American Megatrends, Inc.
5555 Oakbrook Parkway
Suite 200
Norcross, GA 30093 (USA)

Copyright (c) 1999-2018 American Megatrends, Inc. All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends, Inc.

American Megatrends, Inc. retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


AmiChipsetPkg: F:/AMI/A_CHM/DoxygenStarterFiles Directory Reference

  • A_CHM
  • DoxygenStarterFiles
DoxygenStarterFiles Directory Reference


AmiChipsetPkg: F:/AMI/A_CHM Directory Reference

  • A_CHM
A_CHM Directory Reference

Directories

Generated by doxygen 1.8.14


AmiChipsetPkg: Main Page

AmiChipsetPkg Documentation
Main Page

Release Notes

Copyright


Release Notes - NDA Required

Component Information:
Component Title: AmiChipsetPkg
Component Reference Name: AmiChipsetPkg
Component Type: eModule
Release Date: 2018-09-12
Source Control Label: AmiChipsetPkg_13
Source Control Location: SS: AptioV_SS;$/AptioV/Source/Hardware/Chipset/Amd/AmiChipsetPkg;

Dependencies
ONE
Dependent Component Title: AmiChipsetModulePkg
Dependent Component Reference Name: AmiChipsetModulePkg
Dependent Source Control Label: AmiChipsetModulePkg_09
Dependent Source Control Location: AptioV;$/AptioV/Source/Hardware/Chipset/Template/AmiChipsetModulePkg;

TWO
Dependent Component Title: ACPI
Dependent Component Reference Name: AmiModulePkg.ACPI
Dependent Source Control Label: ACPI_10
Dependent Source Control Location: AptioV;$/AptioV/Source/Modules/ACPI

Non-Compiled BIN and LIB File(s) within this Component:
N0NE
Component Description:
It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
This is a caption
Filename | Description
AmiChipsetPkg.cif | AmiChipsetPkg CIF file
AmiChipsetPkg.dec | AmiChipsetPkg EDK II Declaration file
AmiChipsetPkg.chm | AmiChipsetPkg CHM file
AmiChipsetPkg.sdl | AmiChipsetPkg SDL file

ModulePart Name: AmiChipsetPkg
ModulePart Description: It defines the standard interfaces of ppis, protocols and libraries provided by AMI Chipset Porting. Other modules can refer to those interfaces in usages.
Filename | Description
Main Component | Root\AmiChipsetPkg\
AmiChipsetPkg.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts that are included in the AmiChipsetPkg eModule.
AmiChipsetPkg.dec | This file is the EDK II Declaration (DEC) file that defines AmiChipsetPkg specific information that will be shared between different EDK II Modules.
AmiChipsetPkg.sdl | This file contains tokens, eLinks, INFComponent and LibraryMapping that are used to configure the module.
ModulePart AmiChipsetPkg Include | Root\AmiChipsetPkg\Include\
Include.cif | This file is the Component Information File(CIF) that defines the files and ModuleParts included in the AmiChipsetPkg Include ModulePart.
ModulePart AmiChipsetPkg Include for Guid | Root\AmiChipsetPkg\Include\Guid\
Guid.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Guid.
Rtc.h | This file includes Real Time Clock and CMOS Data bank register definitions.
ModulePart AmiChipsetPkg Include for Ppi | Root\AmiChipsetPkg\Include\Ppi\
Ppi.cif | This file is the Component Information File(CIF) that defines the files included in AmiChipsetPkg Include ModulePart for Ppi.
BaseMemoryTest.h | This file contains the PPI definition for the Base Memory Test.
NbPpi.h | This file contains the PPI definition for North Bridge.
SbPpi.h | This file contains the PPI definition for South Bridge.
ModulePart AmiChipsetPkg Include for Protocol | Root\AmiChipsetPkg\Include\Protocol\
Protocol.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Protocol.
AcpiModeEnable.h | This file contains all equates, GUIDs and structures for the ACPI enable/disable mode.
AmiMemInfo.h | This file contains all equates, GUIDs and structures for AMI Memory Information.
NbSmiProtocol.h | This file contains all equates, GUIDs and structures for North Bridge SMI protocols.
SbSmiProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SMI protocols.
SbSataProtocol.h | This file contains all equates, GUIDs and structures for South Bridge SATA Protocol.
SmmBiosWriteDispatch.h | This file contains all equates, GUIDs and structures for SMM BIOS Write Dispatch Protocol.
ModulePart AmiChipsetPkg Include for Library | Root\AmiChipsetPkg\Include\Library\
Library.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Include ModulePart for Library.
AmiChipsetRuntimeServiceLib.h | This file contains all equates and functions provided by AmiChipsetRuntimeServiceLib.
AmiChipsetIoLib.h | This file contains all equates and functions provided by AmiChipsetIoLib.
AmiChipsetIoLibEx.h | This file contains all equates and functions provided by AmiChipsetIoLib. (extra definition than template)
ModulePart AmiChipsetPkg Library | Root\AmiChipsetPkg\Library\
LibraryInstances.cif | This file is the Component Information File(CIF) that defines the files included in the AmiChipsetPkg Library ModulePart.
ModulePart AmiChipsetIoLib | Root\AmiChipsetPkg\Library\AmiChipsetIoLib\
AmiChipsetIoLib.c | This file implements the functions defined in AmiChipsetRuntimeServiceLib.h.
AMI Build Tools:
Tools Label: BuildTools_32.1 Dated: 2018-03-01
Visual eBios: 7.19.0590, Dated: 2018-03-01

Compiler Tool(s): EnterpriseWDK_rs2_release_15063_20170317-1834
Compiler Tool(s): Microsoft's Windows Driver Kit (WDK) Ver. 7600.16385.1
New features added in this label:
NONE

EIP Addressed :

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP331006 : Review all PCD name and add "Ami" as the prefix.
[Files] AmiChipsetPkg.sdl
AmiChipsetPkg.dec

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP380700 : Update MEMORY_TYPE_INFO for LPDDR4 support.
[Files] AmiMemInfo.h

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP392549 : Potential issue in using PcdPciExpressBaseAddress in CSP_PCIE_CFG_ADDRESS.
[Files] AmiChipsetIoLib\AmiChipsetIoLib.inf
AmiChipsetIoLib.h

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP396111 : Potential issue of using CSP_PCIE_CFG_ADDRESS.
[Files] AmiChipsetIoLib.h

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP383015 : Do not use InitSmmHandler in Chipset Template.
EIP428272 : SmmRsTable is not found in CspInitSmmHandler.
[Files] AcpiModeEnable.h
SmmBiosWriteDispatch.h
AmiChipsetRuntimeServiceLib.h

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Sync Chipset Template.
EIP414779 : Remove AmiHobs.h since it will be deprecated.
[Files] AmiCspHobs.h
Guid.cif

[TAG] EIP425141
[Category] Improvement
[Severity] Normal
[Description] Update AMI copyright header.
[Files] AmiChipsetPkg.sdl
AmiChipsetPkg.dec
BaseMemoryTest.h
GnbPpi.h
NbPpi.h
SbPpi.h
AmiChipsetIoLib\AmiChipsetIoLib.c
AmiCspSmmBootScriptLibNull\AmiCspSmmBootScriptLibNull.c
NbSmiProtocol.h
SbSmiProtocol.h
SbSataProtocol.h
Rtc.h
AmiChipsetIoLibEx.h

Known Limitations and Erratas in this label:
NONE
Remaining Issues:
NONE
Unit Testing:
EIP425141
Validation Testing:
NONE
Release History:
AmiChipsetPkg_12
AmiChipsetPkg_11
AmiChipsetPkg_10
AmiChipsetPkg_09
AmiChipsetPkg_08
AmiChipsetPkg_07
AmiChipsetPkg_06
5.007_AmiChipsetPkg_05
5.007_AmiChipsetPkg_04
5.007_AmiChipsetPkg_03
5.007_AmiChipsetPkg_02
5.007_AmiChipsetPkg_01

© American Megatrends Inc.