IntelFrameworkModulePkg: Main Page

IntelFrameworkModulePkg IntelFrameworkModulePkg_13.1
  • Main Page
IntelFrameworkModulePkg Documentation
Main Page

Release Notes

Copyright
Generated on Tue Jul 27 2021 15:20:20 for IntelFrameworkModulePkg by doxygen 1.8.4


Copyright

American Megatrends International LLC
3095 Satellite Boulevard
Building 800, Suite 425
Duluth, GA 30096

Copyright (c) 1999-2021 American Megatrends International LLC All Rights Reserved.

This publication contains proprietary information, which is protected by copyright. No part of this publication may be reproduced, transcribed, stored in a retrieval system, translated into any language or computer language, or transmitted in any form whatsoever without the prior written consent of the publisher, American Megatrends International LLC.

American Megatrends International LLC, . retains the right to update, change, modify this publication at any time, without notice.

For Additional Information

Call American Megatrends BIOS Sales Department at 1-800-828-9264 for additional information.

Limitations of Liability

In no event shall American Megatrends be held liable for any loss, expenses, or damages of any kind whatsoever, whether direct, indirect, incidental, or consequential, arising from the design or use of this product or the support materials provided with the product.

Limited Warranty

No warranties are made, either expressed or implied, with regard to the contents of this work, its merchantability, or fitness for a particular use. American Megatrends assumes no responsibility for errors and omissions or for the uses made of the material contained herein or reader decisions based on such use.

Trademark and Copyright Acknowledgments

All product names used in this publication are for identification purposes only and are trademarks of their respective Companies.


IntelFrameworkModulePkg: C:/AptioV/DoxygenDox Directory Reference

IntelFrameworkModulePkg IntelFrameworkModulePkg_13.1
  • Main Page
  • AptioV
  • DoxygenDox
DoxygenDox Directory Reference

Files

file DoxyDefault.Dox
Generated on Tue Jul 27 2021 15:20:20 for IntelFrameworkModulePkg by doxygen 1.8.4


IntelFrameworkModulePkg: C:/AptioV Directory Reference

IntelFrameworkModulePkg IntelFrameworkModulePkg_13.1
  • Main Page
  • AptioV
AptioV Directory Reference

Directories

directory DoxygenDox
Generated on Tue Jul 27 2021 15:20:20 for IntelFrameworkModulePkg by doxygen 1.8.4


Release Notes - NDA Required

Component Information:
Component Title: IntelFrameworkModulePkg

IntelFrameworkModulePkg_13.1 (07/27/2021)

Dependencies: MdeModulePkg[21..]

Origin: TianoCore.org tag edk2-stable201811

CHM Update

IntelFrameworkModulePkg_13 (07/26/2021)

Dependencies: MdeModulePkg[21..]

Origin: TianoCore.org tag edk2-stable201811

Remove Perf code references
- BdsBoot.c, GenericBdsLib.inf, InternalBdsLib.h
- Delete Performance.c

Updated to use BmpSupportLib
- BdsConsole.c, GenericBdsLib.inf, InternalBdsLib.h

Update ConfigRouting function for UEFI Compliance
- LegacyBootMaintUi.c

LZMA upgrade to version 18.05

Code cleanup

IntelFrameworkModulePkg_12 (02/08/2019)

Dependencies: MdeModulePkg[21..]

Origin: TianoCore.org tag edk2-stable201811

Remove Perf code references
- BdsBoot.c, GenericBdsLib.inf, InternalBdsLib.h
- Delete Performance.c

Updated to use BmpSupportLib
- BdsConsole.c, GenericBdsLib.inf, InternalBdsLib.h

Update ConfigRouting function for UEFI Compliance
- LegacyBootMaintUi.c

LZMA upgrade to version 18.05

Code cleanup

IntelFrameworkModulePkg_11 (11/14/2018)

Dependencies: MdeModulePkg[14..]

Origin: TianoCore.org revision 996bd35.2017-11-15.

BaseUefiTianoCustomDecompressLib: additional buffer overrun checks are added (EIP 393928)

USRT 1863, edk2 bz 686 and 1317

NOTE: The library is typically not used in Aptio project.

IntelFrameworkModulePkg_10 (12/05/2017)

Dependencies: MdeModulePkg[14..]

Origin: TianoCore.org revision 996bd35.2017-11-15.

Improvements to several libraries not used in Aptio projects.

LZMA SDK is upgraded to version 16.04 (Aptio uses LZMA library from MdeModulePkg)

LegacyBootManagerLib is updated to use ARRAY_SIZE macro introduced in MdePkg_15

Other minor improvements

IntelFrameworkModulePkg_09 (12/19/2016)

Dependencies: MdeModulePkg[14..]

Origin: TianoCore.org revision eab2678.2016-09-27

Improvements to several libraries not used in Aptio projects.

Ps2Policy.h protocol is moved to MdeModulePkg(the protocol is not used in Aptio)

PcdS3BootScriptStackSize and several PCD tokens not used in Aptio projects are moved to MdeModulePkg

In order to maintain backward compatibility PcdS3BootScriptStackSize is also

retained in IntelFrameworkModulePkg.dec

IntelFrameworkModulePkg_08 (9/22/2016)

Dependencies: MdeModulePkg[14..]

Origin: TianoCore.org revision 18783.

Bug fix in LegacyBootManagerLib(EIP 268022).

Memory leak in LegacyBmRefreshBbsTableForBoot is fixed

Bug fix in GenericBdsLib(EIP 275097)

Memory leak in BdsLibEnumerateAllBootOption is fixed

Minor bug fix in LegacyBootMaintUiLib.inf and LegacyBootManagerLib.inf(EIP 291851)

A couple og INF files had references to non-existent uni files

References to non-existent files are removed

IntelFrameworkModulePkg_07 (12/24/2015)

Dependencies: MdeModulePkg[14..]

Origin: TianoCore.org revision 18783.

Non-backward compatible changes:

LzmaDecompress.h is moved from IntelFrameworkModulePkg to MdeModulePkg.

Projects that use LZMA compressions must upgrade to MdeModulePkg_14 or newer.

Updates to BDS libraries that are not used in Aptio.

Category is changed from ModulePart to eCore

Component dependencies are listed in the cif file

IntelFrameworkModulePkg_06 (12/3/2014)

Dependencies: None

Origin: TianoCore.org revision 16220.

Minor improvements.

Comment Updates in multiple files

PACKAGE_VERSION in IntelFrameworkPkg.dec is updated to 0.94

Updates in GenericBdsLib and PlatformBdsLibNull. Both libraries are not used in Aptio V.

IntelFrameworkModulePkg_05

Dependencies: None

Origin: TianoCore.org revision 15327.

LZMAF86 decompression support(EIP 148868)

LZMAF86 is a flavor of the LZMA compression algorithm optimized for IA32/X64 instruction set.

The support is enabled via LZMAF86_SUPPORT SDL token.

NOTE: To use LZMAF86, AmiPkg_12 or newer is required.

NOTE: During firmware recovery both old and new images must use the same compression scheme.

New INTEL_FRAMEWORK_MODULE_PKG_VERSION SDL token is added to track package version.

Minor improvements.

Updates to a GenericBdsLib and DxeCapsuleLib which are not used in Aptio V.

IntelFrameworkModulePkg_04

Dependencies: None

Origin: TianoCore.org revision 14733.

Minor improvements.

Updates to a GenericBdsLib which is not used in Aptio V.

© American Megatrends Inc.